Unable to send New messages - Exchange 2007

Jpiggeesr
Jpiggeesr used Ask the Experts™
on
Hello all. I am unable to send new messages. If I reply to an email, it goes out fine, but if I create a new message it gets stuck in the queue.
The error is 4.51 4.4.0 Primary IP Address responded with 421 4.2.1 "Unable to Connect"
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Expert of the Quarter 2009
Expert of the Year 2009
Commented:
The error means what it says, the server cannot connect.
Is that happening for all emails? Do you route email out directly by DNS or through another server as a smart host?

Simon.

Author

Commented:
Yes, I route my mail through a smarthost, SMTP.SECURESERVER.NET

I also tried using the IP address of the smart host. I am able to ping and resolve the smart hosts address on the server.
Expert of the Quarter 2009
Expert of the Year 2009

Commented:
Ping means squat. As a troubleshooting tool it is the equivalent of shouting "is there anyone there" and getting back the reply of yes.

Are you allowed to use that smart host? It looks like GoDaddy's server, which I don't think can be used for outbound email. If you need to use a smart host then use your ISPs SMTP server.

Simon.
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
But I have my domain through Godaddy and that is the SMTP mx record listed.
==========
I digress though, I followed your suggestion and added AT&T's smtp address, (the following address lists most ISP's SMTP servers) http://www.host45.com/resources/ispsmtps.php

I get the exact same error
Expert of the Quarter 2009
Expert of the Year 2009

Commented:
The fact that you have your domain with GoDaddy and that the server is listed as the MX record does NOT mean you can use it as a smart host. Not all SMTP servers are equal - that server is for inbound email only, not outbound.

I would verify whether you can connect to any remote servers on port 25. If you cannot then the port is blocked. That could be locally by an AV product or a firewall or by your ISP.

telnet server.example.com 25

(replacing server.example.com with the host name you are testing).
You should be able to connect to your ISPs smart host - if not then it is local block.
If you can, then try a remote server, such as maila.microsoft.com. If that fails then the ISP is probably blocking port 25 outbound.

Simon.

Author

Commented:
When I do attempt to telnet to any server on port 25, all I get is a blank screen with a blinking cursor. is that normal?
Expert of the Quarter 2009
Expert of the Year 2009

Commented:
No.
That means the port is being blocked. If you cannot telnet to even your ISPs SMTP Server then something local is blocking the port.

For example, the telnet test to Microsoft should return this:

220 mail01.microsoft.com Microsoft ESMTP MAIL Service ready at Mon, 20 Jul 2009 11:18:24 -0700

(or something very close to it, depending which server responds).

Simon.

Author

Commented:
Ok. I changed the smtp port to 587 using the following command in Exchange Shell:
set-sendconnector "Internet Email" -Port 587
I will send a few test messages
Expert of the Quarter 2009
Expert of the Year 2009

Commented:
Port 587 will only allow you to connect to a smart host. If you want to send email directly then you will need to use port 25. Furthermore you cannot receive email on that port - inbound email will only come in on port 25.

Simon.
Changed the send connector to use the DNS setting on the NIC, and changed the DNS settings on the card to point to external DNS server

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial