MSExchangeTransport Error within Application Logs SBS 2008

spencerburke
spencerburke used Ask the Experts™
on
New deployment of SBS2008.  I initially built it up in my lab, and then once I deployed...changed the physical IP address of the server...which I learned the hard way wasn't the best practices for SBS 2008.  After going through and fixing most the apparent errors...everything appears to be up and running.  I also added a Network Solutions SSL certi to the remote.xxxxxx.com, it also appears to be up and running with OWA and Remote Web Workplace...but in the applications log I am getting the following error:
Microsoft Exchange could not load the certificate with thumbprint of 5E6BA9FBEE154F35A98FBF14C2C81A865F69B098 from the personal store on the local computer. This certificate was configured for authentication with other Exchange servers. Mail flow to other Exchange servers could be affected by this error. If the certificate with this thumbprint still exists in the personal store, run Enable-ExchangeCertificate 5E6BA9FBEE154F35A98FBF14C2C81A865F69B098 -Services SMTP to resolve the issue. If the certificate does not exist in the personal store, restore it from backup by using the Import-ExchangeCertificate cmdlet, or create a new certificate for the FQDN or the server enabled for SMTP by running the following command: New-ExchangeCertificate -DomainName serverfqdn -Services SMTP. Meanwhile, the certificate with thumbprint D70ABEFE013E855B07512BBDCDE2FC823F79AE42 is being used.

I have read through several other posts with similar issues, but I was unable to solve the issue.  Before I migrate our email accounts over from the old SBS2003 server and move this into production...I would like to fix this error...because all I am not quite sure what potential problems it may cause?  When I run get-exchangecertificate from within Exchange Management Shell is don't see that cert...but I am not sure, should I use the remote.xxxxxxx.com cert? or one of the other ones?  and I am not sure of what command to use to replace this one and eliminate the error.

[PS] C:\Windows\System32>get-exchangecertificate

Thumbprint                                Services   Subject
----------                                --------   -------
C519138C58AC51696C3334A56E36FAA5BB68B90D  ...WS      CN=remote.xxxxxxx.com, O...
1A8CFD74517E1AD71C092C97D0AC25D14EDED144  IP...      CN=TSSBS09.techsol.local
D70ABEFE013E855B07512BBDCDE2FC823F79AE42  IP..S      CN=Sites
F7B689599091F6EA906F6017BEEFD7D5F117ADC4  .....      CN=techsol-TSSBS09-CA
EEA5A46027AB9C8DEB888C0B82374B552257E447  .....      CN=WMSvc-WIN-5UG5VW04Q5V
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
I figured since it wasn't in production, that I would just try enable-exchangecertificate -thumbprint D70ABEFE013E855B07512BBDCDE2FC823F79AE42 -services SMTP, reboot and see what happened...and so far so good...so I think I have fixed the issue...unless someone can verify that this was not the correct or best way to fix the apparent issue?  Thank you.
No thats it.You must enable other certificate for OWA as well i mean "IIS"
enable-exchangecertificate -thumbprint <PRINT> -services IIS
------
consultkhan

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial