SCCM standard reports are very limited in size - don't understand why.

Mo_Khimani
Mo_Khimani used Ask the Experts™
on
We use SCCM to execute fairly standard reports, such as "Count of all instances of software registered with Add or Remove Programs". SCCM failed to report on a not-too-large quantity of data. Running the same report in 2 parts (with Publisher beginning with A-M, then beginning N-Z (we allowed for others separately)) completed successfully. My question is why SCCM failed to report on a 5800 row, 5 field report, which I didn't think was excessive for it to cope with. Moving ahead we'll need to use SCCM to report on details at a workstation level - if it's reporting capability is severly limited then I can foresee much repetitive work to first fragment then assemble the desired reports. Not good! Please help us understand what we can do better.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
There are three things you may need to modify to allow large reports to work in configmgr

The first is to modify the maximum row count returned, by default its 10,000
http://technet.microsoft.com/en-us/library/bb680885.aspx

The second is to modify the ASP Buffering Limit .. by default its 4MB .. the below steps (from http://support.microsoft.com/kb/925764 will set it to 64MB)

To increase the buffering limit, follow these steps:
Click Start, click Run, type cmd, and then click OK.
Type the following command, and then press ENTER:
cd /d %systemdrive%\inetpub\adminscripts
Type the following command, and then press ENTER:
cscript.exe adsutil.vbs SET w3svc/aspbufferinglimit LimitSize
Note LimitSize represents the buffering limit size in bytes. For example, the number 67108864 sets the buffering limit size to 64 MB.

Finally, you may need to change the ASP Script Timeout for the Virtual Dir, which is 90 Seconds by default (I set my to 180 seconds, and get that seems to work for all my reports)

Open up the Properties of the SMSReporting_<SITECODE> virtual directory in IIS Manager
Click on the Configuration button in the Application Settings
Click on the Options Tab, and set the vault of ASP Script Timeout to 180

Author

Commented:
Hi Jon, thanks again for another solution. Sorry for delay. Initially got following problem: Type mismatch
ErrNumber: 13 (0xD)
Error Trying To SET the Property: aspbufferinglimit
But something was fixed on the server and now we can obtain larger reports in one go without straining SCCM's capability. Top Man!

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial