Outlook/Exchange 2007 Out of Office not working. Neither is Test Email AutoConfig.

adminknight
adminknight used Ask the Experts™
on
Working thru most questions and posts about the OOF not working in Outlook 2007 on an Exchange 2007 server say first thing to test email autoconfig in Outlook. When I do instead of getting a list of info, i get a message that say:
Autoconfiguration was unable to determine your settings!

I'm reading white papers and studying up on Exchange as I'm a bit rusty. Could use some help though.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Expert of the Quarter 2009
Expert of the Year 2009

Commented:
There can be many reasons why autodiscover doesn't work.
Has it ever worked?
Do you have a commercial SSL certificate in place?
Has anything been changed on the server

Internally, on the domain, autodiscover should come off the domain, so name resolution of autodiscover.example.com shouldn't be a problem.

You haven't really provided enough information to work on.
Multiple servers, anything unusual about the configuration?

This blog posting has a good write up, but the images are broken.
http://www.exchange-genie.com/2007/07/exchange-2007-autodiscover-service-part-1/

Simon.
what does it return when you run from the exchange shell

test-outlookwebservices username | fl

Author

Commented:
Worked for about a year.
No changes made to or in exchange
No commercial SSL
Single domain, single server



Badgermike: Results

Id      : 1003
Type    : Information
Message : About to test AutoDiscover with the e-mail address myemail.email.com
         

Id      : 1013
Type    : Error
Message : When contacting https://FQDN.domain.com/Autodiscover/Autodiscover
          .xml received the error The underlying connection was closed: An unex
          pected error occurred on a send.

Id      : 1013
Type    : Error
Message : When contacting https://FQDN.domain.com/Autodiscover/Autodiscover
          .xml received the error Authentication failed because the remote part
          y has closed the transport stream.

Id      : 1006
Type    : Error
Message : The Autodiscover service could not be contacted.


Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

do you have outlook web access enabled....I mean can you log into owa without issue?

Also what happens in an outlook client when you hit send receive - download address book - global address list?

Also if you could post the return of:

get-webservicesvirtualdirectory | fl

Author

Commented:
OWA is not enabled.
When downloading GAB

Task 'Microsoft Exchange' reported error (0x8004010F) : 'The operation failed. An object cannot be found.'

Results of get-webservicesvirtualdirectory

InternalNLBBypassUrl          : https://FQDN.domain.com/ews/exchange.asmx
Name                          : EWS (Default Web Site)
InternalAuthenticationMethods : {Ntlm, WindowsIntegrated}
ExternalAuthenticationMethods : {Ntlm, WindowsIntegrated}
BasicAuthentication           : False
DigestAuthentication          : False
WindowsAuthentication         : True
MetabasePath                  : IIS://FQDN.domain.com/W3SVC/1/ROOT/EWS
Path                          : E:\Program Files\Microsoft\Exchange Server\Clie
                                ntAccess\exchweb\EWS
Server                        : EXCHANGE
InternalUrl                   : https://FQDN.domain.com/EWS/Exchange.asmx
ExternalUrl                   :
AdminDisplayName              :
ExchangeVersion               : 0.1 (8.0.535.0)
DistinguishedName             : CN=EWS (Default Web Site),CN=HTTP,CN=Protocols,
                                CN=EXCHANGE,CN=Servers,CN=Exchange Administrati
                                ve Group (FYDIBOHF23SPDLT),CN=Administrative Gr
                                oups,CN=OURCN,CN=Microsoft Excha
                                nge,CN=Services,CN=Configuration,DC=DOMAIN,DC=COM
Identity                      : EXCHANGE\EWS (Default Web Site)
Guid                          : fae40b6e-7cc9-4df2-a332-04b6d58665f8
ObjectCategory                : domain.com/Configuration/Schema/ms-Exch-Web-Ser
                                vices-Virtual-Directory
ObjectClass                   : {top, msExchVirtualDirectory, msExchWebServices
                                VirtualDirectory}
WhenChanged                   : 6/5/2008 3:51:21 PM
WhenCreated                   : 4/29/2008 9:54:39 AM
OriginatingServer             : DCXX.domain.com
IsValid                       : True
is this an internal client or an external remote client?

Author

Commented:
all internal.
I can't see anything in your webservice test - other than that people say it could be a cert error or if asp.net registered for 32 bit instead of 64....

Anyway

I had the exact same error that I had to fix by:

Uninstall IIS/Reinstall IIS....Uninstall CAS server role/Reinstall CAS role/Rebuild the virtual directories via emc.

for our setup I had to also rebuild legacy virtual directories via emc for our one mac that works off the old /exchange directory, enable webdav in IIS extensions for the entourage client, and since we use the anti-spam agents I had to uninstall/reinstall them.

We have one exchange server with all roles  well except for edge.

I was trying my best to research the solution, when we had the issue I spent like 2 weeks, I just spent about an hour and a half and didn't find anything I was hoping too because I though since I fixed months ago there should be something better than a CAS reinstall but I can't find it. I wish I could have saved you some time. Hopefully someone out there has something better. It took a couple hours to complete and did the trick ....Good luck to you....

.

Author

Commented:
Reinstall of IIS: Anything special to it on an Exchange server? Do I need to do anything before i uninstall or after I reinstall?

The CAS role. What is involved with reinstalling it?

Author

Commented:
Found this:
http://support.microsoft.com/kb/320202
Only question is when recreating virtual directories do I use FQDN or not?
Expert of the Quarter 2009
Expert of the Year 2009

Commented:
If you are going to reinstall IIS, and then CAS, after doing so I would test it again before making any changes to the system. Autodiscover should work internally correctly without any changes to the Exchange configuration.

Simon.
Here is the documentation that I used to unistall ISS and CAS and then reinstall if you are going that route.

http://support.microsoft.com/kb/320202

Scroll down to the Exchange 2007 portion.

I followed everthing to a T - the only non standard things for me that popped up were renabling webdav - for our entourage user / and the reinstall of the antispam agents.



Author

Commented:
Badgermike, that's the same one I posted above. I just was curious before I started it mentions at the bottom, under Recreating Virtual Directories to use the server and DC name. Do I use FQDN or not?
Sorry I was typing to fast - I did not use FDQN -

Issue wasn't IIS, was an issue with the certificates. Working now. Thanks for the info though.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial