IE8 default search provider issue on Citrix / TS

darth_wannabe
darth_wannabe used Ask the Experts™
on
I have a citrix presentation server 4.0 farm of 12 servers (MS Windows Server 2003). These servers host a number of apps for us. Our users have terminal services profiles set up, but the profiles get cleared / deleted every night to prevent issues with our core app.

Since installing IE 8 on the servers, our users now always recieve the following error the first time they launch IE: "A Program on your computer has corrupted your default search setting for Internet Explorer. Internet Explorer has reset this setting to your original search provider. Internet Explorer will now open Search Settings, where you can change this setting or install more search providers."

After clicking ok, the search providers dialog box opens, where they have to click close.

After the first time, they do not recieve the error again on that server until the next day after the profile has been deleted and they log in for the first time again. Our users are launching IE to use an online app that is required for our business, and this error is a pain. I have the search box hidden via group policy, and they will not ever use this IE instance to search anyway.

Is there a way that I can prevent this error from popping up for the users? I suspect it is something in the user profile, as I can reliably recreate the issue be deleting the profile and launching IE again.

FYI, the solutions at http://blog.kirb.us/2009/03/20/a-program-on-your-computer-has-corrupted-your-default-search-provider-setting-for-internet-explorer/ do not apply.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2008
Commented:
Since you are deleting the profiles each night, then I think the easiest solution is to fix the default user profile.

Log in with an admin account, open IE 8 and go through your process of closing the pop up windows (or select a default search provider that you want) and then log off.  Log in with another admin account and copy this profile to the default profile (the default profile is hidden so you will have to be able to see hidden profiles).  Log back in as another user that hasn't logged in yet and see if it works.

I haven't used IE8 yet inside of citrix but I think this will solve your problem.  Test it on one server and if it works you can do the same with the rest.

Author

Commented:
Looks like if I copy just the NTUSER.DAT file from a profile that has been through this setup into the default user profile, the problem goes away. Who's brilliant idea was it to put IE settings in NTUSER.DAT? Wouldn't it be better to put all that someplace we can get at it and change it if we need to? Like in the registry or a config file somewhere?

This definitely fixes my current issue. Seems there should be a better way to do it though. I get concerned about changing the default profile...

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial