USB mice no longer work, any suggestions?

mousemen
mousemen used Ask the Experts™
on
I have a computer that no longer works with USB mice on a Windows XP computer. I have tried multiple mice with it, and thumb drives and other USB devices work just fine. I have already tried doing a repair install twice with different service packs on both discs, as well as running Re-image on it. I even went in and manually copied over the files that the mouse is trying to use from a XP install disc in Recovery Console. Any other suggestions besides formatting the computer?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2013

Commented:
mousemen--I assume you tried other USB ports.
Did software come with the mice?  Did you use it?
Does a PS2 mouse work?
Do you have any errors in your device manager?
Top Expert 2013

Commented:
does the mouse show in device manager?
any errors there?
is it a wireless mouse?
11/26 Forrester Webinar: Savings for Enterprise

How can your organization benefit from savings just by replacing your legacy backup solutions with Acronis' #CyberProtection? Join Forrester's Joe Branca and Ryan Davis from Acronis live as they explain how you can too.

Author

Commented:
I have tried all USB ports, yes.  It is a non-wireless Microsoft mouse, so I downloaded Microsoft Intellipoint drivers and software to see if that would work, but no luck there either. I have tried multiple other mice as well, but none of them work. This is a laptop computer, and there is no PS/2 port, sadly. It does show up in device manager, with an error that says it is having trouble loading the drivers. It is trying to load these files: hidclass.sys, hidparse.sys, hidusb.sys, hid.dll.
I have manually replaced all of these with copies off a XP install disc once already, but it did not help.
Top Expert 2013

Commented:
Remove old hardware devices :
go to Start>right click My computer>properties>device manager
in the view tab - click : "show hidden devices"
inspect  device manager for all hidden devices, and remove them

Commented:
Try this batch script:

@ECHO OFF
:: Check Windows version
IF NOT "%OS%"=="Windows_NT" GOTO Syntax
IF     "%OS%"=="Windows_NT" SETLOCAL
VER | FIND "Windows NT" >NUL && GOTO Syntax

:: Check command line arguments -- none required
IF NOT "%~1"=="" GOTO Syntax

:: Check if DEVCON.EXE is available and if not, prompt for download
SET DevconAvailable=
SET Download=
DEVCON.EXE /? >NUL 2>&1
IF ERRORLEVEL 1 (
      SET DevconAvailable=No
      ECHO This batch file requires Microsoft's DEVCON untility.
      SET /P Download=Do you want to download it now? [y/N]
)

:: Start download if requested
IF /I "%Download%"=="Y" (
      START "DevCon" "http://support.microsoft.com/default.aspx?scid=kb;EN-US;Q311272"
      ECHO.
      ECHO Install the downloaded file and make sure DEVCON.EXE is in the PATH.
      ECHO Then try again.
)

:: Abort if DEVCON.EXE is not available yet
IF "%DevconAvailable%"=="No" GOTO End

:: List and remove all USB devices
>> RenewUSB.dat ECHO.%Date%, %Time%
DEVCON FindAll =USB | FIND ":" >> RenewUSB.dat
FOR /F "tokens=1 delims=:       " %%A IN ('DEVCON FindAll ^=USB ^| FIND ":"') DO DEVCON Remove "@%%A"
DEVCON FindAll USB* | FIND ":" >> RenewUSB.dat
FOR /F "tokens=1 delims=:       " %%A IN ('DEVCON FindAll USB*  ^| FIND ":"') DO DEVCON Remove "@%%A"

:: Rescan for new hardware
DEVCON ReScan

:: Done
ENDLOCAL
GOTO End

:Syntax
ECHO.
ECHO RenewUSB.bat,  Version 1.00 for Windows 2000 / XP
ECHO Use DEVCON to remove all USB devices and then scan for new devices
ECHO.
ECHO Usage:  RENEWUSB
ECHO.
ECHO Notes:  [1] This batch file requires Microsoft's DEVCON.EXE, available at
ECHO             http://support.microsoft.com/default.aspx?scid=kb;EN-US;Q311272
ECHO             You will be prompted for download if it isn't found.
ECHO         [2] I tested this batch file on my own PC running Windows 2000 Pro SP4.
ECHO             However, I cannot guarantee flawless operation on any other PC.
ECHO             Use this batch file entirely at your own risk. Make sure you have
ECHO             a recent full backup available in case something might go wrong.
ECHO         [3] Before removal each USB device is logged in RENEWUSB.DAT.
ECHO.
:End

Author

Commented:
The hidden device trick did not work.
And the batch file ran just fine, then it blue screened on bootup with a 0xC2. On next reboot it booted up fine, but the problem continues with it not recognizing mice.
I have backed up the data because I am starting to think that I will have to format it.

Commented:
Try creating a new user and see if it works there, or on safe mode and check if it works with the administrator acount

Commented:
If not, try with your installation CD to repair, when you enter in console try this command:
chkdsk /r
maybe this can solve your problem.
Commented:
Well, I had already run chkdsk, after running the hard drive test because I also thought it might be some kind of corruption. Running in Safe mode under the admin account yields the same result.  I have decided to format the computer because I am running out of time. Thank you for all of your help xpertoPC and others. It works just fine after the format.

Commented:
ok, no problem, but the chkdsk /r under Repair option with the install disc in console is diferent from windows chkdsk, probably would solved your problem, good that your mouse is working again.

C ya!

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial