How to reset a Cisco 1720 ... that has the console port locked

robertbranch
robertbranch used Ask the Experts™
on
I have a Cisco 1720 that was taken out of production about 1 year ago.  I need to use it for a few weeks and when I attempted to access it via the colsole port I get this:

Cisco1720 con0 is now available

Press RETURN to get started.

When I press return I get this:

% Authentication failed.

The it goes back to Press RETURN to get started.

I was going to try and reset the passwords, but the router will not accept any for of the BREAK command (I used the Cisco Reference).

Any help on resetting this would be greatly appreciated.  I'd like to save the config, but I am wiling to start from scratch if I can just get started.

Thanks!
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Wow there's some help right on EE:
http://www.experts-exchange.com/Hardware/Networking_Hardware/Routers/Q_23222850.html

However, it appears that even that won't work based on what you are getting, because you should be able to get a password: or user: prompt when you hit return.

Have you tried telneting into the box?  The ususal default password in any event is "cisco"

Here's some general help on that box too.

http://www.cisco.com/en/US/docs/routers/access/1700/1720/hardware/installation/guide/trbshoot.html

Also, other cisco boxes have a reset button, which when held in during power on will wipe things to factory.  I don't know if that box has such a button or not.

Istvan KalmarHead of IT Security Division
Top Expert 2010

Commented:
Step 1 Connect an ASCII terminal or a PC running a terminal-emulation program to the CONSOLE port on the rear panel of the router. Refer to the section "Connecting a PC" in the "Installing the Cisco 1700 Router" chapter.

Step 2 Configure the terminal to operate at 9600 baud, 8 data bits, no parity, and 1 stop bit.

Step 3 Reboot the router by pressing the power switch to the OFF position, then to the ON ( | ) position.

tep 5 Record the setting of the configuration register. It is usually 0x2102 or 0x102.

Step 6 Record the break setting.

"Break enabledbit 8 is set to 0.

"Break disabled (default setting)bit 8 is set to 1.

Note To enable break, enter the config-register 0x01 EXEC command.
Reset the Router

Step 1 Do one of the following:

"If break is enabled, go to Step 2.

"If break is disabled, turn the router OFF, wait 5 seconds, and turn it ON again. Within 60 seconds, press the Break key. The terminal displays the ROM monitor prompt. Go to Step 3.

Step 2 Send a break. The terminal displays the following prompt:

rommon 2>


Step 3 Enter confreg 0x142 as follows to reset the configuration register:

rommon 2> confreg 0x142


Step 4 Initialize the router by entering the reset command:

rommon 2> reset


The router resets, and the configuration register is set to 0x142. The router boots the system image in Flash memory, and displays the following:

--- System Configuration Dialog ---


Step 5 Enter no in response to the prompts until the following message is displayed:

Press RETURN to get started!


Step 6 Press Return. The following prompt appears:

Router>


Step 7 Enter the enable command to enter privileged EXEC mode. Configuration changes can be made only in this mode:

Router> enable


The prompt changes to the privileged EXEC prompt:

Router#


Step 8 Enter the show startup-config command to display an enable password in the configuration file:

Router# show startup-config

tep 1 Enter the configure terminal command to enter configuration mode:

Router# configure terminal


Step 2 Enter the enable secret command to reset the enable secret password in the router:

Router(config)# enable secret gobbledegook


Step 3 Enter the config-register command and the original configuration register value that you recorded in Step 5.

Step 4 Press Ctrl-Z to exit configuration mode.

Router(config)# Ctrl-Z


Step 5 Save your configuration changes:

Router# copy running-config startup-config

Reset the Configuration Register Value

Once you have recovered or reconfigured a password

Step 1 Enter the configure terminal command to enter configuration mode:

Router# configure terminal


Step 2 Enter the config-register command and the original configuration register value that you recorded in Step 5.

Step 3 Press Ctrl-Z to exit configuration mode:

Router(config)# Ctrl-Z


Step 4 Reboot the router, and enter the recovered password.

Author

Commented:
Unfortunately, neither of the links were any help I had already been through those.

The issue is I can't get to any prompt on the console port.  I cannot use the BREAK command to get to rommon.  

I can telnet to the box, but the passwords were not documented.
Commented:
If you reboot the router, does it show all the bootup messages?  Can you see the configuration register setting?

Even if break is disabled, it will work if you use it within 60 seconds of power on.

Is it possible that your terminal emulation program isn't really sending a break?

Author

Commented:
The issue did turn out to be the USB/Serial adapter not actually sending the BREAK ... I swapped to a laptop with an actual serial port and suddenly everything worked as promised!  

Thanks!!

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial