USB-devices not showing in Explorer

ISDNO
ISDNO used Ask the Experts™
on
Hi,
The Toshiba laptop in question has the following problem.
1: If you connect _Any_ usb storage device (Like a usb pen) the WinXP os will make all the "correct sounds" and it will list the storage unit as a "Usb mass storage" in the device manager. However it does not show up in Disk Management and not in Explorer.
2: If you connect an iPhone the iPhone will start charging so the USB-connection seems to be fine.

I have tried cleaning out any non-essential disk in Reg\HKLM\System\MountedDevices, I'we tried Uninstalling everything under USB (Including 0 hidden) via Device Manager.

Eventlog error1 and 2 included (Eventlog's in a foreign laguage, so ill try to translate):

For what it's worth iwe tried unplugging/rebooting/checking Disk Management several times (This is usually the problem when i come across this problem).

Thanks in advance.
Error 1:
 
Hendelsestype: Advarsel
Hendelseskilde: Removable Storage Service
Hendelseskategori: Ingen
Hendelses-ID: 128
Dato: 20.07.2009
Klokkeslett: 14:01:32
Bruker: I/T
Datamaskin: XXXX
Beskrivelse:
Enhetsnummeret for disk drive kan ikke bestemmes. Denne enheten ble ikke konfigurert. Denne hendelsen kan bli logget flere ganger for samme enhet.
Hvis du vil ha mer informasjon, se Hjelp og støtte på http://go.microsoft.com/fwlink/events.asp.
 
Error 1 Translated:
 
Event ID 128 Source Removable Storage Service
Event ID 128 
Source Removable Storage Service 
Type Warning 
Description The device number of a(n)<device> cannot be determined. This device failed to configure. This event may be logged several times for the same device. 
 
Error 2:
 
Hendelsestype: Feil
Hendelseskilde: LDMS
Hendelseskategori: Ingen
Hendelses-ID: 3023
Dato: 20.07.2009
Klokkeslett: 14:01:26
Bruker: I/T
Datamaskin: XXXX
Beskrivelse:
Logical Disk Manager Service mislyktes under registrering for enhetsvarslinger på enheten \\?\storage#removablemedia#7&2e9c42da&2&rm#{53f5630d-b6bf-11d0-94f2-00a0c91efb8b}. Win32-feil: 1381
 
Error 2 Translated:
 
The Logical Disk Manager Service failed while registering for device handle
notifications on device \\?\storage#removablemedia#7&2e9c42da&2&rm#{53f5630d-b6bf-11d0-94f2-00a0c91efb8b}. Win32-feil: 1381

Open in new window

Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Did you try reinstalling the USB drivers?

Author

Commented:
The computer is a Lifebook E8410, not a Toshiba.
Iwe searched FUjitsu Siemens's webpages using the Serial of the computer but cannot find any USB related downloads. As I write in my first post i have tried letting the OS find the USB-devices "from fresh" by uninstalling them. Am I missing something here?
Top Expert 2013
Commented:
try these :
-update your chipset driver, from the FUjitsu Siemens's webpages
-Remove old hardware devices :
go to Start>right click My computer>properties>device manager
in the view tab - click : "show hidden devices"
inspect  device manager for all hidden devices, and remove them

-http://support.microsoft.com/kb/925196

OR :
Remove all USB drivers with:     https://filedb.experts-exchange.com/incoming/ee-stuff/6853-RENEWUSB.zip      ---> Now reboot and test.
Delete the "UpperFilters" and "LowerFilters" registry values from:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{36FC9E60-C465-11CF-8056-444553540000}

you can also reset the usb :
rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 C:\WINDOWS\inf\usbstor.inf
rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 C:\WINDOWS\inf\usb.inf
rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 C:\WINDOWS\inf\usbport.inf
rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 C:\WINDOWS\inf\usbprint.inf
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Check in Disk Managment what letters are assigned to usb devices after you plug them in. Maybe the system is assigning the letter which is already in use. In this case just change the letters.

Author

Commented:
I have now tried Nobus's tips (The "OR" part with the downloadable)
I ran  RenewUSB and rebooted. No luck.
I ran RMHIDDEV and rebooted. No luck.
I did not find any Lower- or UpperFilters' values in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{36FC9E60-C465-11CF-8056-444553540000}
I then resetted the usb and rebooted.

Still same problem :(
Top Expert 2013

Commented:
what avbout trying the upper part ?

Author

Commented:
I'm sorry I completely ignored the part with Chipset Drivers.
Will try this now (Newer version is not avaiable but will try to reinstall)
Does the RenewUSB do "the same" as "Remove old hardware devices" manually via the device manager?
Either way I will check and uninstall any hidden device.

Author

Commented:
Tried to install Chipset Drivers from both FujitsuSiemens and directly from Intel - the installations finished up fast and neither of them solved the problem after a reboot. The computer did not have any hidden usb devices.

However, as the computer is generally slow and the user is going away on holiday I'll reinstall windows. Will let you know if that doesn't solve the problem. Thanks for all the help!

Author

Commented:
Even tho this did not solve the problem it's a solid guide to troubleshooting usb-problems.
Top Expert 2013

Commented:
that will solve all problems, except hardware ones !

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial