Can't create a new user or database within 2008 database engine

dbhatoa
dbhatoa used Ask the Experts™
on
Hi,

 I've just installed sql server 2008. When running the management studio I get the option of connecting to the database engine or sql server compact edition.

 When I go to connect to the database engine with a local or domain administrator account, I can't create a new database -
I get the error message

"create database permission denied in database "master"" error 262

When I go to security, create new login and try to give my user domain user access to dbcreator I get another permission denied error (15247).

 I've tried logging on with the sa default username and password, but no luck.

 In short, I can't create a database and can't give myself permissions to do so.

Please help.

tx
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Raja Jegan RSQL Server DBA & Architect, EE Solution Guide
Awarded 2009
Distinguished Expert 2018

Commented:
Is there by any change your OS is Vista or Windows Server 2008?

Because in the above OS, Local administrators wont have access/ privilege to the database by default.
You have to elevate the Local administrator or other users to grant them privileges.

Kindly follow steps mentioned in "To add a Windows user that has the login "domainname \username" to the sysadmin fixed server role " topic in the link below

http://msdn.microsoft.com/en-us/library/bb326612.aspx

Once this is done, you would be able to create database and users.
Hope this helps

Author

Commented:
I'm using Server 2003, unfortunately trying the steps didnt work

With my domain admin account I tried to give myself sysadmin permission only to be given SQL server error 15247

May have to re-install sql server 2008 :-(
Raja Jegan RSQL Server DBA & Architect, EE Solution Guide
Awarded 2009
Distinguished Expert 2018

Commented:
Kindly confirm under what account SQL Server service is running and check whether the user you try to connect have administrator privileges on that machine.

If not kindly use sa login to log in to the machine ( or ask your DB Admin instead) and add this user login and grant sysadmin privileges to your account.
Acronis in Gartner 2019 MQ for datacenter backup

It is an honor to be featured in Gartner 2019 Magic Quadrant for Datacenter Backup and Recovery Solutions. Gartner’s MQ sets a high standard and earning a place on their grid is a great affirmation that Acronis is delivering on our mission to protect all data, apps, and systems.

Sr DB Architect
Commented:
hi,

as per the question i understand that you logging using windows authentication which is not allowing you to create database.

try the following...

1. Go to Control Panel -> User Accounts and Family Safety -> User Accounts -> Turn User Account Control off

uncheck the box Use User Account Control (UAC) to make your computer more secure

Click OK

Vista will ask to restart.

if there is still an issue... try the following...

---

2. http://blogs.msdn.com/knom/archive/2007/03/02/sql-server-user-provisioning-tool-for-vista.aspx

---

if there is still an issue...

3. http://www.rajputbrotherhood.com/Database/SQL-Server/create-database-permission-denied-in-database-master-microsoft-sql-server-error-262-error-in-windows-vista.html

----

let me know if anything above worked...

Author

Commented:
rrjegan,

 SQL server is logged on as NT authority service\network service as shown in services.msc.

 I've tried to make that account a member of local admin group, but account not found in AD.

 jagdish,

 I'm using windows server 2003 for the OS (not Vista and hence no UAC), I'm using sql server 2008

tx
Jagdish DevakuSr DB Architect

Commented:
hi,

sorry i havn't checked that ... meanwhile why cant you try the 3rd step in previous post on windows 2003.

Author

Commented:
Run as local administrator worked, which I thought I tried earlier.

 Odd that domain admin doesn't have permission. All good, tx
Raja Jegan RSQL Server DBA & Architect, EE Solution Guide
Awarded 2009
Distinguished Expert 2018

Commented:
Can you kindly post what exactly helped you to solve this issue so that it would be helpful for others visiting here later on..

Author

Commented:
I managed to right click on the sql server management studio, then run as, run as the local administrator, (not domain), logged on via windows authentication to sql server contacting the local sql server

 that account had permissions to create a db, I could also click within logins to set permissions for existing users (such as sysadmin), as well as create new logins.
Raja Jegan RSQL Server DBA & Architect, EE Solution Guide
Awarded 2009
Distinguished Expert 2018

Commented:
Isn't the same thing I mentioned in my first comment 24902801

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial