Error Moving Mailbox Exchange 2003 to Exchange 2007.

Neos-IT
Neos-IT used Ask the Experts™
on
Receiving the following error when trying to migrate mailboxes from Exchange 2003:
Error was found for Username (User.Name@domain.co.uk) because: Error occurred in the step: Preparing mailbox to be moved. Failed to copy basic mailbox information with error: The Microsoft Exchange Information Store service could not find the specified object., error code: -1056749241
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
are Exchange 2003 and 2007 in the same forest and are all mailbox stores up an available.

Where are you doing the move mailbox from?  Exchange 2003 or 2007, ideally u should be using 2007

Author

Commented:
Yes, both machines are in the same forest.  We are moving from the old Exchange 2003 server to a new Exchange 2007 server.

We are using the Exchange 2007 Management tool on the Exchange 2007 server to "move" the mailbox from the Exchange 2003 Server to the Exchange 2007 Server.

I've attached a copy of the error code for further info

Thanks
Exchange Management Shell command attempted:
'pyv.local/PYV Limited/User Accounts/Standard Users/Paul Baverstock' | move-mailbox -TargetDatabase 'PYV-EXCHANGE\First Storage Group\Group A - PYV'
 
Elapsed Time: 00:00:11
 
<?xml version="1.0" ?> 
- <move-Mailbox> 
- <TaskHeader> 
<RunningAs>PYV\Administrator</RunningAs> 
<Name>move-Mailbox</Name> 
<Type>IntraOrg</Type> 
<MaxBadItems>0</MaxBadItems> 
<Version>8.1.240.6</Version> 
<StartTime>07/20/2009 15:14:02</StartTime> 
<Options Identity="" TargetDatabase="PYV-EXCHANGE\First Storage Group\Group A - PYV" IgnorePolicyMatch="False" GlobalCatalog="pyv01.pyv.local" DomainController="" MaxThreads="4" BadItemLimit="0" ValidateOnly="False" IgnoreRuleLimitErrors="False" ConfigurationOnly="False" /> 
</TaskHeader> 
- <TaskDetails> 
- <Item MailboxName="Paul Baverstock"> 
- <Source> 
<Identity>pyv.local/PYV Limited/User Accounts/Standard Users/Paul Baverstock</Identity> 
<DistinguishName>CN=Paul Baverstock,OU=Standard Users,OU=User Accounts,OU=PYV Limited,DC=pyv,DC=local</DistinguishName> 
<DisplayName>Paul Baverstock</DisplayName> 
<Alias>Paul.Baverstock</Alias> 
<LegacyExchangeDN>/o=PYV Limited/ou=First Administrative Group/cn=Recipients/cn=Paul.Baverstock</LegacyExchangeDN> 
<PrimarySmtpAddress>Paul.Baverstock@pyv.co.uk</PrimarySmtpAddress> 
<SourceServer>pyv02.pyv.local</SourceServer> 
<SourceDatabase>PYV02\First Storage Group\PYV Store - B</SourceDatabase> 
<IsResourceMailbox>False</IsResourceMailbox> 
<SourceGlobalCatalog>pyv01.pyv.local</SourceGlobalCatalog> 
<SourceDomainController>pyv01.pyv.local</SourceDomainController> 
</Source> 
- <Target> 
<TargetGlobalCatalog>pyv01.pyv.local</TargetGlobalCatalog> 
<TargetDomainController>pyv01.pyv.local</TargetDomainController> 
<TargetServer>PYV-EXCHANGE.pyv.local</TargetServer> 
<TargetDatabase>PYV-EXCHANGE\First Storage Group\Group A - PYV</TargetDatabase> 
</Target> 
<MailboxSize>3506947KB</MailboxSize> 
<Duration>00:00:10</Duration> 
<Result IsWarning="False" ErrorCode="-1056749241">Error occurred in the step: Preparing mailbox to be moved. Failed to copy basic mailbox information with error: The Microsoft Exchange Information Store service could not find the specified object.</Result> 
</Item> 
</TaskDetails> 
- <TaskFooter> 
<EndTime>07/20/2009 15:14:14</EndTime> 
<TotalSize>0B</TotalSize> 
<StandardMessagesDeleted>0</StandardMessagesDeleted> 
<AssociatedMessagesDeleted>0</AssociatedMessagesDeleted> 
<DumpsterMessagesDeleted>0</DumpsterMessagesDeleted> 
<Result ErrorCount="1" CompletedCount="0" WarningCount="0" /> 
</TaskFooter> 
</move-Mailbox>

Open in new window

the databases are available yeah?

Does it only happen with this user or all?
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
Yes all DB's are online and actually serving end users.

It happens with the three mailboxes we have tried:

1 - An ex-emplyee
2 - A new mailbox on the Exchange 2007 Server
3 - An Existing user

I have also created a new user and placed their mailbox on the Exchange 2007 Server.  We sent/received mail from that account both internally and externally and it all worked fine.

I checked the address books to ensure all these users are listed i.e. not hidden from any address lists.

It looks like an access rights issue to me, but I'm not sure where.

Rgds
Greg
Cool .. How many Exchange 2003 servers do you have?

Wonder if it is an Access control list (ACL) inheritance maybe blocked on the source Exchange server?

You can you run ExBPA on the Exchange 2007 server and make sure you download the latest update.

and - or -  
Run ADSIEdit and drill down to the source server.Right Click on the server object and choose properties.  Then choose the Security tab. Click the Advanced button and you should see the a inheritance dialog.

This should be checked



Author

Commented:
We and the ADSIEdit and it worked!

Thanks you for a quick response and solution.

All the best,
Greg
sweet .. hope you raised a change control before fixing it ;-)

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial