Error: no `server' JVM when trying to run JVM in server mode.

jdcredit
jdcredit used Ask the Experts™
on
I have JDK 1.6 update 14 installed on a Linux RedHat virtual server.  The server has one CPU and 2 gig of memory.   By default the JVM is running as client and I have been trying to determine if I can switch it to -server.  When I try java -server I get the error "Error: no `server' JVM"  Can I not run in server mode?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Are you sure you have the hotspot installed? It should be under .../JDK install/jre/bin/server/ If so, you may need to set your JAVA_HOME to this folder.
just try executing java and see what all the options listed. you should see -server, if not try installing again.

btw, hotspot is the synonym for -client. so it doesn't matter here!

Author

Commented:
I don't have a /usr/java/jdk1.6.0_14/jre/bin/server folder.  When I installed the JDK on my LInux servers this folder isn't there.  I looked at the Windows installation and it is there.  Do I need to download something different for Linux?

java -version says ithe following:
$ java -version
java version "1.6.0_14"
Java(TM) SE Runtime Environment (build 1.6.0_14-b08)
Java HotSpot(TM) Client VM (build 14.0-b16, mixed mode, sharing)

Announcing the Winners!

The results are in for the 15th Annual Expert Awards! Congratulations to the winners, and thank you to everyone who participated in the nominations. We are so grateful for the valuable contributions experts make on a daily basis. Click to read more about this year’s recipients!

yes, you need to download the linux build

Author

Commented:
I had installed the .bin (jdk-6u14-linux-i586.bin).  What do I need?  The only other option is jdk-6u14-linux-i586-rpm.bin

Commented:
did you try to install with yum? java-1.6.0-openjdk and java-1.6.0-openjdk-devel?

Author

Commented:
We don't have the option for Yum, so I went to Red Hat Network and looked for java-1.6.0-openjdk and it is only available for Red Hat v5.0 and we are will on 4.

Any other suggestions?

Author

Commented:
I downloaded and installed the jdk-6u14-linux-i586-rpm.bin and then installed the rpm that was created.  Now I am at least not getting the error message when I put in java -server.  Now I just need to figure out how to run in server mode (if possiible).
>> had installed the .bin (jdk-6u14-linux-i586.bin)

still not seeing -server option?

also is your Linux is 64bit, if so, you need to download appropriate linux build!

Author

Commented:
No, java -server now does not error out, but i am missing an arguement or something.  I had to install the RPM created jdk-6u14-linux-i586-rpm.bin was extracted.

when I run java -server, it just outputs the help information  
Commented:
I think it is correct. You need the usual arguments for your program: -cp ...jar MainClass

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial