Strange issue with locked files on file server

waktasz
waktasz used Ask the Experts™
on
From time to time I have an issue where users report they cannot move or rename a file, getting the error that it is currently in use.  I have checked the file server, and no active sessions exist pointing to these files.  I have also tried to use "Unlocker" software to forcefully close any open connections to the files, but the software says there are no locking handles on these files.  The only way to get these files to cooperate again is to reboot the file server.  

Does anyone have an idea what might be going on here?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Is it the same file or multiple files?  

Is it the same type of file (eg. spreadsheet) or different types?

Commented:
Hey,

Unfortenately i have had my fair share of locked files.. I beleive the way your went is the way to go.. Using a tool like unlocker. The only possible solution i ever found was rebooting the server and deleting the file then.. And i saw this happening with almost every single filetype, from PDF to tiff...

Just to clarify one thing, the file doesn't end with a . or a <space> right??

Author

Commented:
They files are pdf and excel files. No spaces or . At the end.  
Acronis in Gartner 2019 MQ for datacenter backup

It is an honor to be featured in Gartner 2019 Magic Quadrant for Datacenter Backup and Recovery Solutions. Gartner’s MQ sets a high standard and earning a place on their grid is a great affirmation that Acronis is delivering on our mission to protect all data, apps, and systems.

Author

Commented:
Our administrator applied a Windows patch to address the issue.  Not sure which one at the moment. I'll update the question when I found out.  So far it has fixed the problem.

Commented:
He most propably will have rebooted the machine after installing the patch, this way the files will be released anyways.. If there is some sort of Microsoft patch for it, please post the KB article of it, might be of interest for other people..
Commented:
It actually was a McAfee antivirus patch that was applied that fixed the issue.

hotfix # VSE80HF375377

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial