Office Communication Server 2007 R2 Certificate error

Rodders1000
Rodders1000 used Ask the Experts™
on

I recently installed office communication server 2007 R2 enterprise which seemed to be working ok, Until I tried to "Fix it".
I also have office communication server 2005 standard, with 60 odd users on it all working fine.

Once I finished installing the new server I moved over some of users from the existing server to the new server. All seemed fine except for an error with the address book.
I had this error on the previous server and was resolved by installing a new certificate.
This didnt fix the error this time in fact it made things worse.

After creating the certificate and assigning it to the new server no new users can connect to the new server.
The users connecting get an error saying the certificate is invalid and doesnt seem to come from the server it says it is from

I have tried naming the certificate the FQDN as some posts on here say but unfortunatly this didnt help.

It seems as though everything is in place and correct I was just wondering does anyone have any pointers for what could be wrong ?
Does the enterprise version of communicator have to have an external certificate like from Verisign ? As I did this from from my certificate server.


Thanks for any help

Rod




Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Hi,

The Certificate can be created by an Internal CA without issue as long as it is trusted by the clients.

Did you delete the old certificate if you didn't then you could just re-point OCS to use that.

IIS and OCS have seperate Certificate Configurations so updaing the IIS one through IIS Manager should not effect the Certificates for OCS which are configured through the OCS Administration Tool; unless you deleted the cert.

Enterprise Edition uses the Pool Address for the Certificate as this is what the clients should connect to; rather than the Server FQDN.

The best way to re-create the OCS Certificates is to use the Certificates Wizard which you can get to by right clicking the server in the Administration Tool and selecting Certificates. The wizard will allow you to create a new request, submit it and then activate the Certificate, it will populate most of the entries automatically.

I hope that makes sense if not let me know and I will try again....

Adam

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial