IIS 6 virtual directory HTTP error 500

qinformation
qinformation used Ask the Experts™
on
I have an IIS 6 server (windows 2003 standard) in a workgroup outside our domain. It has a virtual directory connected to a share on a file share on a server (2003 standard) in our domain. I can navigate the directory structure and see the files from within IIS but when I try to browse I get an HTTP 500 error. The log entry follows.

2009-07-20 21:41:13 W3SVC715844336 192.168.1.118 GET /Test - 80 - 192.168.1.118 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.2;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729) 500 16 1326

Ive set the CONNECT AS  to a domain ID, the domain admin and a local user of the server with the share. Same symptoms and  error for all. Ive also set the Enable anonymous to these ID under Directory Security.
Ive tried building similar VDs connecting to other servers in the domain with the credentials above and get the same error.  I use the IP of the server when creating the VD and directory browsing is enabled. There is no firewall between them and the local firewall on the webserver is off.

My question is what is the difference between IIS  and  browsing with IE?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Disable "friendly http messages" in your IE then try again. Error will occur again but message can be much more meaningful.

Author

Commented:
Same error either way...

The page cannot be displayed
There is a problem with the page you are looking for, and it cannot be displayed.
--------------------------------------------------------------------------------

Please try the following:

Contact the Web site administrator to inform them that this error has occured for this URL address.
HTTP Error 500 - Internal server error.
Internet Information Services (IIS)

--------------------------------------------------------------------------------

Technical Information (for support personnel)

Go to Microsoft Product Support Services and perform a title search for the words HTTP and 500.
Open IIS Help, which is accessible in IIS Manager (inetmgr), and search for topics titled Web Site Administration, and About Custom Error Messages.
In the IIS Software Development Kit (SDK) or at the MSDN Online Library, search for topics titled Debugging ASP Scripts, Debugging Components, and Debugging ISAPI Extensions and Filters.

Commented:
This is friendly message :)

What type of default document do you have in /test virtual folder?
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
I know. it's the same regardless of the setting. I restarted IE after the change.

I expected a directory listing as Direcory browse is enabled o the VD. Just to check I disabled that and added a defaulft.htm file ("hello').  Same error. I set up a local VD to test the file and it works.

Commented:
And what about accessing root folder of this site?

Author

Commented:
I didn't set anything up orginially. Just moved the same default.htm file to the root. The error on the VD is the same.
OK. Here's how I got it to work. I created identical local users (ID and password) on both the webserver and the file server. The webserver is in a workgroup and the file server is in a domain. In the 'connect as' of the virtual directory I specified the user ID only. No domain or machine name qualifier. For some reason I can now see the files in IIS AND browse via URL. Don't really know why.

Commented:
Ok.... great news you've solved it. :)

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial