error 1044 creating database mysql on vista

a_cadore
a_cadore used Ask the Experts™
on
Loaded 5.1 Mysql, assigned a password to root, started an istance,launched MySqlAdministrator, succesfully connected as root@localhost:3306, trying to add a new schema I get this msgbox:
Error while executing query
Create database 'DatiCM'
MySql error number: 1044
Access denied for user 'root'@'localhost' to database 'daticm'

O.S. : Windows Vista HomePremium Service Pack1
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Author

Commented:
Does'nt work......
Top Expert 2005

Commented:
Login as root with the command line client:

mysql -u root -p

After entering your password when prompted, issue this:

SHOW GRANTS;

Report your results
How to Generate Services Revenue the Easiest Way

This Tuesday! Learn key insights about modern cyber protection services & gain practical strategies to skyrocket business:

- What it takes to build a cloud service portfolio
- How to determine which services will help your unique business grow
- Various use-cases and examples

Maybe mysqld does not have sufficient filesystem permissions in the data directory?

Can you go through the steps here: http://dev.mysql.com/doc/refman/5.1/en/windows-post-installation.html

Author

Commented:
Microsoft Windows [Versione 6.0.6001]
Copyright (c) 2006 Microsoft Corporation. Tutti i diritti riservati.

C:\Users\io>mysql -u root -p
Enter password: *******
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 1
Server version: 5.1.36-community MySQL Community Server (GPL)

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

mysql> show grants;
+-------------------------------------------------------------------------------
------------------------------+
| Grants for root@localhost
                              |
+-------------------------------------------------------------------------------
------------------------------+
| GRANT USAGE ON *.* TO 'root'@'localhost' IDENTIFIED BY PASSWORD '*F669A61D2539
36512264E7FBC451EA9A86489B0C' |
+-------------------------------------------------------------------------------
------------------------------+
1 row in set (0.02 sec)

mysql>
Top Expert 2005
Commented:
Your root user has no privileges.

If you have some other user with full privileges, use that instead.

Otherwise:

- shut down MySQL
- restart MySQL with --skip-grant-tables (you can add the line to my.ini without the leading -- if it's easier)
- login to the command line client (you will not need any user or password)
- FLUSH PRIVILEGES;
- GRANT ALL ON *.* TO 'root'@'localhost' WITH GRANT OPTION;
- restart MySQL normally (without the skip-grant-tables)

Author

Commented:
Sorry for the time (1 week) of our response, due to a week of vacation, many thanks.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial