Folder Permissions

ipendlebury
ipendlebury used Ask the Experts™
on
I want to get access to the redirected MyDocuments folders on my SBS 2008 server. Even though I have full administrative privileges, I cannot get in there. I can't even view the permissions. How can I achieve this?

Ian
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Alan HardistyCo-Owner
Top Expert 2011

Commented:
When you setup the redirected folders via a GPO, you have the option to Grant the user exclusive rights to all documents.  If you select this option, you lose the ability to access their documents.
To change this, you would have to remove folder redirection, change the policy and then set folder redirection up again without the exclusive access option.
http://technet.microsoft.com/en-us/library/cc782799(WS.10).aspx 
Cris HannaSr IT Support Engineer

Commented:
Are you attempting to see the properties while logged onto the server with an admin account, or trying to do this from a workstation?
you cannot view the permissions because you do not have ownership of the folders.  this is by design :
 see http://technet.microsoft.com/en-us/library/cc736916(WS.10).aspx

you can as administrator take ownership, and give yourself the appropriate permissions however you must remember to give the original user permissions to the folder once you have take ownership.

the process is:
right click the folder select properties
click on the security tab (you will get an error)
Click on advanced
select owner tab
in the "change owner to" box select "administrators"
the select the "replace owners on subcontainer and object" checkbox
click apply
you should get a dialogue asking if you want to replace the folder permissions with permissions giving you full control. answer yes or ok to that
close the properties dialogue when it has finished then go back into the properties for the folder, you now have full control
add the original user into the root folder and give them the required permissions as per the above technet document.

Regards
Grahame



1 right click the folder select permissions

Author

Commented:
Thanks Graham, thats what I was looking for.

Ian

Author

Commented:
Grahame, Is there a way of changing the system behaviour so that this does not happen? I would much prefer that administrators are given full access to the entire server.

Ian

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial