Problem Conection L2TP-IPSEC ASA5505

Baeta
Baeta used Ask the Experts™
on
I´m trying to connect Windows XP L2TP with ASA5505 and receive the message All IPSec SA proposals found unacceptable!, can someone help me to find the error in my configuration.
ASA Version 7.2(4) 
!
hostname FWNEWLINE
domain-name newlinealarmes.com.br
enable password 7mgIYEPHCghs7q.K encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.100.100.1 255.0.0.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 200.178.98.145 255.255.255.240 
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
 domain-name newlinealarmes.com.br
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list deny-flow-max 2048
access-list policy_nat_web1 extended permit ip host 10.100.100.100 any 
access-list policy_nat_web2 extended permit ip host 10.100.100.100 any 
access-list policy_nat_web3 extended permit ip host 10.100.100.200 any 
access-list policy_nat_web4 extended permit ip host 10.100.100.200 any 
access-list inbound_outside extended permit ip any host 200.178.98.147 
access-list inbound_outside extended permit ip any host 200.178.98.148 
access-list inbound_outside extended permit ip host 200.178.98.147 host 10.100.100.200 
access-list inbound_outside extended permit ip host 200.178.98.148 host 10.100.100.100 
access-list inbound_outside extended permit tcp any any eq ssh 
access-list inbound_outside extended permit ip host 200.178.98.149 host 10.100.100.201 
access-list inbound_outside extended permit ip any host 200.178.98.149 
access-list inbound_outside extended permit tcp host 200.178.98.150 host 10.0.0.75 eq 3389 
access-list inside_nat0_outbound extended permit ip any 10.1.1.0 255.255.255.128 
access-list inside_nat0_outbound extended permit ip 10.0.0.0 255.0.0.0 192.168.100.0 255.255.255.0 
access-list inside_nat_static extended permit ip host 10.100.100.201 any 
access-list inside_nat_static_1 extended permit ip host 10.100.100.201 any 
access-list inside_nat0_outbound_1 extended permit ip any 192.168.100.0 255.255.255.0 
access-list outside_cryptomap_dyn extended permit ip any 10.0.0.0 255.0.0.0 
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool VIVO 192.168.100.1-192.168.100.254 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound_1
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) 10.100.100.100  access-list policy_nat_web2 
static (inside,outside) 200.178.98.148  access-list policy_nat_web3 
static (inside,outside) 10.100.100.200  access-list policy_nat_web4 
static (inside,outside) 10.100.100.201  access-list inside_nat_static 
static (inside,outside) 200.178.98.149  access-list inside_nat_static_1 
access-group inbound_outside in interface outside
route outside 0.0.0.0 0.0.0.0 200.178.98.145 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
aaa-server VIVO protocol radius
aaa-server VIVO (inside) host 10.100.100.201
 timeout 5
 key teste123
 authentication-port 1812
 accounting-port 1812
aaa authentication enable console LOCAL 
aaa authentication http console LOCAL 
aaa authentication ssh console LOCAL 
http server enable
http 10.0.0.0 255.0.0.0 inside
http 0.0.0.0 0.0.0.0 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set TRANS_ESP_3DES_SHA esp-des esp-sha-hmac 
crypto ipsec transform-set TRANS_ESP_3DES_SHA mode transport
crypto ipsec transform-set TRANP_ESP_DES_SHA esp-3des esp-md5-hmac 
crypto ipsec transform-set myset esp-3des esp-sha-hmac 
crypto ipsec transform-set TRANS_ESP_3DES_MD5 esp-3des esp-md5-hmac 
crypto ipsec transform-set TRANS_ESP_3DES_MD5 mode transport
crypto dynamic-map outside_dyn_map 20 set pfs 
crypto dynamic-map outside_dyn_map 20 set transform-set TRANS_ESP_3DES_SHA TRANS_ESP_3DES_MD5
crypto dynamic-map dynmap 20 set transform-set myset
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto map mymap 10 set transform-set myset
crypto ca certificate map outside_cryptomap_dyn 10
crypto isakmp identity address 
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash md5
 group 2
 lifetime 86400
crypto isakmp policy 20
 authentication pre-share
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 30
 authentication pre-share
 encryption des
 hash sha
 group 1
 lifetime 86400
crypto isakmp nat-traversal  20
telnet timeout 5
ssh 10.0.0.0 255.0.0.0 inside
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 10.100.100.2-10.100.100.129 inside
dhcpd enable inside
!
 
group-policy DfltGrpPolicy attributes
 banner none
 wins-server none
 dns-server none
 dhcp-network-scope none
 vpn-access-hours none
 vpn-simultaneous-logins 3
 vpn-idle-timeout 30
 vpn-session-timeout none
 vpn-filter none
 vpn-tunnel-protocol IPSec l2tp-ipsec 
 password-storage disable
 ip-comp disable
 re-xauth disable
 group-lock none
 pfs disable
 ipsec-udp disable
 ipsec-udp-port 10000
 split-tunnel-policy tunnelall
 split-tunnel-network-list none
 default-domain none
 split-dns none
 intercept-dhcp 255.255.255.255 disable
 secure-unit-authentication disable
 user-authentication disable
 user-authentication-idle-timeout 30
 ip-phone-bypass disable
 leap-bypass disable
 nem disable
 backup-servers keep-client-config
 msie-proxy server none
 msie-proxy method no-modify
 msie-proxy except-list none
 msie-proxy local-bypass disable
 nac disable
 nac-sq-period 300
 nac-reval-period 36000
 nac-default-acl none
 address-pools value VIVO
 smartcard-removal-disconnect enable
 client-firewall none
 client-access-rule none
 webvpn
  functions url-entry
  html-content-filter none
  homepage none
  keep-alive-ignore 4
  http-comp gzip
  filter none
  url-list none
  customization value DfltCustomization
  port-forward none
  port-forward-name value Application Access
  sso-server none
  deny-message value Login was successful, but because certain criteria have not been met or due to some specific group policy, you do not have permission to use any of the VPN features. Contact your IT administrator for more information
  svc none
  svc keep-installer installed
  svc keepalive none
  svc rekey time none
  svc rekey method none
  svc dpd-interval client none
  svc dpd-interval gateway none
  svc compression deflate
username vivo@Newlinealarmes.com.br password fUg7VHhsNEbewGdW5vjz7A== nt-encrypted
username andrei password yb4w8X2iuY4wSQQJ encrypted privilege 15
tunnel-group DefaultRAGroup general-attributes
 authentication-server-group VIVO LOCAL
 authorization-server-group (outside) VIVO
 strip-realm
 strip-group
tunnel-group DefaultRAGroup ipsec-attributes
 pre-shared-key *
 isakmp keepalive disable
tunnel-group DefaultRAGroup ppp-attributes
 no authentication chap
 authentication ms-chap-v2
tunnel-group VIVO type ipsec-ra
tunnel-group VIVO general-attributes
 address-pool VIVO
 authentication-server-group VIVO LOCAL
tunnel-group VIVO ipsec-attributes
 pre-shared-key *
tunnel-group VIVO ppp-attributes
 no authentication chap
 authentication ms-chap-v2
tunnel-group-map outside_cryptomap_dyn 10 DefaultRAGroup
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny 
  inspect sunrpc 
  inspect xdmcp 
  inspect sip 
  inspect netbios 
  inspect tftp 
!
service-policy global_policy global
prompt hostname context 
Cryptochecksum:c3a27ed18de3469c5ae84c0608bd2e07
: end
asdm image disk0:/asdm-524.bin
no asdm history enable

Open in new window

Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2010

Commented:
Try adding:
crypto ipsec transform-set TRANS_ESP_3DES_SHA esp-3des esp-sha-hmac

Author

Commented:
I add the line, but the error still the same.
Top Expert 2010

Commented:

As a reference, here is cisco's how to:
http://www.cisco.com/en/US/products/ps6120/products_configuration_example09186a00807213a7.shtml


Check to make sure the preshared keys match.  
Check the config on the XP client using the above article as a reference.  

Also, would you provide the vpn log snippet from the XP client please.  


Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Commented:
I solved the problem thanks for the help.
Baeta,

are you going to explain to everyone exactly how you resolved your problem?

Author

Commented:
The configuration of the ASA
ASA Version 7.2(4)
!
hostname FWNEWLINE
domain-name newlinealarmes.com.br
enable password 7mgIYEPHCghs7q.K encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.100.100.1 255.0.0.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 200.178.98.145 255.255.255.240
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
 domain-name newlinealarmes.com.br
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list deny-flow-max 2048
access-list policy_nat_web1 extended permit ip host 10.100.100.100 any
access-list policy_nat_web2 extended permit ip host 10.100.100.100 any
access-list policy_nat_web3 extended permit ip host 10.100.100.200 any
access-list policy_nat_web4 extended permit ip host 10.100.100.200 any
access-list inbound_outside extended permit tcp any host 200.178.98.150 eq 1236
access-list inbound_outside extended permit tcp any host 200.178.98.150 eq 1235
access-list inbound_outside extended permit tcp any host 200.178.98.150 eq 1234
access-list inbound_outside extended permit tcp any host 200.178.98.150 eq 3389
access-list inbound_outside extended permit ip any host 200.178.98.147
access-list inbound_outside extended permit ip any host 200.178.98.148
access-list inbound_outside extended permit ip host 200.178.98.147 host 10.100.100.200
access-list inbound_outside extended permit ip host 200.178.98.148 host 10.100.100.100
access-list inbound_outside extended permit tcp any any eq ssh
access-list inbound_outside extended permit ip host 200.178.98.149 host 10.100.100.201
access-list inbound_outside extended permit ip any host 200.178.98.149
access-list inbound_outside extended permit tcp host 200.178.98.150 host 10.0.0.75 eq 3389
access-list inside_nat0_outbound extended permit ip any 10.1.1.0 255.255.255.128
access-list inside_nat0_outbound extended permit ip 10.0.0.0 255.0.0.0 192.168.100.0 255.255.255.0
access-list inside_nat_static extended permit ip host 10.100.100.201 any
access-list inside_nat_static_1 extended permit ip host 10.100.100.201 any
access-list inside_nat0_outbound_1 extended permit ip any 192.168.100.0 255.255.255.0
access-list outside_cryptomap_dyn extended permit ip any 10.0.0.0 255.0.0.0
access-list inside_access_in extended permit ip host 10.100.100.201 any
access-list inside_access_in extended permit ip any any
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool VIVO 192.168.100.1-192.168.100.254 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound_1
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp 200.178.98.150 3389 10.0.0.75 3389 netmask 255.255.255.255
static (inside,outside) tcp 200.178.98.150 1234 10.0.0.230 1234 netmask 255.255.255.255
static (inside,outside) tcp 200.178.98.150 1235 10.0.0.230 1235 netmask 255.255.255.255
static (inside,outside) tcp 200.178.98.150 1236 10.0.0.230 1236 netmask 255.255.255.255
static (inside,outside) 10.100.100.100  access-list policy_nat_web2
static (inside,outside) 200.178.98.148  access-list policy_nat_web3
static (inside,outside) 10.100.100.200  access-list policy_nat_web4
static (inside,outside) 200.178.98.149  access-list inside_nat_static
access-group inside_access_in in interface inside
access-group inbound_outside in interface outside
route outside 0.0.0.0 0.0.0.0 200.178.98.147 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
aaa-server VIVO protocol radius
aaa-server VIVO (inside) host 10.100.100.201
 timeout 5
 key teste123
 authentication-port 1812
 accounting-port 1812
aaa authentication enable console LOCAL
aaa authentication http console LOCAL
aaa authentication ssh console LOCAL
http server enable
http 0.0.0.0 0.0.0.0 outside
http 10.0.0.0 255.0.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set TRANS_ESP_3DES_MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set TRANS_ESP_3DES_MD5 mode transport
crypto ipsec transform-set TRANS_ESP_3DES_SHA esp-3des esp-sha-hmac
crypto ipsec transform-set TRANS_ESP_3DES_SHA mode transport
crypto ipsec transform-set trans esp-3des esp-sha-hmac
crypto ipsec transform-set trans mode transport
crypto dynamic-map outside_dyn_map 20 set pfs
crypto dynamic-map outside_dyn_map 20 set transform-set TRANS_ESP_3DES_MD5 TRANS_ESP_3DES_SHA
crypto dynamic-map dyno 10 set transform-set trans
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map vpn 20 ipsec-isakmp dynamic dyno
crypto map vpn interface outside
crypto ca certificate map outside_cryptomap_dyn 10
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp nat-traversal  3600
telnet timeout 5
ssh 10.0.0.0 255.0.0.0 inside
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 10.100.100.2-10.100.100.129 inside
dhcpd enable inside
!

group-policy DfltGrpPolicy attributes
 banner none
 wins-server none
 dns-server none
 dhcp-network-scope none
 vpn-access-hours none
 vpn-simultaneous-logins 3
 vpn-idle-timeout 30
 vpn-session-timeout none
 vpn-filter none
 vpn-tunnel-protocol IPSec l2tp-ipsec
 password-storage disable
 ip-comp disable
 re-xauth disable
 group-lock none
 pfs disable
 ipsec-udp disable
 ipsec-udp-port 10000
 split-tunnel-policy tunnelall
 split-tunnel-network-list none
 default-domain none
 split-dns none
 intercept-dhcp 255.255.255.255 disable
 secure-unit-authentication disable
 user-authentication disable
 user-authentication-idle-timeout 30
 ip-phone-bypass disable
 leap-bypass disable
 nem disable
 backup-servers keep-client-config
 msie-proxy server none
 msie-proxy method no-modify
 msie-proxy except-list none
 msie-proxy local-bypass disable
 nac disable
 nac-sq-period 300
 nac-reval-period 36000
 nac-default-acl none
 address-pools value VIVO
 smartcard-removal-disconnect enable
 client-firewall none
 client-access-rule none
 webvpn
  functions url-entry
  html-content-filter none
  homepage none
  keep-alive-ignore 4
  http-comp gzip
  filter none
  url-list none
  customization value DfltCustomization
  port-forward none
  port-forward-name value Application Access
  sso-server none
  deny-message value Login was successful, but because certain criteria have not been met or due to some specific group policy, you do not have permission to use any of the VPN features. Contact your IT administrator for more information
  svc none
  svc keep-installer installed
  svc keepalive none
  svc rekey time none
  svc rekey method none
  svc dpd-interval client none
  svc dpd-interval gateway none
  svc compression deflate
username TESTE password mD2QX3gsHYfJ1SjdSiofqw== nt-encrypted
username vivo@Newlinealarmes.com.br password Mu2HvbX9xenLqIVHN2gY1A== nt-encrypted
username andrei password yb4w8X2iuY4wSQQJ encrypted privilege 15
tunnel-group DefaultRAGroup general-attributes
 address-pool VIVO
 strip-realm
 strip-group
tunnel-group DefaultRAGroup ipsec-attributes
 pre-shared-key *
 isakmp keepalive disable
tunnel-group DefaultRAGroup ppp-attributes
 authentication ms-chap-v2
tunnel-group-map outside_cryptomap_dyn 10 DefaultRAGroup
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:8ccefdd140fde53346897ec17c7a2bd7
: end

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial