Outlook RPC over HTTP to Exchange 2007 using Cellular Aircard - password prompt

jmirsky
jmirsky used Ask the Experts™
on
Hello,
    For some reason we are unable to use Microsoft Outlook while using a cellular aircard, we are continuously prompted to log into the virtual server name of our Exchange 2007 cluster.  The password will never accept.  The only way to get around this is to modify the account settings on the local Outlook profile and tell it to not connect using HTTP.  If someone is using their home internet connection and not the aircards, everything works fine for them.  

Do Cell companies handle RPC over HTTP traffic differently than a "landline" ISP?  

 The steps we are taking to open Outlook are as follows:

1. Connect to Cellular network
2. Open Cisco VPN Client and connect
3. Launch Outlook.
4. Outlook prompts to login into "ExchangeVirtualName"

I do know of some certificate issues for our Exchange environment that prevents us from being able to use Outlook without the VPN, however this is a slightly different issue (although possibly related) as this works fine from a standard cable/DSL connection.  We have tried with ATT, Verizon and Sprint, all have the same result.  We are running Windows XP Pro with SP2 on all machines.  

Thoughts?  Any assistance is greatly appreciated.  

JustMirsk
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
so if you connect to the VPN...that means your outlook clients are on LAN... and not using RPC over HTTPS... instead normal TCP/IP connection....

Also what authentication are you using for Outlook Anywhere?

Try running a test at https://testexchangeconnectivity.com

Author

Commented:
lastlostlast,
       Thanks for the response.  I have performed the tests at this website before and there are issues with our Outlook anywhere from external sources, which may be causing this problem.  I have tried both Basic and NTLM authentication, both result in the same password prompt.  I was under the impression that our clients were still trying to connect via HTTP as if we disable this option while on the aircards outlook will connect without any problems.  Please let me know if any other information will be valuable in finding the solution to this.  I appreciate your assistance.
Which is the latest Rollup Update that is applied on the Exchange Server?
The latest one is RU 9... http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=55320be2-c65c-48bb-bab8-6335aa7d008c

Also try disabling the Kernel Mode Authentication... It is automatically disabled if you have applied Rollup 8

You can run this command to disable it...
%systemroot%\system32\inetsrv\AppCmd.exe set config /section:system.webServer/security/authentication/windowsAuthentication /useKernelMode:false

Also go through this article http://technet.microsoft.com/en-us/library/cc671176.aspx
Disable the IPv6 on the CAS server....

Author

Commented:
lastlostlast,
    Thanks for the information.  We are currently on Rollup 5 for Exchange 2007.  I am investigating the possibility of the update to RU9 and disabling the kernel Mode authentication.  As far as the TCPIP6 stuff goes, we are not running server 2008, we are running server 2003 x64, I did not mention this before.  I will get back to you as soon as I can.  Thanks!

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial