Simple Cisco 1861 Router with CME Configuration

pezzonovante1
pezzonovante1 used Ask the Experts™
on
I have set up CME numerous times on 2800 and 3800 series routers but I cannot for the life of me get it working properly on a new 1861 router (with internal switch). I've set up separate voice and data VLANs, DHCP and CME. The IP phone gets an IP address but then returns TFTP timeout when trying to download the firmware. I cannot ping the single router interface (FastEthernet0/0) which I believe should be the TFTP server IP as well.

I did not assign IP addresses to the FastEthernet0/0 sub-interfaces because I got an "overlaps with Vlan X" error as well. I would like to have the sub-interface IP on the same subnet as the Vlan if possible. Although I'm not exactly sure what I need that address for.

The problem seems to be that the "switch" within the router is not communicating with the router. In the past I've set up trunks appropriately between the router and a standalone switch but I'm not sure what to do here. Please look at my configuration and tell me what the problem might be.


show run
Building configuration...

Current configuration : 2834 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router18
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
network-clock-participate wic 1
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
ip cef
!
!
no ip dhcp use vrf connected
!
ip dhcp pool Voice
   network 172.18.5.0 255.255.255.0
   default-router 10.10.18.1
   option 150 ip 10.10.18.1
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
voice-card 0
 no dspfarm
!
!
!
archive
 log config
  hidekeys
!
!
!
interface FastEthernet0/0
 description WAN Interface
 ip address 10.10.18.1 255.255.255.0
 speed 100
 full-duplex
!
interface FastEthernet0/0.1
 description Voice and Data Encapsulation - DO NOT USE
 encapsulation dot1Q 1 native
!
interface FastEthernet0/0.5
 description Voice VLAN
 encapsulation dot1Q 5
!
interface FastEthernet0/0.10
 description Data VLAN
 encapsulation dot1Q 10
!
interface Integrated-Service-Engine0/0
 no ip address
 shutdown
!
interface FastEthernet0/1/0
 switchport access vlan 10
 switchport mode trunk
 switchport voice vlan 5
!
interface FastEthernet0/1/1
!
interface FastEthernet0/1/2
!
interface FastEthernet0/1/3
!
interface FastEthernet0/1/4
!
interface FastEthernet0/1/5
!
interface FastEthernet0/1/6
!
interface FastEthernet0/1/7
!
interface FastEthernet0/1/8
!
interface BRI0/1/0
 no ip address
!
interface BRI0/1/1
 no ip address
!
interface Vlan1
 ip address 172.18.1.254 255.255.255.0
!
interface Vlan5
 ip address 172.18.5.254 255.255.255.0
!
interface Vlan10
 ip address 172.18.10.254 255.255.255.0
!
!
!
no ip http server
no ip http secure-server
!
!
!
tftp-server flash:P00308000500.bin
tftp-server flash:P00308000500.loads
tftp-server flash:P00308000500.sb2
tftp-server flash:P00308000500.sbn
tftp-server flash:SCCP70.8-2-2SR2S.loads
!
control-plane
!
!
voice-port 0/0/0
!
voice-port 0/0/1
!
voice-port 0/0/2
!
voice-port 0/0/3
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/4/0
 auto-cut-through
 signal immediate
 input gain auto-control
 description Music On Hold Port
!
!
!
telephony-service
 no auto-reg-ephone
 load 7960-7940 P00308000500
 load 7970 SCCP70.8-2-2SR2S
 max-ephones 12
 max-dn 48
 ip source-address 10.10.18.1 port 2000
 max-conferences 4 gain -6
 transfer-system full-consult
 create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-dn  11  dual-line
 number 180001
 name Phone180001
!
!
ephone  1
 device-security-mode none
 mac-address 001F.CAE7.9017
 type 7960
 button  1:11
!
!
!
line con 0
 no modem enable
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
 login
!
!
webvpn cef
end
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Istvan KalmarHead of IT Security Division
Top Expert 2010

Commented:
ip dhcp pool Voice
   network 172.18.5.0 255.255.255.0
   default-router  172.18.5.1
   option 150 ip 10.10.18.1


interface FastEthernet0/0.5
ip address 172.18.5.1 255.255.255.0

Author

Commented:
ikalmar:

interface FastEthernet0/0.5
ip address 172.18.5.1 255.255.255.0

I tried this already. It gives me the error 172.18.5.0 overlaps with VLAN 5.
Sr. Systems Engineer
Top Expert 2008
Commented:
Are you trying to trunk Ether0/0 to a switch, or use the switchports on the router?

Don't use any sub-interfaces on the Fast0/0 interface. This is WAN connection
Just use the L3 vlan interfaces, just be sure to actually define the vlans

router#vlan data
router(vlan)#vlan 5
router(vlan)#vlan 10
router(vlan)#exit
Apply completed....
router#
Remove the sub-interfaces

no interface FastEthernet0/0.1
no interface FastEthernet0/0.5
no interface FastEthernet0/0.10

ip dhcp pool Voice
   network 172.18.5.0 255.255.255.0
   default-router 10.10.18.1  <== this HAS to be 172.18.5.254 !!!


 
Les MooreSr. Systems Engineer
Top Expert 2008
Commented:
Also recommend that you use a loopback interface for the tftp server IP instead of Fast0/0
Is fast0/0 actually connected to something? Is it up/up?

Author

Commented:
I'm trying to use the switchports on the router. I think that's where I got confused, i was somehow trying to trunk the switchports to the router as though they it was an external switch.

I removed the subinterfaces as you suggested and I've added a loopback interface of 172.168.0.1 and set the dhcp option 150 to that address and it's working now. I always wondered what loopbacks were useful for on routers, now I know - thanks!

I couldn't set the loopback IP as part of a VLAN, VLAN #1 in this case. What's the point of having VLAN 1 if I cannot put router addresses on it?

Next step is to add more phones, then another 1861 router with CME and trunk them using H.323.

I will accept your above solution lrmoore. Here's my configuration as of now. Please let me know if there's anything I could clean up or that is not to convention regarding VLAN IP addresses and such.


Router18#show run
Building configuration...

Current configuration : 2625 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router18
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
network-clock-participate wic 1
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
ip cef
!
!
no ip dhcp use vrf connected
!
ip dhcp pool Voice
   network 172.18.5.0 255.255.255.0
   default-router 172.18.5.254
   option 150 ip 172.18.0.1
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
 no dspfarm
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
interface Loopback0
 ip address 172.18.0.1 255.255.255.0
!
interface FastEthernet0/0
 description WAN Interface
 ip address 10.10.18.1 255.255.255.0
 speed 100
 full-duplex
!
interface Integrated-Service-Engine0/0
 no ip address
 shutdown
!
interface FastEthernet0/1/0
 switchport access vlan 10
 switchport mode trunk
 switchport voice vlan 5
!
interface FastEthernet0/1/1
!
interface FastEthernet0/1/2
!
interface FastEthernet0/1/3
!
interface FastEthernet0/1/4
!
interface FastEthernet0/1/5
!
interface FastEthernet0/1/6
!
interface FastEthernet0/1/7
!
interface FastEthernet0/1/8
!
interface BRI0/1/0
 no ip address
!
interface BRI0/1/1
 no ip address
!
interface Vlan1
 ip address 172.18.1.254 255.255.255.0
!
interface Vlan5
 ip address 172.18.5.254 255.255.255.0
!
interface Vlan10
 ip address 172.18.10.254 255.255.255.0
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
tftp-server flash:P00308000500.bin
tftp-server flash:P00308000500.loads
tftp-server flash:P00308000500.sb2
tftp-server flash:P00308000500.sbn
tftp-server flash:SCCP70.8-2-2SR2S.loads
!
control-plane
!
!
!
voice-port 0/0/0
!
voice-port 0/0/1
!
voice-port 0/0/2
!
voice-port 0/0/3
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/4/0
 auto-cut-through
 signal immediate
 input gain auto-control
 description Music On Hold Port
!
!
!
!
!
!
!
!
telephony-service
 no auto-reg-ephone
 load 7960-7940 P00308000500
 load 7970 SCCP70.8-2-2SR2S
 max-ephones 12
 max-dn 48
 ip source-address 10.10.18.1 port 2000
 max-conferences 4 gain -6
 transfer-system full-consult
 create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-dn  11  dual-line
 number 180001
 name Phone180001
!
!
ephone  1
 device-security-mode none
 mac-address 001F.CAE7.9017
 type 7960
 button  1:11
!
!
!
line con 0
 no modem enable
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
 login
!

!
webvpn cef
end

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial