WSUS not seeing any client computers

AxiServices
AxiServices used Ask the Experts™
on
I just installed WSUS on an SBS 2003 server. I followed everything step by step and edited the group policies on the client computers. Even after this, the computers do not show up on the WSUS list. I was just wondering what could be the issue?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Jan Vojtech VanicekIT Specialist

Commented:
Hello,
you must setup the group policy on the OU in AD where are domain connected computers stored...
It is better than do it on each single computer.

What exactly you are setup in policies?

For synchronisation you can use these commands:

gpupdate /force
for sync of GPO from DC

wuauclt /detectnow
for invoke the connection to setup WSUS service (or windows update if WSUS is not configured)
DonNetwork Administrator

Commented:
Confirm that a client is getting the GPO for WSUS by running from the command prompt

"HKLM\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate" /s

post your results
Acronis in Gartner 2019 MQ for datacenter backup

It is an honor to be featured in Gartner 2019 Magic Quadrant for Datacenter Backup and Recovery Solutions. Gartner’s MQ sets a high standard and earning a place on their grid is a great affirmation that Acronis is delivering on our mission to protect all data, apps, and systems.

DonNetwork Administrator

Commented:
oops, sorry my first comment should have read

reg query "HKLM\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate" /s
DonNetwork Administrator

Commented:
This is the best place to start when troubleshooting WSUS

http://www.wsuswiki.com/WSusTroubleshooting

Author

Commented:
When doing the "HKLM\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate"  command, i get
The system cannot find the path specified. Also the group policies are set on the OU in AD.
Network Administrator
Commented:
yup, i forgot a part
reg query "HKLM\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate" /s
 
 

Author

Commented:
After doing reg query "HKLM\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate" /s, I get


HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate
    WUServer    REG_SZ  http://pdc-coburn-01
    WUStatusServer      REG_SZ  http://pdc-coburn-01
    ElevateNonAdmins    REG_DWORD       0x1

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU
    UseWUServer REG_DWORD       0x1
    NoAutoUpdate        REG_DWORD       0x0
    AUOptions   REG_DWORD       0x3
    ScheduledInstallDay REG_DWORD       0x7
    ScheduledInstallTime        REG_DWORD       0x3
    DetectionFrequencyEnabled   REG_DWORD       0x1
    DetectionFrequency  REG_DWORD       0x16
    NoAutoRebootWithLoggedOnUsers       REG_DWORD       0x1
    RebootRelaunchTimeoutEnabled        REG_DWORD       0x0
    RescheduleWaitTimeEnabled   REG_DWORD       0x1
    RescheduleWaitTime  REG_DWORD       0x1e
    NoAUShutdownOption  REG_DWORD       0x0

Author

Commented:
pdc-coburn-01 is the server where WSUS is installed
DonNetwork Administrator

Commented:
ok run clientdiag
DonNetwork Administrator

Commented:
Reg query was good

Author

Commented:

WSUS Client Diagnostics Tool

Checking Machine State
        Checking for admin rights to run tool . . . . . . . . . PASS
        Automatic Updates Service is running. . . . . . . . . . PASS
        Background Intelligent Transfer Service is not running. PASS
        Wuaueng.dll version 7.2.6001.788. . . . . . . . . . . . PASS
                This version is WSUS 2.0

Checking AU Settings
        AU Option is 3 : Notify Prior to Install. . . . . . . . PASS
                Option is from Policy settings

Checking Proxy Configuration
        Checking for winhttp local machine Proxy settings . . . PASS
                Winhttp local machine access type
                        <Direct Connection>
                Winhttp local machine Proxy. . . . . . . . . .  NONE
                Winhttp local machine ProxyBypass. . . . . . .  NONE
        Checking User IE Proxy settings . . . . . . . . . . . . PASS
                User IE Proxy. . . . . . . . . . . . . . . . .  NONE
                User IE ProxyByPass. . . . . . . . . . . . . .  NONE
                User IE AutoConfig URL Proxy . . . . . . . . .  NONE
                User IE AutoDetect
                AutoDetect not in use

Checking Connection to WSUS/SUS Server
                WUServer = http://pdc-coburn-01
                WUStatusServer = http://pdc-coburn-01
        UseWuServer is enabled. . . . . . . . . . . . . . . . . PASS
                Client is pointed to SUS 1.0 Server
        Connection to server. . . . . . . . . . . . . . . . . . PASS

WinHttpDownloadFileToMemory(szURLDest, NULL, 0, NULL, NULL, NULL, &downloadBuffe
r) failed with hr=0x80190194

No Error description could be found

Press Enter to Complete
DonNetwork Administrator

Commented:
Did you install wsus to the custom port 8530???

Author

Commented:
No I did not. How do I do that?
DonNetwork Administrator
Commented:
You should also read here
 
http://www.wsuswiki.com/wsusonsbs 

Author

Commented:
According to sources, On a SBS server setup will always install WUS on port 8530. Since Im running SBS 2003, I think its already on 8530.

Author

Commented:
After editing my group policy intrantet statistics server to http://pdc-coburn-01:8530, I now get:

WSUS Client Diagnostics Tool

Checking Machine State
        Checking for admin rights to run tool . . . . . . . . . PASS
        Automatic Updates Service is running. . . . . . . . . . PASS
        Background Intelligent Transfer Service is not running. PASS
        Wuaueng.dll version 7.2.6001.788. . . . . . . . . . . . PASS
                This version is WSUS 2.0

Checking AU Settings
        AU Option is 3 : Notify Prior to Install. . . . . . . . PASS
                Option is from Policy settings

Checking Proxy Configuration
        Checking for winhttp local machine Proxy settings . . . PASS
                Winhttp local machine access type
                        <Direct Connection>
                Winhttp local machine Proxy. . . . . . . . . .  NONE
                Winhttp local machine ProxyBypass. . . . . . .  NONE
        Checking User IE Proxy settings . . . . . . . . . . . . PASS
                User IE Proxy. . . . . . . . . . . . . . . . .  NONE
                User IE ProxyByPass. . . . . . . . . . . . . .  NONE
                User IE AutoConfig URL Proxy . . . . . . . . .  NONE
                User IE AutoDetect
                AutoDetect not in use

Checking Connection to WSUS/SUS Server
                WUServer = http://pdc-coburn-01
                WUStatusServer = http://pdc-coburn-01
        UseWuServer is enabled. . . . . . . . . . . . . . . . . PASS
                Client is pointed to SUS 1.0 Server
        Connection to server. . . . . . . . . . . . . . . . . . PASS
        SelfUpdate folder is present. . . . . . . . . . . . . . PASS

Press Enter to Complete
DonNetwork Administrator

Commented:
It looks like the problem is now fixed.... ;^D

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial