Cron not firing on system time

inajam
inajam used Ask the Experts™
on
I have a VPS based in Australia and have set system time to New Zealand so when I run #date I get NZDT, the correct time.  

However my cron jobs seem to be running on Australia time, firing two hours later than set.  Do crons run on a different time clock?

How can I check/adjust what time the cron should be firing.   Note I use Plesk 9 to set up crons and adjust time but am comfortable with SSH if that might help diagnose the problem.

Linux 2.6.18 Apache/2.2.3 (CentOS)
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2007

Commented:
try to set in the script the env. variable TZ
Commented:
Well I had to stop and restart the server for something else and it seems to have solved the timing issue of the crons as well.   Thanks for your reply omarfarid.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial