How to change alias name in MIcrosoft Exchange?

Mojojiju
Mojojiju used Ask the Experts™
on
I have just recently configured my Microsoft Exchange to work properly. The email accounts are defaulted to the names assigned to the client computers in SBS 2003. I would like to format them differently.

In example, I have the client computer vmccoy and the email for exchange is  vmccoy@kfsindustries.com. But I want it to be vance.mccoy@kfsindustries.com

How do I do this?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
See attached link should explan how to change Policy
http://support.microsoft.com/kb/822447
%g.%s@kfsindustries.  You can add this in the Recipient Update Service.
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
Hey,

I have modified the address field inside the SMTP setting of the Recipient Policy (see attached screen shot). I have tested the new alias in example instead of the original prefix vmccoy@kfsindustries.com, vance.mccoy@kfsindustries.com and it works. The problem now is just that when I send email out it still displays as vmccoy@kfsindustries.com

Any help?

Thanks,

Author

Commented:
Here is the file showing the screenshot.
Screen-shot-of-Recipient-Policy.doc
SaakarSenior Technical Consultant
Commented:
You can locate the option by following steps:
 
1.      Open ESM, expand Global Settings
2.      Click Internet Message Formats, on the right panel, double click the Remote Domain
3.      Under the Advanced tab, please check whether the Preserve sender's display name on message option has been enabled. By default, it should be enabled.
You cannot configure Exchange 2003 so that the simple display name appears in outgoing messages  
http://support.microsoft.com/kb/888416 
In the Recip Policy, goto properties and choose the SMTP address you created, then click Set as Primary..  This will solve your issue.  You can then do an update now on the RUS, which should start the propogation.  Have patience.  It may take some time for the changes to be made.

Author

Commented:
Hi,

Just so we are clear, you are saying that even though I have entered %g.%s@kfsindustries.com as the recipient policy email, when I send out, it will still be in the default format.

In example my email vmccoy@kfsindustries instead of vance.mccoy@kfsindustries.com like I would like to have?
You've already entered the %g.%s@kfsindustries.com in Recip Policies and the address has already propogated, right?  All I'm saying is in Recip Policies, click on the SMTP address that has %g.%s@kfsindustries.com and then click the set as primary.  This will set the vance.mccoy@kfsindustries.com as the default SMTP address and as such be the primary address of the mailbox, when that user sends mail.

Author

Commented:
I assume it has propogated. %g.%s@kfsindustries.com is set in the recipient policy. I did an update. I can send mail into the address vance.mccoy@kfsindustries.com but when I send it out from that address it still displays vmccoy@kfsindustries.com

Mojojiju,

Have you verified that vance.mccoy@kfsindustries.com  is the primary SMTP address for this user in AD?  When sending email, the primary SMTP address, however it is spelled out, will be what the recipient sees.  You will also want to ensure that this email address is listed as such in the users account in AD as well.

Author

Commented:
neopumpkin:

I apologize for the delayed response. I went to Server Managment>Advanced Management>local domain (KFS.local)>users>domain users. Then I clicked the "Members" tab. From here, I double clicked on Vance McCoy and made the following changes. Under the General tab I changed the email to vance.mccoy@kfsindustries.com and under the Email Addresses tab, I selected the SMTP address vance.mccoy@kfsindustries.com > set as primary> applied changes. After I close it out though, it goes right back to vmccoy@kfsindustries.com.

I also tried to delete the vmccoy@kfsindustries.com and it still comes back. Any suggestions?

Thanks,

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial