VMWare Server 2.0 on Windows Server SBS 2008 "Unable to connect to the MKS: There is no VMware process running for config file......"

jeremyhurst
jeremyhurst used Ask the Experts™
on
Hi,

We have VMware server 2.0.1 installed on a Windows Server 2008 box, and after a recent restart have lost the ability to access the console. The VM guest appears to be running OK and can be accessed via RDP and VNC but not the console available in the software web admin. The message we receive is as follows.

Unable to connect to the MKS: There is no VMware process running for config file
S:\Virtual Machines\server\xxxx.vmx
 Either run "C:\Program Files (x86)\VMware\VMware Server\x64\vmware-vmx.exe S:\Virtual Machines\server\xxxx.vmx" manually on the server, or register the config file.

Obviously I have tried what the message suggests but it returns the message:

VMware Server Error - Another instance of VMware server is already running this configuration file. Module VMAutomation initialization failed.

The guest OS is Windows 2003 Server

Any help getting the console working would be greatly received.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2009
Commented:
We encountered the same issue, we wasted hrs to troubleshoot
In the end, we just backup all VMs to a safe place then uninstall+reinstall vmware server
Load back all vmx to inventory
Problem solved!
Good luck!
Did you make any Hardware Changes to the Host machine before you restarted it ?
Try deleting it from the inventory, but select the option to keep files. Then reintroduce it to the inventory and try starting it.

Author

Commented:
Thanks for the input, was hoping there would be a more elegant solution.

Word of warning, after the reinstall the existing shortcuts to the web interface no longer worked and needed to be recreated.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial