Server Service keeps stopping, and Generic Host Crashes - SBS 2003

nwteam
nwteam used Ask the Experts™
on
Hi Experts,

Have a server that has just started to play up really badly.

Its a Microsoft SBS 2003 system, service pack 2.

Have moved the disks to new hardware (same everything) and it is still having the same issues.


Basically alot of the services are failing to start automatically, with "server" and anything dependant on it such as "computer browser" being the most problematic.

Most of the time (90%) I can manually start the service, and I can browse local shares (\\server) for several minutes before the service stops itself. Sometimes it stops straight away, sometimes I get a error "access denied" when starting it, and finally, it sometime starts, but although it's status is "started" I still cannot view shares.

At the same time i'm getting a popup saying generic host for windows needs to be closed. Click ok to that and it reappears straight away.

Event log has no errors that relate to anything it seems. Generic host isnt logging anything as it crashes, nor is "server" service. There were alot of Winmngt errors in the log, however I rebuilt the WMI, and they seem to have gone away, however the original issue still exists.

I have disabled backupexec 9.1 completely, removed symantec AV, disable all blackberry services, deselected everything on startup from MSCONFIG. Still no change.

I have also added "NOPAE" to the boot.ini as suggested in a similar problem thread on here (lost the link just at the moment).


Any ideas?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Awarded 2009
Top Expert 2010

Commented:
Sounds like Conficker or a variant, have you dint a full system virus scan?
Also check fir strange looking tasks in the scheduled tasks on the server.
Is the server fully patched?

It could also be the clients causing the problem so check them too.
Awarded 2009
Top Expert 2010

Commented:

Commented:
Did you change the administrator password for some reason?
OWASP Proactive Controls

Learn the most important control and control categories that every architect and developer should include in their projects.

Author

Commented:
Hi,

Thanks for the replies.

Scan came up clean, and patch has been done.
Still no change.

Administrator password was changed several weeks/months ago I believe (customer's server), but nothing in the past week or so.

Commented:
Try changing back to the last admin password and see if the system stablizes.
Commented:
seems the RAID mirror had split apart about a month ago, whether that caused the problems or not I managed to re-build the system from the C: of the older disk (which didn't have this problem) and the data D: off the disk that was having problems.  Thanks guys.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial