VPN Error 732: Your computer and the remote computer could not agree on PPP control protocols

Hi all,

I've set up a small office with 4 peer to peer networked computers with one having all the shared data on it.  XP Pro all round.  It has an ADSL2 connection via a Belkin F5D5730au Modem and Linksys WRT310N Router.

I've set up a Windows VPN server on this main computer for the clients to access the shared files from home.

From my workshop using a laptop running XP Pro I can connect to the VPN in less than a second and can browse the folders, use remote desktop etc.

My setup is a cable broadband modem Motorola Surfboard SB5101i and Dlink DIR-615 router.

When I take exactly the same laptop over to the client's house and plug it into their Siemens Speedstream 4200 ADSL Modem (I've taken their router out of the equation) I can connect to the internet, the VPN connection connects to the ip address and hangs on Verifying User Name and Password.and then we get this:
Error 732: Your computer and the remote computer could not agree on PPP control protocols

When I first set up their VPN access it worked for about 3 days but now it gets the above error every time.  Nothing I can think of changed.

I've run wireshark on my connection and their failed connection and compared the captures and the only difference is that on the successful connection we get:
Transmission Control Protocol, Src Port: aplx (1134), Dst Port: pptp (1723), Seq: 0, Len: 0
and on the unsuccessful connection we get:
Transmission Control Protocol, Src Port: ff-sm (1091), Dst Port: pptp (1723), Seq: 0, Len: 0

The unsuccessful connection holds up at the next stage which is Configuration request for the PPP LCP Protocol.  It always is rejected.

I'm afraid I don't know what a ff-sm Port  is.  Could anyone suggest whether this is where it is going wrong and what I might be able to do to fix it?

Thanks very much,

PaulD
RockpigAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Qlemo"Batchelor", Developer and EE Topic AdvisorCommented:
The source port is irrelevant when using PPTP. It is chosen dynamically, as ports are free. This is the case with almost all TCP protocols, and many UDP ones.

If you get problems with PPP LCP, it is usually:
  1. GRE (protocol 47) is not passed. Usually, if you have a routing device for Internet, it has to be configured for "PPTP passthru" (or "VPN passthru") to allow for GRE traffic also.
  2. GRE is catched by the router, and not handled correctly. I.e. the router is serving PPTP connections itself, and you want to use PPTP client to go outside
  3. Router is changing contents of PPP LCP phase. Unlikely, as this is only done by high-end routers/firewalls.
  4. GRE/PPTP address confusion caused by NAT.
For first go, you should additionally filter for protocol 47 with WireShark (or even better in this case, free Microsoft Network Monitor 3.3) while connecting. And compare both PPTP and GRE communication has a whole.

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
RockpigAuthor Commented:
Thanks for the explanation Qlemo,
I've tried the Siemens speedstream 4200 with the firewall off, on low, on high, with GRE packets as an ADMIT filter.  I guess I haven't got it right yet.
I'll give it another go this afternoon and let you know.
0
RockpigAuthor Commented:
I returned to the clients house last night to discover that the VPN now works without me changing anything so I'm putting it down to a faulty modem and will replace it if it happens again.
Thanks for the clarity Qlemo.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VPN

From novice to tech pro — start learning today.