We help IT Professionals succeed at work.

Access 2007. "Your network access was interrupted. To continue, close the database, and then open it again"

Access 2007 database.  Linked tables to backend SQL Server 2008 server.  Running under Terminal Services on Server 2008 x64.  Each user has their own copy of the frontend mdb.  This message happens frequently for all users.

This application was running with Access 2007, backend to SQL Server 2005, under Terminal Services on Server 2003.  This problem only began occurring since the move to the new environment.
Comment
Watch Question

Scott McDaniel (EE MVE )Infotrakker Software
Most Valuable Expert 2012
Top Expert 2014

Commented:
I'm assuming that the SQL Server is NOT on the same machine as the TS ...

If that's the case, then the first thing to look at would be the connection between the TS and the machine running the SQL Server. Have you checked the event log of both machines to see if there's any clues?

Also check User and Group settings for policies that may cause this. I'm not sure exactly what those would be (the logs will likely give you a clue, if this is a problem).

If you run the db locally from the TS box (i.e. do a physical walkup and fire up a local copy of the FE) does the same thing happen?

Author

Commented:
SQL Server is NOT on TS box; it runs on an SBS 2008 box.

Event Logs on both boxes are pretty clean; no clues there.

GP's for users work in all respects.  This database is the only app having a problem.

WRT running db locally.  Currently running app from physical console (versus RDP connection).  Will have results shortly.  This app will get error just by being open and sitting idle.  Not sure of mean time to failure.
FYI, I have a 2007 dba running on one computer, no network, nothing tricky.

I frequently got this error when my broadband connection was on, I think it was something to do with Windows Update, since turning it off I've had no problems.
Should have said, this only occured on PC with Vista. I work on same dba with same broadband connection on XP laptop with no probs.

Author

Commented:
notpandora, I don't see how your comments apply to this problem.
Scott McDaniel (EE MVE )Infotrakker Software
Most Valuable Expert 2012
Top Expert 2014

Commented:
What happened when you ran the app from the physical machine? Did you still experience the error?

Author

Commented:
from the TS console, it disconnects just like the user sessions
Scott McDaniel (EE MVE )Infotrakker Software
Most Valuable Expert 2012
Top Expert 2014

Commented:
I'm at a loss. If I was a betting man, I'd say it had to do with the new x64 operating system, but then I don't work with that platform so don't know.

What provider are you using for connecting to the server? Are you using SQL Native Client?

Author

Commented:
lol, I always get the problems from hell.  I agree that it seems to have something to do with my new TS platform and I'm glad to be experimenting on myself before deploying to clients.

Because this app uses linked tables, it is using 32-bit ODBC, which means that the SQL Driver is my one and only option.  I've just gotten on SSMS and set the remote query timeout to 0 and if that fails, will upgrade to MDAC 2.8 ifnot already at that level.
Commented:
As an Access developer I have recently experienced this problem at a client site mainly running Access 2007 on Vista.
The following fixed it!
Thanks to Pinpoint Computers Steve Gauci (Thornton Australia)
Reference  -  http://support.microsoft.com/default.aspx/kb/297684
Update registry keys on user PCs as follows
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters]

"autodisconnect"=dword:ffffffff

 

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanworkstation\parameters]

"KeepConn"=dword:00003840


Author

Commented:
llewes...This is nice to know and I will try it if my SQL Server timeout fix does not work.  Of particular interest to me was the second reg entry, which is not doucmented in the referenced KB article, that controls disconnects of UNC references.  I use those a lot (prefer them to drive mapping) and that is essentially how the SQL Server is referenced by the ODBC driver.

I'll update here after testing the SQL Server timeout for a few more days.

Author

Commented:
The server timeout seems to have mitigated this problem substantially.  I cannot cause it to reproduce at will.  I am still getting occasional messages but to a much less degree of frequency before.  I may still try the reg hacks, but my pants are no longer on fire :)
Jim Dettman (EE MVE)President / Owner
Most Valuable Expert 2017
Most Valuable Expert 2012

Commented:
<<I may still try the reg hacks, but my pants are no longer on fire :)>>
Excellent news!
JimD.

Author

Commented:
I did also try llewes reg hacks.

My issue has reduced in frequency and I'm not sure how to reproduce it on demand.  But it is still happening.
I have the same problem but do not seem to have KeepConn in my HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanworkstation\parameters folder. Why is this and can I add it in some way?
Should I make the same adjustments in the other computer (the PC on which I run the backend of the DB)?
Christina

Author

Commented:
Server=backend pc.  You can create the KeepConn key, non-existance just means it uses the default value (http://technet.microsoft.com/en-us/library/cc960471.aspx)

I'm going to be looking more closely at the following:
(http://www.brianmadden.com/blogs/guestbloggers/archive/2007/02/19/updated-lanmanserver-and-lanmanworkstation-tuning.aspx

Commented:
I recently experienced this same issue where our FileServer (no terminal services) was producing the following errors:
1)Opening an 2007 Access file:  Error-Your network access was interrupted. To continue, close the database and then try it again.  2) Copying the Access file off the share:  Error-Cannot copy ____: not enough server storage is available to process this command.   I used llewes suggestion by adding the following 2 edits to the server's registry and it worked immediately after!!!
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters]
"autodisconnect"=dword:ffffffff    (had to change this from "f")

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanworkstation\parameters]
"KeepConn"=dword:00003840   (had to create this dword key)
Thanks!!

Commented:
I was looking at a similar issue with Server 2012, client OS was upgraded from Win7 to Win10.  Then the issue started.

A smart co-worker of mine looked at the Group policy and based on MS information relating to Server and OS higher than 8, GP updates in the background with drive mappings (didn't with Win7 and earlier OS) rather than at first log in.

He changed the Drive mapping in GP to update and that fixed the issue.  Here is a link that mentions the problem and resolution.
http://arstechnica.com/civis/viewtopic.php?t=1233859