• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1614
  • Last Modified:

Having Issues with Mysql error 10048

Dear sir,

I am having issue with MySQL on two of my dedicated  Windows 2003 servers.I am running Voipswitch software(Voip) and Database is mysql Server 5 .The issue I am having is Some times I am not able to connect to mysql.It gives me error"" ERROR [HY000] [MySQL][ODBC 3.51 Driver]Can't connect to MySQL server on 'localhost' (10048)""....some error like this.So the only way for me to make it work is to restart the servers.Issue is I am having this servers for 4 years now and this is the first time i am facin this issues.(since last 15 days)This happens daily and I had to restart and facing lot of calls from my clients.Please help me solve this.

Regards,
0
Sam2009
Asked:
Sam2009
  • 4
  • 2
2 Solutions
 
Sam2009Author Commented:
Dear Gawai,

I have done two things as I searched through the experts exchange database,

1)Start > Control Panel > Administrative Tools > Data Sources (ODBC).
This will open up the "ODBC Data Source Administrator".
On the "Connection Pooling" tab, double click the ODBC Driver you are using to connect to MySQL.
This will open up the "Set Connection Pooling Attributes" dialog.
To enable pooling select "Pool Connections to this driver"

####Here,Please tell me the time in seconds that I need to give.###

2)Start Registry Editor (Regedt32.exe).

Locate the following key in the registry:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
On the Edit menu, click Add Value, and then add the following registry value:

Value Name: MaxUserPort
Data Type: REG_DWORD
Value: 65534
This sets the number of ephemeral ports available to any user. The valid range is between 5000 and 65534 (decimal). The default value is 0x1388 (5000 decimal).

On the Edit menu, click Add Value, and then add the following registry value:

Value Name: TcpTimedWaitDelay
Data Type: REG_DWORD
Value: 30
This sets the number of seconds to hold a TCP port connection in TIME_WAIT state before closing. The valid range is between 0 (zero) and 300 (decimal). The default value is 0x78 (120 decimal).

Quit Registry Editor.

Reboot the machine.

This is What I have done.I have done both.Please tell me is this sufficient.Also Tell me what value should i give for pooling
Kind Regards
0
 
GawaiCommented:
well to be honest, i m not much familiar with that stuff.
ref this link if it helps u
http://support.microsoft.com/default.aspx?scid=kb;EN-US;q169470
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
Sam2009Author Commented:
Thank you for your message . I will check it out and update you very soon.I have done all and restarted.Let me see If i get the issue again.
0
 
Sam2009Author Commented:
A Brilliant site to follow.For the last 24 hours Its working.I have to see if it still comes up,but i think its solved.Will update incase it happens again.Thank you so much!
0
 
Sam2009Author Commented:
Thank you so mcuh.Its working for the last 24 hours.Incase it happens again,I will get back.Thank you so much!!
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now