Avatar of EICT
Flag for United Kingdom of Great Britain and Northern Ireland asked on

Rebuilding 5 Disk RAID 2100S using Adaptec Storage Manager when a disk fails

I have a 5 Disk RAID array which uses the Adaptec 2100S SCSI controller. The RAID is showing one of the disks as failed and the RAID as degraded. I have 3 spare disks so no problem I thought Id just swap the failed disk for a spare. All 5 disk & spares are Ultra 160 36Gb disks of the same make.

I am unable to assign the replacement disk to the Array. I've followed the Adaptec Instructions, below but I don't get the rebuild option. Interestingly both the failed disk and new disk show up as Ultra2 80MB/sec not Ultra 3 106MB/sec like the working 4 disk. I can't assign the new disk as a hot spare because I get a message "not large enough to protect any of the arrays" I assume its because all 5 hotswap bays were used.

Any help  much appreciated. Thanks

To rebuild an array, follow these steps:
1 Replace the failed drive according to the procedure in your
hardware documentation.
2 After the failed drive has been replaced, select
Logical Configuration View in Storage Manager.
3 Double-click the array group icon to open the Array Group
Information window.
4 Click Rebuild in the Array Group Information window to start
the rebuild process.
StorageStorage Hardware

Avatar of undefined
Last Comment

8/22/2022 - Mon

View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.

Thanks qikkel,

I did try rebooting. I did have the rebuild option but after I selected this it dissappeared and nothing happened. So I ended up with the same problem during boot that I had with storage manager.

I will update firmware/drivers as suggested. What is the best way to image the array?. I have ghost V12 (i think) enterprise edition but I don't think it supports arrays.

Since you're using hardware raid, you can use ghost to image the array...if you're using this to backup a system drive, you should do this with windows pe or bart pe
http://service1.symantec.com/SUPPORT/on-technology.nsf/docid/2007091315410760 (for ghost 11, same concept)
Do you have any larger disks you can try?  

Thanks qikkel,

I'll take your advise with regards imaging the array for the future.

I finally fixed this. I noticed that in the boot storage manage and windows, it was stuck with the new disk as unrecognised. I updated the windows driver only. And put the old disk back in. The old disk now showed as ok but still not part of the array. I rebooted again for the as I had done loads before and this time I was able to rebuild the array in boot storage manager. Logged back into windows and it continued with the rebuild. All is ok now with the original disk, couldn't get the new disk to rebuild. Very strange as I had tried swapping disks several times before, must have been the driver which resolved this.

Thanks for your help.
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck