Avatar of aedolbey
Flag for Afghanistan asked on

log-in problem with WinXP-Virtual-Machine under VMware Fusion on MacBook Pro

Hello Experts,

I purchased a MacBook Pro a couple months ago (a *wonderful* machine!).  So that I could continue using a couple WinXP apps I had been using for several years, I purchased at the same time VMware Fusion (v. 2.0.5).  I was amazed at how easy and quick it was to install WinXP as a virtual machine (along with an Ubuntu Linux Virtual Machine).  It was equally quick and easy to install WinXP apps on the VMware Fusion virtual machine (VM).

Unfortunately, despite all these initial successes, I'm now dealing with a very frustrating problem.  After I had installed a few WinXP apps, I logged out of the VM so that I could cleanly shut down the MacBook Pro.  When I later restarted the MacBook, and attempted to open the WinXP VM, virtual WinXP presented a log-in screen in which the only user listed is 'Administrator', and then asked for a log-in password.  But I don't think I was ever asked to specify a password for the WinXP VM.  And if I was but just don't recall this, I am 100% confident that I know what I would've chosen for a password.  Nevertheless, the WinXP VM rejects this password.  I have tried all the possible passwords that are even remotely likely, and none of them were accepted.  And just leaving the password field blank was also not accepted.

I know there are utilities available for recovering WinXP passwords, but the only ones I know of are for dedicated WinXP machines, not for a Fusion VMware VM within a MacBook Pro OS X 10.6.1 system.

Does anybody have any suggestions for getting logged in to the WinXP VM 'Administrator' account?  If I can't figure out how to do this, I'll have to delete the VM and install a new copy.  I'd really rather not do that, as I've already set up WinXP apps in the VM (including entering all the initial set-up data, etc.).  This would be a huge hassle.

If anyone has any suggestions, please let me know!


Apple HardwareVMwareWindows XP

Avatar of undefined
Last Comment

8/22/2022 - Mon
Ezan Javeed

Have you created any user other then Administrator ?
Cause when you install it will definitely ask you to create a user,
May be the password you using is for a separate user ?

Try cntrl+alt+ Del (twice)

Hope this help ...

They are way to retrieve window xp password running in VMware for sure. (but i don't know how ? )


First, is this XP Pro or XP Home.  Also, have you tried a blank password

If you didn't specify a password when you installed, I believe the password is blank by default. Just don't enter anything in the password box and hit continue.

Once you are in, it would not be a bad idea to specify a password.

Have a look at:  http://pcsupport.about.com/od/windowsxp/f/adminpassword01.htm
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy

View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.

javeedabdul, thanks for the cntrl+alt+Del suggestion.  At least I got to try a different username than 'Administrator', but after trying the only username choices I think I would've chosen (along with all the most likely password choices), I still can't log in successfully.

calldrdave, it is XP Pro I had installed for the Fusion VM.  And yes, I've tried a blank password, now with all the different username choices that I've ever made for myself.

One bad possibility, maybe the username I chose included a typo. If this is what happened, now I really am  back to using software for cracking passwords, but in the context of a VM (rather than a dedicated WinXP notebook).  Any suggestions on how to do this?

Sure, you can tell the VM to boot off a cd.  At the start I believe you press F2 to choose options.  

As far as recovery tools, here is a list


You don't even need to burn the CD, use the image file of theses as the actual CD settings

aedolbey, did you try my method?
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.

Did you try leaving the password blank?

Did you try the solutions in my post?
Gary Case

This problem illustrates why it's always a good idea to set a password ... just having one eliminates the likelihood of an accidental password being set, resulting in this issue.

Password cracking tools work exactly the same in a virtualized machine as on a real one.    I'd simply download the excellent OphCrack [http://pcsupport.about.com/od/toolsofthetrade/gr/ophcrack.htm ] and boot to it.    As noted above, you don't need to burn a CD when you download an ISO -- just set the VMWare machine to use that ISO as the CD.

I think Fusion is already set to boot from CD first, but am not sure (I don't use Fusion, as I don't have a Mac)  ==>  if you need to enter the BIOS setup on the virtual machine, you can easily do that without needing to "bang on F2" to try and capture the BIOS during the boot ...

(a)   Fusion MAY have the same option as VMWare Workstation for a direct boot to the BIOS.   If so, this is the simplest way.    In the VMWare interface, look at VM - Power  and see if one of the options is "Power On to BIOS".    Workstation has this option, but I'm not sure whether or not Fusion does.

(b)  If Fusion doesn't have that simple feature, then just do this:   Use a text editor to add the following line to the configuration file for your virtual machine (the .vmx file):
bios.forceSetupOnce = "TRUE"

... this will cause the VM to boot to BIOS setup the next time that virtual machine is power up.    Note it also resets the option -- so you'll have to edit the .vmx file each time you want to go to the BIOS.

Thanks, ryder0707!  trinity-rescue-kit worked like a charm!  And I was only minutes away from just giving up and creating a new copy of the VM.
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck

Glad it solves your problem :)