Event ID:6161 - Win32 error code returned by the print processor: 5. Access is denied - Source: Microsoft-Windows-PrintSpooler

Please help!

This is very quite urgent.

I have installed and configured a new Windows server 2008 STD 64bit and installed / configured terminal server. Initially all Windows XP computers that were logging on to the terminal server, their printers were not listed at all. I read about the problem, and came across that I was suppose to install service pack 3, and .NET framework 3.5 with SP1, make sure that Terminal server 6.1 is installed (Which comes standard with service pack 3)

All is well, I logged on to the terminal server, still the same problem. The initial XP computer has a 2200 HP LaserJet computer. I then went to Microsofts website to update the very old driver from 2200 series PCL to 2200 series PCL5 driver. Now when I log on to the terminal server the printer shows up. But when I attempt to print, the following error appears in the even viewer:

Log Name:      System
Source:        Microsoft-Windows-PrintSpooler
Date:          2009/10/08 09:17:25 AM
Event ID:      6161
Task Category: None
Level:         Error
Keywords:      Classic
User:          myuser
Computer:      termserver.mydomain.com
Description:
The document Test Page, owned by user, failed to print on printer user (redirected 4). Try to print the document again, or restart the print spooler.
Data type: RAW. Size of the spool file in bytes: 134159. Number of bytes printed: 0. Total number of pages in the document: 1. Number of pages printed: 0. Client computer: \\TERMSERVER. Win32 error code returned by the print processor: 5. Access is denied.


I am stuck, and dont know what to do. I came across an article that said it could be that the temp file that Windows was trying to create was being "access denied" because the user did not have privileges to do so, and another website that said the user needs to be able to have rights to the print spooler??? Surely this is not necessary?

Please help, Thank-you in advance!
LVL 3
wimpie_asgAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

wimpie_asgAuthor Commented:
Hi,

For the people reading this, and for the completion of this thread, this is what I did to solve the problem:

The reason for this error is due the remote users that could not write to the spool directory / did not have the rights. I dont know if this is an official Microsoft the solution, but it dentally worked for me, over 40 people can now print remotely due to it. All I have done was to give all the people rights to the spool directory c:\windows\system32\spool. After giving people rights to this directory, it works! Now, like I said, if there is any one else that has a better solution to this problem, or a more official Microsoft solution, please share!

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
bklynhubbyCommented:
Hello.  Did you grant the rights to c:\windows\system32\spool on the print server or the individual workstations?  Thanks.
MarcusPfeifferCommented:
BINGO! I've been fighting with this problem as well for two months and it was exactly that simple!

Thanks many times over Wimpie!
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

RLUNTCommented:
This was fantastic.

This is one of those out of the box DUH! moments for Microsoft.

I have a new windows 2012 server with the same error.  Why when the Print Management role was installed the security was not set is just unfathomable.

But, again, Experts-exchange gets the answer right the quickest!
htottenCommented:
Worked for one our customers as well...This one was Server 2008R2  (TS)
TPAMisfitCommented:
We are having the same issue I think, and this did not solve it. We have a Terminal Server (2008) with TSWEB installed. When Users attempt to print to their local workstation through redirection, we see this error on the Terminal Server: Win32 error code returned by the print processor: 5. Access is denied. We've given Full access to DOmain Users, Everyone, etc. in hopes of hitting this, but it continues to fail. Any help is appreciated.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.