Exchange 2007 SCR Enable-StorageGroupCopy Problem

Rynstein
Rynstein used Ask the Experts™
on
Hi there,

I've got 2 CCR sites replicated, and I've just done my first failover successfully.  However, when I try to enable-storagegroupcopy back to the original ccr cluster, i get the error

"Enable-StorageGroupCopy : Could not find a directory entry for the host CMS.domain.com.
At line:1 char:24
+ Enable-StorageGroupCopy  <<<< "CMS\SG01" -standbymachine servername -replaylagtime 0.0:0:0"

When I first did my failover, I noticed that I didn't have DNS registration must succeed on the cmsname, and that's now fixed.  

I've tried the following:
I had to add the DNS entry manually, as it had dissappeared after my failover
I've tried stopping and starting the cluster at my active ccr site
I've tried adding a host entry at the destination
I can run "Get-StorageGroupCopyStatus and it finds the cms, and it just comes back with "NotConfigured"

Any ideas?  

Thanks in advance!

Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Satya PathakLead Technical Consultant

Commented:
To resolve this problem, install Update Rollup 7 for Exchange 2007 Service Pack 1. For more information about Update Rollup 7 for Exchange Server 2007 Service Pack 1, see the following Exchange Help topic:

http://technet.microsoft.com/en-us/library/ee221171.aspx

http://support.microsoft.com/kb/961281

Author

Commented:
Thanks for the links Satya. I have installed SP2 though however.  Would you suggest reinstalling SP2?
Justin DurrantSr. Engineer - Windows Server/Virtualization

Commented:
^^ yes.. SP2 would even be better :)
Commented:
Thanks for the advice.  What I ended up having to do, was manually run AD replication within Sites and Services manually.   Even though I had waited for a day for it to replicate.

 I find that everytime I do something with the StorageGroupReplication, that it's best to run AD replication.

Thanks for your help.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial