frame-relay issue

mikey250
mikey250 used Ask the Experts™
on
Ive configured the following:

3 routers
frame-relay switch router
singapore router
london router

1.  but I keep seeing this message pop up but dont understand what it means?

Singapore#
*Mar  1 00:37:11.431: IP-EIGRP(Default-IP-Routing-Table:100): Neighbor 192.168.

2. Also im seeing in some examples when:?

sh frame-relay map is entered I should see something like:

router#show frame-relay map
serial/0/0  (up): ip 0.0.0.0 dlci 18 (0x12), 0x420)
                     broadcast,
                     Cisco, status defined, active
serial/0/0  (up): ip 192.168.192.2 dlci 18 (0x12, 0x420), dynamic
                        broadcast, , status defined, active

3. BUT i only see so im not sure?

router#show frame-relay map
serial/0/0  (up): ip 192.168.192.2 dlci 18 (0x12, 0x420), dynamic
                        broadcast, , status defined, active

from what i can see, all 3 routers show both dlci 17 & 18 as UP UP!!
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Hi,

*Mar  1 00:37:11.431: IP-EIGRP(Default-IP-Routing-Table:100): Neighbor 192.168.
 
What is the full message in the log?

Author

Commented:
Building configuration...

Current configuration : 1188 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname FRAMERELAYSWITCH
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
ip cef
!
ip audit po max-events 100
frame-relay switching
!
!
interface Serial0/0
 description Connected to London
 no ip address
 encapsulation frame-relay
 clockrate 56000
 no fair-queue
 frame-relay intf-type dce
 frame-relay route 17 interface Serial0/1 18
!
interface Serial0/0.17 point-to-point
!
interface Serial0/1
 description Connected to Singapore
 no ip address
 encapsulation frame-relay
 clockrate 56000
 frame-relay intf-type dce
 frame-relay route 18 interface Serial0/0 17
!
interface Serial0/1.18 point-to-point
!
interface Serial0/2
 no ip address
 shutdown
!
interface Serial0/3
 no ip address
 shutdown
!
interface Ethernet1/0
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!
router eigrp 100
 network 192.168.192.0
 no auto-summary
!
ip http server
no ip http secure-server
ip classless
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

FRAMERELAYSWITCH#
---------------------------------------------------------------------------------------

Building configuration...

Current configuration : 724 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Singapore
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
frame-relay switching
!
!
!
interface Ethernet0
 ip address 192.168.232.1 255.255.255.0
!
interface Serial0
 ip address 192.168.192.4 255.255.255.0
 encapsulation frame-relay
 no fair-queue
 frame-relay map ip 192.168.192.2 18 broadcast
!
interface Serial0.18 point-to-point
!
interface Serial1
 no ip address
 shutdown
!
router eigrp 100
 network 192.168.192.0
 network 192.168.232.0
 no auto-summary
!
ip http server
ip classless
!
!
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
end

Singapore#
------------------------------------------------------------------------------------------------

Current configuration : 728 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname London
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
!
!
interface Ethernet0
 ip address 192.168.200.1 255.255.255.0
!
interface Serial0
 ip address 192.168.192.2 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 192.168.192.4 17 broadcast
!
interface Serial0.17 point-to-point
!
interface Serial1
 no ip address
 shutdown
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
!
router eigrp 100
 network 192.168.192.0
 network 192.168.200.0
 no auto-summary
!
ip http server
ip classless
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end

London#

Author

Commented:
Singapore#
Singapore#sh frame-relay pvc

PVC Statistics for interface Serial0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          1            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 18, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0

  input pkts 46            output pkts 53           in bytes 2920
  out bytes 3436           dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 44        out bcast bytes 2816
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:40:57, last time pvc status changed 00:38:06
Singapore#

Singapore#
Singapore#sh frame-relay map
Serial0 (up): ip 192.168.192.2 dlci 18(0x12,0x420), static,
              broadcast,
              CISCO, status defined, active
Singapore#

Singapore#sh frame-relay lmi

LMI Statistics for interface Serial0 (Frame Relay DTE) LMI TYPE = CISCO
  Invalid Unnumbered info 0             Invalid Prot Disc 0
  Invalid dummy Call Ref 0              Invalid Msg Type 0
  Invalid Status Message 0              Invalid Lock Shift 0
  Invalid Information ID 0              Invalid Report IE Len 0
  Invalid Report Request 0              Invalid Keep IE Len 0
  Num Status Enq. Sent 247              Num Status msgs Rcvd 248
  Num Update Status Rcvd 0              Num Status Timeouts 0
  Last Full Status Req 00:00:58         Last Full Status Rcvd 00:00:58
Singapore#
-----------------------------------------------------------------------------

London#sh frame-relay pvc

PVC Statistics for interface Serial0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          1            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 17, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0

  input pkts 52            output pkts 47           in bytes 3372
  out bytes 2984           dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 43        out bcast bytes 2752
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:39:56, last time pvc status changed 00:39:56
London#

London#sh frame-relay map
Serial0 (up): ip 192.168.192.4 dlci 17(0x11,0x410), static,
              broadcast,
              CISCO, status defined, active
London#

London#sh frame-relay lmi

LMI Statistics for interface Serial0 (Frame Relay DTE) LMI TYPE = CISCO
  Invalid Unnumbered info 0             Invalid Prot Disc 0
  Invalid dummy Call Ref 0              Invalid Msg Type 0
  Invalid Status Message 0              Invalid Lock Shift 0
  Invalid Information ID 0              Invalid Report IE Len 0
  Invalid Report Request 0              Invalid Keep IE Len 0
  Num Status Enq. Sent 242              Num Status msgs Rcvd 242
  Num Update Status Rcvd 0              Num Status Timeouts 0
  Last Full Status Req 00:00:27         Last Full Status Rcvd 00:00:27
London#
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
hi rochey,

thats all it shows me:  

London#
*Mar  1 00:41:08.683: IP-EIGRP(Default-IP-Routing-Table:100): Neighbor 192.168.0
*Mar  1 00:41:22.647: IP-EIGRP(Default-IP-Routing-Table:100): Neighbor 192.168.0
*Mar  1 00:41:36.159: IP-EIGRP(Default-IP-Routing-Table:100): Neighbor 192.168.0

the rest goes off the screen.  ive decreased the fonts and it doesnt make a difference!!
*Mar  1 00:37:11.431: IP-EIGRP(Default-IP-Routing-Table:100): Neighbor 192.168.
 
please can you post the rest of the message in the log.

Author

Commented:
i havent a log setup yet as not sure how to do it on a router for this yet so i just read off the screen for the time being!
Hi,

Can the routers ping each other?

Author

Commented:
London#ping 192.168.192.4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.192.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 68/70/72 ms
London#

London#ping 192.168.232.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.232.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 68/71/72 ms
London#
--------------------------------------------------------------------------------------------------
Singapore#ping 192.168.192.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.192.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 72/72/72 ms
Singapore#

Singapore#ping 192.168.200.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.200.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 72/72/72 ms
Singapore#
please can you do

show ip eigrp neighbor

on both routers.
*Mar  1 00:41:08.683: IP-EIGRP(Default-IP-Routing-Table:100): Neighbor 192.168.0
it looks as though there is a neighbor on a different subnet, do you have anything else connected?

Author

Commented:
no nothing else is connected at all just.  Although in order to get ping connectivity Ive plugged the singapore & london ethernet connection into a switch using ports singapore port2 & london port 2.

Author

Commented:
Singapore#sh ip eigrp neighbor
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.168.192.2           Se0              148 01:49:59   52   312  0  4
Singapore#
*Mar  1 02:50:11.335: IP-EIGRP(Default-IP-Routing-Table:100): Neighbor 192.168.

London#sh ip eigrp neighbor
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.168.192.4           Se0              148 01:50:22   52   312  0  4
London#
*Mar  1 02:48:22.299: IP-EIGRP(Default-IP-Routing-Table:100): Neighbor 192.168.
no nothing else is connected at all just.  Although in order to get ping connectivity Ive plugged the singapore & london ethernet connection into a switch using ports singapore port2 & london port 2.

port2 of what?

Author

Commented:
i mean ports 2 & 3.

Author

Commented:
according to my guide i have it says that on the singapore & london router should have a statement such as:

frame-relay interface-dlci 18
frame-relay interface-dlci 17

ive added both these yesturday and still everything is still showing as active, so ive removed them as per the original config on this thread ive sent!

Author

Commented:
im not quite grasping when i should or shouldnt use these commands in this case:?

frame-relay map ip 192.168.192.4 17 broadcast
frame-relay map ip 192.168.192.2 18 broadcast

Author

Commented:
ive just read,

if the singapore router had an incorrect frame-relay map statement instead of a frame-relay interface-dlci statement, the self-correcting automatic inverse arp process would not have taken place and the connection between singapore and london would have been down.  As inverse arp is automatically disabled for an interface that has a frame-relay map statement configured.

im now assuming these are improved commands over a period or a security measure dependant on network design circumstances or requests!!?

Author

Commented:
or is it the other way round.  there seems to be some gramatical inconsitencies in my reading!?
Hi,

Try the following on both routers.

router eigrp 100
 passive-interface ethernet0

Author

Commented:
Hi done, just waint now.  Yes i understand that command as it means ethernet interface would recognise packet flow but not forward anything on.

Author

Commented:
it looks like it hasnt come back!

Author

Commented:
that looks like it resolves part1!  what about part2 regarding how the "sh frame-relay map" should look?
please can you repost the show frame-relay map from each router.

Thanks.

Author

Commented:
Singapore#
Singapore#sh frame-relay map
Serial0 (up): ip 192.168.192.2 dlci 18(0x12,0x420), static,
              broadcast,
              CISCO, status defined, active
Singapore#
--------------------------------------------------------------------------
London#sh frame-relay map
Serial0 (up): ip 192.168.192.4 dlci 17(0x11,0x410), static,
              broadcast,
              CISCO, status defined, active
London#
That looks ok now.

Author

Commented:
no probs!  thanks!!

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial