DPM 2007 tape library error

JeffersonCounty
JeffersonCounty used Ask the Experts™
on
I am setting DPM 2007 up.  So far all backups are going ok.  My next step is long term protection - tape backups.

When I first tried backing up to tape it worked but the first tape was the only one used.  Then no more tape drive.

When I do a 'rescan' in 'Management/Libraries' I get this message: "The rescan operation failed. For more details, view the jobs tab in the Monitoring task area. (ID: 31102)".  There is no info in the Monitoring tab.

I started the Tandberg Data Lib Tool, which sees the library:  Device 6: Exabyte VXA 1x10 1U [2:0:0] Type=8 Bus=1   Library found: Exabyte VXA 1x10 1U.  When I click on 'Inventory' all drives show up (Slot 1 is empty because it's in the tape drive).

My environment:  MS Server 2003 R2 Standard x64 SP2,  all critical updates applied, Tape drive: Exabyte VXA-3 SCSI (Driver 1.4.0.0), medium changer: Exabyte VXA Packloader 1x10 (Driver 2.0.0.0)

Any help will be greatly appreciated.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Are you using the native backup utility?   Are you sure that it can see and use tape libraries?
In you Windows Device Manager, do you see a top-level entry for Medium Changer, and separately entries for the tape drive(s)?  If you don't see the medium changer, then your OS doesn't know that you have a library, and the backup application won't either.

Author

Commented:
Thanks for your response.  Using the Lib Tool from Tandberg, the 'inventory' function lists all 10 slots.  #1 is in the drive (empty), #2-9 show as occupied with barcode values listed, #10 is the cleaner tape.

Device Manager:  'Medium Changers' lists the Exabyte PacketLoader and 'Tape Drives' lists the Exabyte SCSI drive separately.

The tape backup I intend to use is long-term protection in DPM.  Initially, I could copy to the tape in the drive, but not continue with the next tape in the library.  Now when I perform a 'rescan' in 'Management/Libraries', I get the aforementioned error - "The rescan operation failed. For more details, view the jobs tab in the Monitoring task area. (ID: 31102)".
Looking at Microsoft's page for DPM-supported tape devices, I do see the PacketLoader, but I only see 32-bit drivers listed; I wonder if that's a purposeful or accidental omission.
I also note that there are newer driver versions listed, and would recommend you get the latest:

Exabyte VXA PacketLoader 1x10 1U
     exapl32.sys, 2.01.0, 11/15/2005, unsigned, 32bit
VXA-320
     vxa32.sys, 1.10.1, 4/1/2005, signed, 32bit

Make sure your cabling and termination is correct, including length of SCSI cables.
If connectivity to the library was lost for some reason, it may be necessary to reboot the server to re-establish connectivity, although it's possible that disabling and re-enabling the HBA in Windows Device Mangler will pick up the library again.

It is possible that some other application is trying to claim the library; it's a pretty sure bet that you should not have the Tandberg utilities running while you are trying to run backup, as tape drives and libraries like to have only one "owner" or controlling application at a time.
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
I have 64 bit drivers installed.  Seems like the problems may have started about then.  Can I install 32 bit drivers for the tape library/drive in my 64 bit OS environment?

Side note:  first try to run ntbackup - finds tape drive & tape with backup data.  I select used tape, backup starts to 'mount the media' and I get an error: backup device is not responding.

second try - select 'new' tape and get a message that says no free media but found "Nameserver2-0000001" in device Exabtye VXA-3 SCSI Tape Drive"  Do I want to use it.

So, I see the drive, see the tape and it's label but can't use it.
I don't think that NTBackup supports autoloaders... if you load the tape through the library OCP, can you doa backup?

Author

Commented:
Sorry for my poor response - flu bug.  I tried to install the 32 bit driver, but is rejected because the OS is 64 bit.  Now I'm concerned that my 64 bit OS is incompatible with the tape library andf drive.  Any truth to this?
I don't know... would suggest you look up the library's compatibility matrix on the manufacturer's web site.   But the symptoms you describe would be explained by that.

Author

Commented:
That seems to be it - the DPM tape library compatability list only mentions 32 bit.  So this means a complete redo, darn it.

Thank you for your help.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial