cisco 1751 speed issue

mmercaldi
mmercaldi used Ask the Experts™
on
I am paying for a 25mb/10mb line with fios and i have it hooked up to a 1751 router with 4esw card, as far as i know all 5 ports on the router can go up to 100mb/sec
But for some reason when I do a speed test on a pc hooked directly up to the router, my download speed is only at 9.5 mb, and I only have 1 pc hooked up to my cisco running nothing but firefox.  Does anyone know if the 1751 series cannot receive wan speeds over 10mb?  Also if it helps below is my config
Using 4014 out of 29688 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$oD3R$c41VqaYj9RJYyaLi5DAXI/
!
username mercxi privilege 15 password 0 merc84
memory-size iomem 15
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
aaa new-model
!
!
aaa authentication login userauthen local
aaa authorization network groupauthor local 
aaa session-id common
ip subnet-zero
!
!
ip name-server 4.2.2.1
!
ip dhcp pool DATA
   network 50.0.0.0 255.255.255.0
   dns-server 50.0.0.1 4.2.2.1 
   default-router 50.0.0.1 
!
ip dhcp pool CABLE
   network 10.10.10.0 255.255.255.0
   dns-server 10.10.10.1 4.2.2.1 
   default-router 10.10.10.1 
!
!
ip cef
ip audit po max-events 100
no ftp-server write-enable
!
!         
!
!
! 
no crypto isakmp enable
!
crypto isakmp policy 1
 hash md5
 authentication pre-share
 group 2
!
crypto isakmp client configuration group mercgroup
 key merc84
 pool ippool
 acl 101
!
!
crypto ipsec transform-set mytransformset esp-3des esp-md5-hmac 
!
crypto dynamic-map dynmap 10
 set transform-set mytransformset 
 reverse-route
!
!         
crypto map clientmap client authentication list userauthen
crypto map clientmap isakmp authorization list groupauthor
crypto map clientmap client configuration address initiate
crypto map clientmap client configuration address respond
crypto map clientmap 10 ipsec-isakmp dynamic dynmap 
!
!
!
interface FastEthernet0/0
 ip address dhcp
 ip nat outside
 speed 100
 crypto map clientmap
!
interface FastEthernet1/1
 switchport access vlan 50
 no ip address
 speed 100
!
interface FastEthernet1/2
 switchport access vlan 10
 no ip address
 speed 100
!
interface FastEthernet1/3
 switchport trunk native vlan 50
 switchport mode trunk
 no ip address
!
interface FastEthernet1/4
 switchport access vlan 10
 no ip address
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 ip address 10.10.10.1 255.255.255.0
 ip access-group 150 in
 ip nat inside
!
interface Vlan50
 ip address 50.0.0.1 255.255.255.0
 ip nat inside
!         
router rip
 version 2
 network 10.0.0.0
 network 50.0.0.0
 no auto-summary
!
ip local pool ippool 50.0.0.100 50.0.0.105
ip classless
no ip http server
ip http secure-server
ip nat inside source route-map INTERNET interface FastEthernet0/0 overload
!
ip dns server
!
!
access-list 1 permit 50.0.0.0 0.0.0.255
access-list 1 permit 10.10.10.0 0.0.0.255
access-list 101 permit ip 50.0.0.0 0.0.0.255 any
access-list 150 permit tcp 10.10.10.0 0.0.0.255 any eq 3074
access-list 150 permit udp 10.10.10.0 0.0.0.255 any eq 3074
access-list 150 permit udp 10.10.10.0 0.0.0.255 any eq 88
access-list 150 permit tcp 10.10.10.0 0.0.0.255 any eq domain
access-list 150 permit tcp 10.10.10.0 0.0.0.255 any eq www
access-list 150 permit udp 10.10.10.0 0.0.0.255 any eq domain
access-list 150 permit tcp 10.10.10.0 0.0.0.255 any eq 4567
access-list 150 permit udp 10.10.10.0 0.0.0.255 any eq 63145
access-list 150 permit ip any any
access-list 151 permit tcp 10.10.10.0 0.0.0.255 any eq www
access-list 151 permit tcp 10.10.10.0 0.0.0.255 any eq 3074
access-list 151 permit tcp 10.10.10.0 0.0.0.255 any eq domain
access-list 151 permit udp 10.10.10.0 0.0.0.255 any eq domain
access-list 151 permit udp 10.10.10.0 0.0.0.255 any eq 88
access-list 151 permit udp 10.10.10.0 0.0.0.255 any eq 3074
access-list 152 permit tcp host 96.232.183.215 10.10.10.0 0.0.0.255 eq domain
access-list 152 permit tcp host 96.232.183.215 10.10.10.0 0.0.0.255 eq www
access-list 152 permit tcp host 96.232.183.215 10.10.10.0 0.0.0.255 eq 3047
access-list 152 permit udp host 96.232.183.215 10.10.10.0 0.0.0.255 eq 3047
access-list 152 permit udp host 96.232.183.215 10.10.10.0 0.0.0.255 eq 88
access-list 152 permit udp host 96.232.183.215 10.10.10.0 0.0.0.255 eq domain
!
route-map INTERNET permit 10
 match ip address 1
 match interface FastEthernet0/0
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
 password merc84
!
!
end

Open in new window

Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Since they're FastEthernet ports, each should support 100Mbps.  Realistically, the only way you're going to get an answer (more than likely) is to contact your ISP and talk with them.  As long as you reach a knowledgeable service rep, you should receive an answer - and possibly faster speeds!

Hope this helps...

Mike

Author

Commented:
thats what I am thinking too but I am checking to see if anyone else has other ideas
Commented:
Your router doesn't have the processing capability to handle that much bandwidth.  It has nothing to do with the speed the switch card can link up at, but how much processing capability the router has and what features are in use.  (NAT, VPN, etc.)

I'd upgrade to an 1841.
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Commented:
As a quick comparison, the 1751 can only handle 12,000 packets per second where the 1841 can do 75,000...

Author

Commented:
would the 871 be able to do the same thing? or maybe another cisco router that is at end of life?

Author

Commented:
also could you please tell me where you found that comparison?
Commented:
871 will give you a little more speed but not 25 Mbps....  More like 15-20?

Any reason it needs to be a router?  An ASA 5505 can handle up to 90 Mbps....  Much cheaper option.

http://www.cisco.com/web/partners/downloads/765/tools/quickreference/routerperformance.pdf

Author

Commented:
ah ok thanks I will be using ebay for this too THANKS

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial