Outlook 2007 Exchange Sync issue over VPN with Wireless Broadband

troy_g
troy_g used Ask the Experts™
on
Hi Guys, hope you can help with this frustrating issue we have!

We have a Lenovo ThinkPad T60, running Windows 7 Ultimate.  We are running Outlook 2007, connecting to a SBS 2003 via VPN.  When we are connected via any other Internet connection ( not on the same wired network as the business ) and VPN in, Outlook synchronises fine.  Even when connected directly to Exchange and the network wired in, it works fine.

We are in Australia and are using Telstra Wireless Broadband HSDPA modem Internet access on the go.  We can connect fine to the Internet and even VPN in to the network okay.  We can then view network drives and folders and even connect to Exchange fine.  Our signal strength is fine and we are getting 2Mbps download speeds.

However, the weird thing is that the folders just won't synchronise in outlook when connected via the Wireless Broadband HSDPA modem!  Have had the laptop sitting beside me now, for the last 1 hour, saying "Synchronizing Server changes in folder 'Inbox' ", but it isn't doing anything!  Even looking at the data sent/received it isn't having any transfers and therefore not synchronising Exchange.

Have tried all of the below and they haven't worked:

* Resetting the Send / Receive settings, to just do it on one folder
* SCANOST
* SCANPST
* Deleted the Outlook profile and recreated it
* Turned Windows firewall off
* Reset default security settings in Internet Explorer to the lowest level
* Deleted the Telstra connection software, rebooted and reinstalled

Am also VPN'ing in at the moment on a different computer and Exchange connects and synchronises okay.  Just also disconnected the wireless modem on the laptop and am at a remote location, with another separate wired Internet connection and it is happily synchronising exchange!? Isn't it moments like this, that you just wish you could . . . @#$%@#$% !!

Further to this, it definitely used to work!  The only thing that we did that might have changed some settings somewhere, is plugged into a hotel broadband Internet connection, but didn't end up using it and from then on, we are having this issue in synchronising Exchange.

Thanks so much in advance for anyone's help, would really appreciate it!
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
are you using ip addresses or dns names in the account options for the server name

Author

Commented:
thanks heaps Nelson for assisting - we are using DYNDNS for IP Address redirection, but am now connecting, just to the fixed IP address of the server and connecting successfully
so, if you are now connecting fine the problem is with the dyndns. I use dyndns for my clients that have dynamic ip's but would never use it in an environment using an exchange server.  I would ask the isp for a static ip, change my dns entries, and then all should be fine.  
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

I've had a similar issue like this. Except it was it Vodafone though.
What happenes is the software can try to use its "own" vpn software settings that can be comflicting.

You may have aldready tried this... but worth a shot if you haven't...

The way i ended up fixing it was to completly remove the Vodafone software from the machine (WIreless Broadband Software.- You may want to speak to Telstra to get some removal software (as there can be reg keys left behind)
Delete the Current VPN Settings you have (through your Network Connection Manager Console)
Reboot the system.
Reinstall the Modem+Software
Check to see if the Telstra Install kit, also installed the VPN Connection Kit as well (through the options) if you do find it, disable it
Then recreate the VPN Connection in the network management console in control panel - However use IP Address's instead of dns names just for now
Connect the INternet, make sure it is running correctly
then try to connect to the VPN
If you connect, make sure you can ping everything inside your network via DNS names (ie servername) OR At least via IP
Test Outlook at that point..

Simple, but worth a shot...

Otherwise you could have an issue with the windows MAPI Subsystem not being able to connect correctly... perhaps a Repair on the OS

Good Luck

Author

Commented:
thanks Nelson, sorry for not clarifying, but yes, we were using DYNDNS for the IP Address redirection, but now are just connecting to the Network via the static IP address that we have with our ISP.  And the weird thing is, that as we said when we connect not using our Telstra wireless Broadband connection, it connects fine!
do you have your clients set up in cached mode for outlook.

Author

Commented:
yes - confirming Cached Mode in Outlook 2007, not downloading shared or public folders . . .

Author

Commented:
thanks so much for your detailed thoughts The_Dark1, did a full removal of the Telstra software, including registry entries etc... rebooted, installed again and unfortunately, the same issue.  They don't have any VPN options in the connection manager software, so unfortunately lucked out there.

Confirming as well, that can see and ping other machines, including the server on the network.

Am connected to Exchange at the moment, but it is still stuck 'Synchronizing Server Changes' etc...
try this

 into TOOLS - ACCOUNT SETTINGS.

Select your exchnage account

Click on CHANGE

Click the MORE SETTINGS button

Click on the ADVACED TAB

Uncheck "Download public Folders Favorites"

OK - NEXT - CLOSE.

Author

Commented:
thanks Nelson, confirming that this is unchecked.

Please see below for details of configuration screens in the Advanced Configuration section of Outlook 2007
1.jpg
2.jpg
3.jpg
4.jpg
5.jpg
6.jpg
Here's another thought...

Have you tried using Outlook 2007 native RPC over HTTP?

So long as your exchange server supports it......
just to be clear this only happens with a WIRELESS connection but not with a wired connection as stated here.  am i correct to say it ALWAYS works with a wired connection

"However, the weird thing is that the folders just won't synchronise in outlook when connected via the Wireless Broadband HSDPA modem!"

Author

Commented:
Thanks for the thought re : RPC over HTTP, did think about that and had a look around, but couldn't get clear instructions for it - as anyone have good tips re : this ?

Author

Commented:
Thanks Nelson, confirming that this issue only happens with our Broadband HSDPA modem connection, not normal wireless or wired connections.
Nat WallisTechnical Services Manager

Commented:
I think that everything is probably okay with everything but your telstra connection.

everything you say works, except when you connect via your nextg wireless modem is that correct?

firstly, what modem are you using?

Have you tested this device on a XP Pro laptop or similar?

I know that telstra isnt going to give you any service running Windows 7 - they probably dont even know what it is.

How are you VPNing into the server - PPTP? IPsec? SSL?

Are there any issues with accessing files across the network?
Nat WallisTechnical Services Manager

Commented:
"Am also VPN'ing in at the moment on a different computer and Exchange connects and synchronises okay."

Sorry I didnt see this before. How is this being done - IE OS & Wireless connection?
hmmm.... i'm in the US and not familiar with Telstra but have you spoken with them....dont settle for anyone less than a level 3 tech....  if anything tell them "thats not a knife...." haha

pls post or send any exchange logs that have been created.....by now you should be logging any Xchng errors
Nat WallisTechnical Services Manager

Commented:
I am not sure if Telstra employ any Level 3 techs - well any that mere morals can access! :-D

Author

Commented:

Thanks all, to answer your questions:

  • Yes, everything works when using when using the Telstra Nextg Wireless HSDPA Modem ie. able to view Server & other File Shares on the network and browse the Internet
  • Haven't tested it on another laptop, but will this evening
  • Just using standard MS VPN into the Server, i think that is just PPTP ?
  • No issues in accessing files across the network
  • The VPN from the other computer is same configuration ( Windows 7, Office 2007, SBS 2003 ) as this laptop and disconnecting from a separate Internet connection, back to the main office and synchronising fine
  • Surprisingly, there are no Exchange errors in the Exchange Logs, just network connection errors when I did SCANOST
So frustrating isn't it !?

Please see below for screen shots of VPN setup . . .

9.jpg
8.jpg
7.jpg
This is gonna hurt my brain to night....its 2am here in the states so gotta go but i'll continue helping in the morning (atleast morning for me)

Author

Commented:
thanks so much, appreciate it !

Author

Commented:
please find attached the Outlook 2007 screen, showing where it looks like it's synchronizing, but stays on this screen

and also, our wireless broadband status card, showing after 15 mins, hardly any data transferred . . .
1.jpg
2.jpg
to use RPC over HTTP
you need a SSL Certificate (either self assigned or purchased)
you need to install it on to the device you wish to connect RPC over HTTP into the "Trusted Certificates"

You can follow these instructions:

http://technet.microsoft.com/en-us/library/cc179036.aspx

It is very similar to OL2003 and using that over RPC over HTTP
Here is another link, it is for OL2003 however the connection method remains the same for both versions... just a difference in installing the certifcate...

I cannot stand telstra... bashed my head against so many walls talking to them.
Couple of things,

1. How is your VPN connection established is it IPSEC over UDP or TCP?

2. Can you access any other network resources while connected to the VPN via the wireless card or are you having the same problem.

3. How large is the exchange mailbox? With cached mode this shouldn't be an issue, but just to be thorough.

I have had instances with some ISP's that block TCP vpn traffic, so you may need to switch the connection to UDP. You will get connected, but nothing will happen after that.

Nat WallisTechnical Services Manager
Commented:
From what I can gather answer to 3 questions
1 - I believe this would be PPTP as most basic to setup
2 - I believe this is working fine
3 - Yes cached mode is configured
Last comment - most likely the issue - Telstra in one way or another.

From what I can see, is that everything is pointing to the card/telstra.

You have another machine working. same vpn, os, office etc etc. only thing different is the internet connection.

if you dont use the telstra wireless and use other internet connection that it is working fine.

I am just not sure why you are playing with all these other settings when it would be highly unlikely to be the problem - in my opinion.

What I would do is test the wireless telstra card in the other computer that vpn in fine and see how that goes. I would guess it would have the same issues. if it does it confirms issue and isolates problem.

Is the modem a Telstra or Bigpond one? What version connection manager are you running? What model modem do you have?
Futher to NaughtyNats Comments, I think you mentioned this is Win7?
Is this the RC Edition or the Full Version? As when I had the RC edition of Win7 I couldnt get OL007 working either, I needed to settle for RPC over HTTP...

WIth Win7 Ent Edition it has worked perfectly...

Does this configuration work on other versions of the MS OS Suite? (XP, Vista)

Nat WallisTechnical Services Manager

Commented:
I thought Win7 was suppose to just work! :-)
Gotta love Windows (or Microsoft's I should say) ideal of "everything just works"

If it did, I wouldnt have a job sadly :(

:)

Author

Commented:
Thanks so much everyone, for all of your assistance.

Please see below for updates and answers to your questions:

  • Have tested on another laptop ( also Win 7 ) and unfortunately, the same issue.  Don't have another laptop available that isn't Win 7 - that's the problem with being too efficient and upgrading everyone ! :-)
  • VPN we believe is just set up as standard, being TCP  | Auric1983 - good point, regarding opening the UDP port and / or setting up the VPN, to use UDP - do you know where I can access that setting?
  • Can definitely access other network resources when successfully VPN into Server - including successfully connecting to Exchange, just not Synchronising!
  • Nothing in Exchange error logs
  • Exchange Mailbox is 8Gb ( big i know, but keep in mind, that it was actually working successfully when it was at 10Gb, till I archived )
  • The BigPond modem we are using is Sierra Wireless AC880E 7.2 Mobile Card and the software is BigPond Wireless Broadband Connection Manager 2.13.6
  • Using full verion Win 7 Ultimate RTM
  • Would like to try RPC over HTTP, but it isn't patched to SP2, as had issues with MMC snap-in when doing that, so it looks messy to setup, but will work at giving that a go.
What do you think ?!
Here is something worth a try, I have noticed that applications that dont support Windows 7 have their little hicups, if we believe the issue is the Telstra card (which is something I am leaning to) Why not try to run (install the app) in "Compatibiity Mode"

Right click on the Telstra application's exe, and select the Compatibility tab, and run the application in XP SP2/SP3 or Even Vista...

Given your above settings, I cannot see anythnig further to change or modify, as if you communication with everything else on your network, there shouldnt be anything else to modify...

You have tried this on a differenet type of internet connection yes? IE Internet cafe, or from your home DSL Connection? And that works (Either cabled or wireless... What i mean is, does it work with any other type of DSL Connection external to your business?

Author

Commented:
Thanks for that, good thought, hadn't thought about the compatibility settings; just tried it with the compatibility set for XP SP2 and unfortunately, still no joy.

Confirming that yes, was able to synchronise at the airport lounge with their wireless Internet connection and also 2 separate external, wired DSL connections ( am on that now and it synchronises ok damn it )

Does anyone think the size of the OST file could be the issue ?  Have quick speeds to syncronise with over the wireless HSDPA am going to try with a new mailbox and let you know how it goes; but on that point, have already redone this Outlook profile, so don't know if that is the issue.

Will also look at re-imaging the laptop, but it has the same issue on a separate laptop, maybe will have the same issue again; oh the joy!
That was my next suggestion, try a different mailbox... however I cant see that helping too much as if the file sync's locally on the network, it is only ever going to sync changes on the file... which would not be Gigs in size... megs maybe... (pending on the amount of time between sync) but not gigs...

Its Telstra and Windows 7 ... enemies....lol

Let me know how you go with the new mailbox
Nat WallisTechnical Services Manager

Commented:
Well you are a very persistant in trying to get this to work!

Yes as its cached it shouldnt be an issue but wouldnt be suprised since it is an absolute monstor @ 8GB! I always set limit of 2GB even for myself!

Everything points towards issue with telstra.

I dont have any 880, only the 885 which are quite different and the telstra wireless gateways - so I can not test unfortunately with my system.

Have you been game enough to try and get any sense out of telstra about the issue? or they jsut say W7 isnt supported?
2gb? wow, we have a 250meg mailbox limit, but I have a large number of users here, and 8gb is just insane...

Not sure if you can change the connection from TCP/UDP for PPTP vpn connections, I just set one up on my win7 box and could not find the settings.

It may very well be a firewall issue or a probelm with the carrier. I have a 3G USB dongle I can test with but it's a different carrier.
Did you get any further in this matter?

Author

Commented:
sorry for the delay, narrowing it down to Server issues, as re-created Outlook profile and size of OST file climbed to 15Gb ?? when on other machine it is down to 3Gb

will report back shortly !

Author

Commented:
Thanks so much for all your assistance guys, it was the weirdest thing we have encountered where it was sporadically working and then not.

So, in frustration we have decommissioned that server and commissioned a new SBS 2008, where it works fine!

So, we now know that Telstra Next G, along with Windows 7 and SBS 2008 work !!

Thanks again to all for your assistance, please understand me sharing the points around, as you all did assist . . .

Author

Commented:
everyone contributed magnificently, thank you so much!

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial