Cisco 877W, ADSL and DNS settings

PugwashXP
PugwashXP used Ask the Experts™
on
I am trying to setup ADSL access on a new 877W router. I can connect to my ISP but cannot get DNS/domain name resolution to work. The running config is attached. I am asking my ISP for DNS servers.

Version info:
Cisco IOS Software, C870 Software (C870-ADVIPSERVICESK9-M), Version 12.4(24)T1, RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2009 by Cisco Systems, Inc.
Compiled Sat 20-Jun-09 02:20 by prod_rel_team

ROM: System Bootstrap, Version 12.3(8r)YI4, RELEASE SOFTWARE

I am using CLI to configure the router.
What have I missed out/got wrong.

Thanks
RunningConfig-192.168.1.1-V2.txt
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Ilir MitrushiIT Infrastructure and Security Architect

Commented:
add to your config
ip domain-lookup - so the router performs dns queries
ip name-server <ip address> - where ip address is the ip of the dns server your isp will give you

Author

Commented:
Thanks - but that made no difference. The router is picking up the DNS server from my ISP but this is not being made available to a PC attached to the router.

My current config is below and the attached file has a connection test which shows that the DNS is being picked up correctly - it is just not being passed through.

Thanks in advance


Router#term len 0
Router#show run
Building configuration...
 
Current configuration : 2727 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
no logging buffered
enable secret 5 $1$aKnH$v553C2g6OjQ.TcJnHixUs1
enable password 7 002521225508595F1E
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local 
!
!
aaa session-id common
clock timezone PCTime 0
clock summer-time PCTime date Mar 30 2003 1:00 Oct 26 2003 2:00
!
!
dot11 syslog
ip source-route
!
!
ip dhcp excluded-address 192.168.1.1 192.168.1.99
ip dhcp excluded-address 192.168.2.1 192.168.2.99
!
ip dhcp pool Internal-net
   import all
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1 
   lease 4
!
ip dhcp pool VLAN20
   import all
   network 192.168.2.0 255.255.255.0
   default-router 192.168.2.1 
   lease 4
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
username xxx privilege 15 password 7 08007E6A584A574E03
! 
!
!
archive
 log config
  hidekeys
!
!
!
bridge irb
!
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 0/38 
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
!
interface FastEthernet0
 spanning-tree portfast
!
interface FastEthernet1
 spanning-tree portfast
!
interface FastEthernet2
 spanning-tree portfast
!
interface FastEthernet3
 spanning-tree portfast
!
interface Dot11Radio0
 no ip address
 shutdown
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root
!
interface Vlan1
 description Internal Network
 no ip address
 ip nat inside
 ip virtual-reassembly
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface Dialer0
 description ##Dialer0##
 ip address xx.xx.xx.xx 255.255.255.0
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 no ip route-cache cef
 no ip route-cache
 no ip mroute-cache
 dialer pool 1
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname xxx
 ppp chap password 7 132425365A5F56732A
 ppp ipcp dns request
 ppp ipcp address accept
!
interface Dialer1
 no ip address
!
interface BVI1
 description Bridge to Internal Network
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
ip http server
no ip http secure-server
!
!
ip nat inside source list 100 interface Dialer0 overload
!
access-list 100 permit ip 192.168.1.0 0.0.0.255 any
dialer-list 1 protocol ip permit
!
!
!
!
!
control-plane
!
bridge 1 route ip
!
line con 0
 password 7 052A342B701F1C5008
 no modem enable
line aux 0
line vty 0 4
 password 7 072E13681F5A4B5C06
!
scheduler max-task-time 5000
end

Open in new window

WAN-Troubleshooting-Report.doc
IT Infrastructure and Security Architect
Commented:
I am sorry I didn't notice that your dhcp config is lacking the entry for the dns server. Please add to your dhcp config this
dns-server 192.168.1.1
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
Finally solved it using the above (which did not work on its own) and the use of "ip dns spoofing".

Thanks for your pointers

Author

Commented:
Need additional parameter included in posting
Ilir MitrushiIT Infrastructure and Security Architect

Commented:
ip dns spoofing shouldn't be needed under normal circumstances.
check this link
http://www.cisco.com/en/US/docs/ios/12_3t/12_3t2/feature/guide/gtdnsspf.html

Configuring DNS Spoofing
This feature turns on DNS spoofing and is functional if any of the following conditions are true:

"The no ip domain-lookup command is configured.

"IP name server addresses are not configured.

"There are no valid interfaces or routes for sending to the configured name server addresses.

If these conditions are removed, DNS spoofing will not occur

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial