troubleshooting Question

Bug in MSSQL 2k8 Report Builder 2.0?

Avatar of CallConnection
CallConnection asked on
Microsoft SQL Server 2008SSRS
9 Comments1 Solution1368 ViewsLast Modified:
I've come across what appears to be a bug in SSRS Report Builder 2.0. Designing a parameter based report and deploying it is fine. However, when I reopen the report via Report Builder it's losing part of the parameter definition.

The report is very basic with a single parameter (datatype text,allow nulls,no default value). After deploying the valid report,reopening and executing I get...

Error:
The AllowBlank property of report parameter pName is false. However, the DefaultValue property contains a value that violates the AllowBlank property condition. (rsParameterValueNullOrBlank).

When looking into the 'Default Values' of the parameter, 'Specify Value' is now selected with a blank value. To correct this I have to select 'No default value' or (null) in the value.

Does anyone know of a fix\workaround for this?


ASKER CERTIFIED SOLUTION
Join our community to see this answer!
Unlock 1 Answer and 9 Comments.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 9 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros