SBS 2008 Can't connect to my RWW from outside my network

allroundComp
allroundComp used Ask the Experts™
on
Hello,

I've set up an windows SBS 2008 server.
I want to use the Remote Web Workplace function of this server from outside my network.
When i try to reach it from inside my network it works perfectly.
I have a registered Dyndns (eg site.mysite.info that points to my external ip adress).
When i type this Dyndns from within my network i get redirected to my RWW, when i type my external ip-adress i get redirected to a site 'welcome to IIS 7".
From outside my network i can't reach my RWW neither by typing my Dyndns nor my external IP-adress.
The ports 3389, 443, 1723, 80, 4125 on my router are forwarded to the internal IP of my SBS2008.
My router is a Linksys(cisco) WRT320N gigabit router.
I can ping my dyndns correctly.
PPTP works from an outside network to my network and i can connect from an outside network to the remote desktop of my server with RDP.
I guess this means that there's nothing wrong with the port forwarding part of my router.

Maybe the following is causing my problems: I had to recreate the Self-Invoked Certificate from SBS2008 because the first one was created with the standard remote (remote.site.mysite.info) prefix.
I needed a Certificate without the remote prefix, so i had to recreate it by using advanced settings in that wizard.

I have set up al lot of remote web workplaces in SBS2003 and it was no big deal to get those working.
This one is the first in SBS2008 and it's giving me a lot of headaches.

Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Author

Commented:
Very urgent problem,
I've increased point value to 500

Note: I've installed the SBS2008 certificate on the computer outside our network where i try to connect to our RWW .  I don't know if this is necessary, but it's done.
Top Expert 2013

Commented:
One issue is the ports.
You do not need 3389, that is for RDP only, not RWW
You should not use 80, that is for running a website which is very risky on a DC/SBS
1723 is for the VPN
For RWW you need 443 and 987
987 on SBS 2008 replaces 4125

The certificate may also be a problem. It needs to match the name you are using to connect to the server
Thanks for the reply Will.
I added the 3389 port so i could access the server remotely through RDP,
as soon as i get the RWW working i will remove it again.

Anyway, after two days of  headaches i've found the problem.
In belgium, there's a crappy ISP called Telenet.
They're blocking port range 0-1024.

So all users in Belgium who might have the same problems as me.
Check your ISP, if it's telenet, I suggest to switch to ADSL.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial