BACKUP WAN USING SWITCHES AND LAN-EXTENSION

1w3
1w3 used Ask the Experts™
on
Hi

I am trying to implement redundancy between two sites using LAN-EXTENSION from two different Service Providers.The following is the configuration and I want FAILOVER to happen automatically WITH TWO LINKS PLUGGED IN ALL THE TIME  .
When I plugin both the links I am not able to connect to SITE A from
SITE B or Vice Versa with the following configuration.IF I SHUTDOWN  BACKUP LINK or PRIMARY LINK on SITE B everything is working.Please Advise.
Right now I have shutdown interface FastEthernet0/48 on 3550-SITE B and everything seems to be good but I want this interface FastEthernet0/48 on 3550-SITE B to be UNSHUT AND STILL EVERYTHING SHOULD BE WORKING

Thanks in Advance






4006-SITE A#

!
interface FastEthernet2/43---------------------primary Service provider A
 description primary-LAN-X
 switchport access vlan 24
 switchport mode access
 speed 100
 duplex full
end

!
interface FastEthernet3/12---------------------backup Service Provider B
 description BACKUP-LAN-X
 switchport access vlan 24
 switchport mode access
 speed 100
 duplex full
end

interface Vlan24
 ip address 10.32.0.7 255.255.252.0
 

ip route 0.0.0.0 0.0.0.0 10.32.0.5
ip route 10.32.64.0 255.255.252.0 10.32.0.1
ip route 10.32.72.0 255.255.254.0 10.32.0.1



3750-SITE B:

interface GigabitEthernet1/0/1---------------cross over connection to 3550-SITE B:interface FastEthernet0/1
 switchport mode access
 power inline never


interface Vlan1
 ip address 10.32.0.1 255.255.252.0

ip route 0.0.0.0 0.0.0.0 10.32.0.5



3550-SITE B:

interface FastEthernet0/1---------------------cross over connection to 3750-SITE B:interface FastEthernet0/1
 no ip address
 duplex full
 speed 100

interface FastEthernet0/47------------------primary Service provider A
 description to SERVICE POVIDER A
 no ip address
 duplex full
 speed 100
end


!
interface FastEthernet0/48-----------------backup Service Provider B
 description to SERVICE POVIDER B
 no ip address
 duplex full
 speed 100
end

interface Vlan1
 ip address 10.32.0.10 255.255.252.0
 no ip route-cache

ip default-gateway 10.32.0.1
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Hi, for failover what technology you want to use, for this switch i think you can use simple spanning tree protocol. And you can use hsrp also. Can you post your network diagram for better understanding.
Hi there,

Are you trying to connect two switches from two vendors with two ethernet cables? (Perhaps I did not understand the question entirely)

If this is the case, then configure the two ports on both switches as a trunk. If the switches are from different vendors, then I would suggest you use the LACP trunk-type since this is an open standard that provides interoperability.

Regards,
Craig.
1w3

Author

Commented:
prvnkumark:

I want  to use spanning tree protocol and the above is the config related to this setup.i will try to draw this setup but in config I have put in comments
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

1w3

Author

Commented:
prvnkumark:

please see atatched diagram
DIAGRAM.gif
Don JohnstonInstructor
Top Expert 2015

Commented:
I your current configuration, spanning tree should be handling the loop prevention.

With both links up, please post the output of "show span" for the 4006 and 3550.

1w3

Author

Commented:
donjohnston:

Show span  attached

Thanks
4006-Show-Span
3550-Sh-Span
Hi,
Spanning tree should work for you, you dnt shutdown anyport , in cisco switches spanning tree is enabled defaultly, and it is pvst i mean per vlan spanning tree protocol. so for each vlan it will have different spaaning tree instance to increase the convergence speed use rapid spanning tree protocol, usually spanning tree takes more then 50 seconds to converge which is not good so you can use rapid spanning tree protocol. You can find lot of document on how to configure rapid spanning tree protocol.
try it if does not work send me the running config i will change the settings for you.

http://www.cisco.com/en/US/products/hw/switches/ps708/products_configuration_example09186a00807b0670.shtml 

Go through this link it may be helpfull for you.
1w3

Author

Commented:
I have no problem with late convergence but Why is it that I loose connection when that port is enabled ?
Don JohnstonInstructor
Top Expert 2015

Commented:
Couple of issues here:
 
  1. 0/48 on the 3550 doesn't appear to be up.
  2. The 3550 is running 802.1d spanning tree while the 4006 is running 802.1w spanning-tree.
  3. You've got mis-matched VLANs on the links between the 4006 and 3550.
  4. The 4006 is the root for VLAN 24. The 3550 0/47 port has a cost of 19 yet is showing a root cost of 90. Which means your provider is participating in the spanning tree protocol.
If you fix 1 - 3 and the problem still exists, you may have to coordinate with the provider to resolve it.
1w3

Author

Commented:
donjohnston:

1.I have shut it down because when i bring it up I loose connection to SITE A

2.How do I fix this?

3.How do I fix this ?

Thanks
Don JohnstonInstructor
Top Expert 2015

Commented:
  1. I understand that. But it's hard to see WHY it's not working until we can see the spanning tree topology with the link up.
  2. "spanning-tree mode pvst" on the 4006 or "spanning-tree mode rpvst" on the 3550. Actually, you should use the same protocol as the provider.
  3. "switchport access vlan 1" on the 4006 ports going the the 3550 or "switchport access vlan 24" on the 3550 ports going to the 4006.
1w3

Author

Commented:
Thanks

3.Does VLAN IDs have to match ?Just ip subnets being the same doesn't work ?
1w3

Author

Commented:
3550-05(config)#spanning-tree ?
  backbonefast  Enable BackboneFast Feature
  etherchannel  Spanning tree etherchannel specific configuration
  extend        Spanning Tree 802.1t extensions
  portfast      Spanning tree portfast options
  uplinkfast    Enable UplinkFast Feature
  vlan          VLAN Switch Spanning Tree

I do not see the option to change the mode of spanning-tree ? Is there any workaround or I have to upgradE  the IOS
Don JohnstonInstructor
Top Expert 2015

Commented:
You're running per vlan spanning-tree. If you were running CSTP (Common Spanning Tree Protocol) then it wouldn't matter. I your case, I suspect the provider is going to be an issue but we might as well eliminate all other variables first. Otherwise, that's the first thing they'll say when you contact them.
Instructor
Top Expert 2015
Commented:
You're running an older IOS that doesn't support rapid spanning-tree. You'll either have to upgrade the IOS or run 802.1d spanning-tree on the 4006.
Hi,
Whatever donjohnston said is true ,u need to check with your service provider also ,because mismatch wont work, spanning tree is very simple and effective concept to avoid loop but it gets complicated when your not configuring all your swithes and transapath switches. Cordinate with your service provider this problem can be resolved easyly.
1w3

Author

Commented:
I will have to try upgrading the 3550 IOS

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial