Having trouble configuring Cisco 881 G Router, not routing between VLAN

jffisher
jffisher used Ask the Experts™
on
Hello,
I am trying to get a Cisco 881G Router up and running and am having issues with the routing.
Most routers have a Serial interface and Ethernet LAN interface but not these routers. I setup the FE4 as my wan IP and it is working ok, I then setup a VLAN and assigned FE0 to it. DHCP is working on the LAN side. From the console port I can ping the internet and the LAN IP but from the LAN I can not get out. I am confused as what to set the LAN side default gateway to since the router does not have an LAN ethernet port? I have been using the VLAN IP as the default gateway for the LAN DHCP. I have IP routing enabled but the thing wont route traffic from one VLAN out the router.

One thing that is strange is that when I do a "show vlans" command it says no VLANs are configured but as you can see below, they are and I even has a port assigned to one.......
Building configuration...                         
 
Current configuration : 2072 bytes                                  
! 
version 12.4            
no service pad              
service timestamps debug datetime msec                                      
service timestamps log datetime msec                                    
service password-encryption                           
! 
hostname QUA_RTR_01                   
! 
boot-start-marker                 
boot-end-marker               
! 
logging message-counter syslog                              
no logging console                  
enable secret 5 $1$RatL$nPniMwdlksAe1PBRHfa4D1                                              
enable password 7 130815010803163A7C7378                                        
! 
no aaa new-model                
memory-size iomem 10                    
clock timezone EST -5                     
! 
! 
ip source-route               
! 
! 
ip dhcp excluded-address 10.150.255.0 10.150.255.99                                                   
! 
ip dhcp pool dpool1                   
   import all             
   network 10.150.255.0 255.255.255.0                                     
   dns-server 205.210.42.205                            
   default-router 10.1                    
! 
! 
ip cef      
no ip domain lookup                   
ip name-server 205.10.42.205                            
no ipv6 cef           
! 
! 
multilink bundle-name authenticated                                   
! 
! 
! 
! 
! 
archive       
 log config           
  hidekeys          
! 
! 
! 
! 
! 
interface FastEthernet0                       
 switchport access vlan 255                           
! 
interface FastEthernet1                       
 shutdown         
! 
interface FastEthernet2                       
 shutdown         
! 
interface FastEthernet3                       
 shutdown         
! 
interface FastEthernet4                       
 ip address 12.159.48.100 255.255.255.240                                         
 duplex auto            
 speed auto           
! 
interface Cellular0                   
 no ip address              
 encapsulation ppp                  
! 
interface Vlan1               
 no ip address              
 shutdown         
! 
interface Vlan2               
 no ip address              
! 
interface Vlan255                 
 ip address 10.150.255.1 255.255.255.0                                      
! 
ip default-gateway 12.159.48.100                                
ip forward-protocol nd                      
ip route 0.0.0.0 0.0.0.0 12.159.48.97                                     
no ip http server                 
no ip http secure-server                        
! 
! 
! 
! 
! 
! 
! 
! 
control-plane             
! 
! 
line con 0          
 password 7 000911150754191658761C                                  
 login      
 no modem enable                
line aux 0          
line 3      
 no exec        
 rxspeed 3100000                
 txspeed 1800000                
line 4      
 exec-timeout 0 0                 
 timeout login response 0                         
 privilege level 0                  
 modem answer-timeout 0                       
 modem dtr-delay 0                  
 activation-character 0                       
 exec-character-              
 special-character-bits 8
 no exec
 length 0
 width 0
 no history
 no editing
 transport preferred none
 transport input none
 transport output none
 escape-character soft 0
 escape-character 0
 no ip tcp input-coalesce-threshold
 callback forced-wait 0
 callback nodsr-wait 0
 stopbits 1
 speed 115000
line vty 0 4
 password 7 000911150754191658761C
 login
!
scheduler max-task-time 5000
end
 
QUA_RTR_01#
 
QUA_RTR_01#show int stat                        
Cellular0         
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out                                                                    
               Processor          0          0          0          0                                                                    
             Route cache          0          0          0          0                                                                    
                   Total          0          0          0          0                                                                    
FastEthernet0             
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out                                                                    
               Processor       8917     638857      10021     673326                                                                    
             Route cache          0          0          0          0                                                                    
                   Total       8917     638857      10021     673326                                                                    
Interface FastEther                  
 
Interface FastEthernet2 is disabled                                   
 
Interface FastEthernet3 is disabled                                   
 
FastEthernet4
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
               Processor       3913     562692       1186     377500
             Route cache          0          0        507      42002
                   Total       3913     562692       1693     419502
SSLVPN-VIF0
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
               Processor          0          0          0          0
             Route cache          0          0          0          0
                   Total          0          0          0          0
Interface Vlan1 is disabled
 
Vlan2
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
               Processor          0          0          0          0
             Route cache          0          0          0          0
                   Total          0          0          0          0
Vlan255
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
               Processor       7232     436646       7258     438082
             Route cache        507      42236          0          0
                   Total       7739     478882       7258     438082
QUA_RTR_01#
 
QUA_RTR_01#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
 
Gateway of last resort is 12.159.48.97 to network 0.0.0.0
 
     12.0.0.0/28 is subnetted, 1 subnets
C       12.159.48.96 is directly connected, FastEthernet4
S*   0.0.0.0/0 [1/0] via 12.159.48.97
QUA_RTR_01#

Open in new window

Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
have you tried creating vlan 255, you need to create it then apply it to the interface. also you might need to set fa0 to switchport

Author

Commented:
cosmicfox:
have you tried creating vlan 255, you need to create it then apply it to the interface. also you might need to set fa0 to switchport

Hi
Yes, created vlan 255, added F0 to vlan 255 but when I do a show vlans command it says no vlans are configured?
i'm not sure the 881 allows you create multiple vlan's. you can put your ip address on vlan 1 and remove the switchport access vlan 255 off of fa0 and it should work. Even though vlan 1 is bad practice, did you create vlan 2 or was it there by default, if it was on by default i would try and use vlan 2. are you using all four lan ports? if no then you should be able to put the ip on fa0 port and it should work.
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
Hi
I tried doing Vlan 1 already, same results, not routing out the router.
I did create vlan 2, I believe you can have many vlans with the 881.

I know this has to do something with the error message I get when I do a show vlans, it says no vlans configured when their are actually 6 as you can see in my "show int status" command.......... very strange.
a show int status doesn't give you any detail into vlan's if you create a interface for vlan 100 it will do nothing until you create the vlan. how are you trying to create the vlan?

Author

Commented:
config t
vlan xxx

Here is show vtp
VTP Version                     : 2
Configuration Revision          : 1
Maximum VLANs supported locally : 12
Number of existing VLANs        : 5
VTP Operating Mode              : Server
VTP Domain Name                 : cuautitlan
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x0C 0xF9 0x7E 0xC1 0x44 0x8E 0xFC 0x1E
Configuration last modified by 10.150.255.1 at 10-22-09 13:53:48
Local updater ID is 10.150.255.1 on interface Vl1 (lowest numbered VLAN interfac
e found)
that is very strange you vtp shows vlan's, but your show vlan doesn't. something isn't right as your show ip route should show the vlan 255 as connected. You might try and copy your config and wipe the router if you can. it also could be an ios bug.

Author

Commented:
I am beginning to think the same thing?

Here is the show vlans

QUA_RTR_01#show vlans

No Virtual LANs configured.

QUA_RTR_01#
what is your show version. see if there is a newer ios I'm thinking bug

Author

Commented:
Cisco IOS Software, C880 Software (C880DATA-UNIVERSALK9-M), Version 12.4(22)YB2
There is this bug. I would upgrade to the latest ios, you have a older image.
CSCse86912
VLAN switching broken
Symptoms: Packets are not switched.

Conditions: This symptom is observed when you configure a VLAN for Xconnect.

Workaround: There is no workaround.

Author

Commented:
Thanks, I will work on getting that image.
I have been doing some monitoring on my switches and have seen that the router is indeed forwarding the lan IP addresses but not getting replies. I am pretty sure I need to NAT the inside IP because the router is passing the LAN IP whcih of course can not be routed. Need to get the book out on setting up NAT.
i didn't even look to see if had a nat rule. i was to stuck on the vlan not showing up. you will need to setup nat below is a quick nat setup.

interface FastEthernet4                      
ip nat outside

interface Vlan255
ip nat inside


access-list 101 permit ip 10.150.255.0 0.0.0.255 any

ip nat inside source list 101 interface fa4 overload

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial