troubleshooting Question

Installing SOAP

Avatar of BarbaraW
BarbaraWFlag for Netherlands asked on
Web Languages and StandardsApache Web ServerLinux Distributions
3 Comments1 Solution1229 ViewsLast Modified:
This is driving me crazy...

I installed SOAP with "yum install php-soap" on my Linux CentOS 5.3, logged in as root, which put this in my php.ini:
-----------------
[soap]
; Enables or disables WSDL caching feature.
soap.wsdl_cache_enabled=1
; Sets the directory name where SOAP extension will put cache files.
soap.wsdl_cache_dir="/tmp"
; (time to live) Sets the number of second while cached file will be used
; instead of original one.
soap.wsdl_cache_ttl=86400
-----------------

Restarted the server, but no SOAP section in my phpinfo()...
http://kooistra.marketier4.net/info.php

Tried putting
extension=soap.so
in the php.ini and restarting.

Still no SOAP in phpinfo()...

Did
updatedb
and
find /usr/ -name *soap*

-------------------------
/usr/share/psa-horde/lib/Horde/RPC/soap.php
find: /usr/include/php/include: No such file or directory
find: /usr/lib/php/pear: No such file or directory
-------------------------

So, no php_soap.so on the server.

What am I doing wrong?? My client is in a hurry with the website and I really don't know anymore :(

Can I download php_soap.so somewhere and just put it on the server, or doesn't that work either?

Thanks,
Barbara
ASKER CERTIFIED SOLUTION
LinuxGuru
Linux Server Administrator

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Join our community to see this answer!
Unlock 1 Answer and 3 Comments.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 3 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros