AD Connectivity Test failed because GUID DNS name could not be resolved

XFERCOM
XFERCOM used Ask the Experts™
on
AD Connectivity Test failed because GUID DNS name could not be resolved
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2012
Commented:
Please post ipconfig /all. Make sure you are only pointing to internal DNS servers.

Author

Commented:
this is what it shows. We have external DNS addresses configured on the nic also.
C:\Documents and Settings\Administrator>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : LOVTOUCHDC
   Primary Dns Suffix  . . . . . . . : LOVINGTOUCH.local
   Node Type . . . . . . . . . . . . : Unknown
   IP Routing Enabled. . . . . . . . : Yes
   WINS Proxy Enabled. . . . . . . . : Yes
   DNS Suffix Search List. . . . . . : LOVINGTOUCH.local

Ethernet adapter Network Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Network Connection
   Physical Address. . . . . . . . . : 00-15-17-8D-8D-80
   DHCP Enabled. . . . . . . . . . . : No
   IP Address. . . . . . . . . . . . : 192.168.2.2
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   IP Address. . . . . . . . . . . . : fe80::215:17ff:fe8d:8d80%4
   Default Gateway . . . . . . . . . : 192.168.2.200
   DNS Servers . . . . . . . . . . . : 68.87.77.130
                                       68.87.72.130
                                       fec0:0:0:ffff::1%2
                                       fec0:0:0:ffff::2%2
                                       fec0:0:0:ffff::3%2

Ethernet adapter Server Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) 82566DM-2 Gigabit Network Connec
tion
   Physical Address. . . . . . . . . : 00-15-17-8D-8D-82
   DHCP Enabled. . . . . . . . . . . : No
   IP Address. . . . . . . . . . . . : 192.168.2.3
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   IP Address. . . . . . . . . . . . : fe80::215:17ff:fe8d:8d82%5
   Default Gateway . . . . . . . . . : 192.168.2.200
   DNS Servers . . . . . . . . . . . : 68.87.77.130
                                       192.168.2.3
                                       68.87.72.130
                                       fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1
   Primary WINS Server . . . . . . . : 192.168.2.3
   NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter Automatic Tunneling Pseudo-Interface:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Automatic Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : C0-A8-02-02
   DHCP Enabled. . . . . . . . . . . : No
   IP Address. . . . . . . . . . . . : fe80::5efe:192.168.2.2%2
   Default Gateway . . . . . . . . . :
   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%2
                                       fec0:0:0:ffff::2%2
                                       fec0:0:0:ffff::3%2
   NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter Automatic Tunneling Pseudo-Interface:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Automatic Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : C0-A8-02-03
   DHCP Enabled. . . . . . . . . . . : No
   IP Address. . . . . . . . . . . . : fe80::5efe:192.168.2.3%2
   Default Gateway . . . . . . . . . :
   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1
   NetBIOS over Tcpip. . . . . . . . : Disabled

C:\Documents and Settings\Administrator>
DrDave242Principal Support Engineer
Commented:
The external DNS servers are probably the cause.  Remove those, flush the resolver cache with "ipconfig /flushdns," and try again.
CompTIA Network+

Prepare for the CompTIA Network+ exam by learning how to troubleshoot, configure, and manage both wired and wireless networks.

Author

Commented:
pull the external dns and they cant get out to internet. it is handled here.
DrDave242Principal Support Engineer
Commented:
You should be using either DNS forwarders or root hints on the DNS servers for Internet name resolution.  That allows your clients to use only internal servers to resolve everything, which is the way it should be in an Active Directory domain.
Top Expert 2012
Commented:
Disable IPv6 as well run ipconfig /flushdns, ipconfig /registerdns, and netdiag /fix.
Commented:
Run Dcdiag, dcdiag /v, dcdiag /fix, dcdiag /q, dncmd /clearcache.
It will register the srv records again.
Rename netlogon.dnb & netlogon.dns to old & restart netlogon & dns service in dns server.
Netlogon.dnb & netlogon.dns can be found by typing config in run.
Run setspn -r servername
Run ipconfig /flushdns & ipconfig /registerdns.

It will refresh all the records of dns & GUID wil be registered again.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial