troubleshooting Question

Windows Vista Network and Services Failure

Avatar of robiche
robiche asked on
Windows OSMicrosoft Legacy OSWindows Vista
7 Comments1 Solution1293 ViewsLast Modified:
Hi all,

I have run into an issue that has me completely baffled.  I have a Dell Latitude D830 laptop running Windows Vista Ultimate with Service Pack 1.  A couple weeks ago, I suspended the machine and put it aside.  I went to use it the other day, and the battery had died while on standby.  I plugged it in and powered it up.

It took an amazingly long time to boot up (about 10 minutes), while most of the time it was after the Windows "logging in.." screen had gone away, and it was just a black screen with a mouse cursor -- nothing else.  I waited until explorer was finally up, and a couple of error windows appeared:
The first was from "SecureUpgrade" (part of the Dell security suite) -- the error said: "The TCP/IP Protocol is not installed properly"
The second was from tcsd_win32.ext - i.e. "... has stopped working"

I thought it was a bit odd to get those errors but didn't think about it much more -- until I tried to open a web browser, and noticed that I had no network connectivity.  I first tried to go to properties of Network Places -- the status of the network was: "Unknown: The dependency service or group failed to start".  So, of course, I next went to the services console and noticed that all of the networking services were stopped..  Attempted to start them.  Here are the errors starting each:
 - DNS Client -- Failed: "Error 10107: A system call that should never fail has failed"
 - Function Discovery Resource Publication -- Failed: "Error 0x8007277b: A system call that should never fail has failed"
 - IKE and AuthIP IPsec Keying Modules -- Failed: "Erro 1364: A specified authentication package is unknown"
- IPsec Policy Agent -- Failed: "Error 10107: A system call that should never fail has failed"
- Netlogon -- Failed: "Error 10093: Either the application has not called WSAStartup, or WSAStartup failed"
and so on and so forth..

So, I decided that Event Viewer would be a good place to check what was going on.  Went there, and got the error, "Event Log service is unavailable.  Verify that the service is running."

So, I went back to services, and sure enough, the service is not running.  Tried to start the Windows Event Log Service -- Failed: "Error 1747: The authentication service is unknown"

So now at this point, no network services are running, and I have no way of viewing the Event Log to see what is failing.  I decide to run a CHKDSK with a surface scan to see if there was hard disk corruption causing the problem..  It needed to reboot to run, so I let it.  It ran through for a few hours, and reported no errors.

Went back into Windows, and decided maybe using the setup media I could run an in-place upgrade/repair.  Tried to run setup.exe on the disk and choose Install -- get error: "Windows could not load required file WinSetup.dll.  The file may be corrupt.  To install windows, restart the installation.  Error code 0x45A".

Well, the file isn't corrupt, because I tried the DVD on another Vista machine, and it works fine there.

I then rebooted the machine with the DVD, and went into the Vista repair option.  It ran for an hour or so going through its checks, and then reported (and I"m summarizing):
 - One item found, "a windows configuration file may have been changed.  Use a system restore point to repair"

Ok, go back into Windows and attempt to recover a system restore point.  Unfortunately, no system restore points are listed to choose from -- fantastic.

So, I thought (thinking in a Windows XP mindset) that maybe I could reapply SP1, and perhaps any corrupted files / configurations would be overwritten.  Well, Vista doesn't work that way: "Error: Service Pack 1 is already installed".  And then it exits.

So, I thought maybe I could apply Vista SP2.  Put it on a DVD and tried to run it.  It went through it's hour long process, step 1, 2 and 3.  Looked like everything went well, rebooted like 8 times during the process and so on.  Finally reboots back to Windows, and I get a Windows Setup error popup: "Error 0x00000000: Installation failed"

Awesome.

So that's where I am at this point.  No way to view the errors, and doesn't seem any way to repair them given any of the horrendous repair options on Vista.  Anyone have any thoughts?

Thanks.
ASKER CERTIFIED SOLUTION
robiche

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Join our community to see this answer!
Unlock 1 Answer and 7 Comments.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 7 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros