uninstall previous versions of .NET Framework

dan_peterson
dan_peterson used Ask the Experts™
on
I have a server running out of disk space on the OS/boot C drive. Can I uninstall the older versions of .NET framework? These are the versions listed in add/remove programs:
Microsoft .NET Framework 2.0 Service Pack 2
Microsoft .NET Framework 3.0 Service Pack 2
Microsoft .NET Framework 3.5 SP1

Is it safe to remove 2.0 and 3.0 and leave 3.5?

This is a Windows Server 2003 running SQL2005 and IIS.

Thanks.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
3.0 and 2.0 are basically the same as 3.5...i.e. 3.5 has everything in it need to run 2.0 and 3.0 programs...but you should definitely keep 1.1

Author

Commented:
1.1 isn't listed as installed on my machine.

Commented:
also read over this forum...

http://forum.soft32.com/windows/NET-Framework-ftopict385573.html

it explains it in better detail...
CompTIA Security+

Learn the essential functions of CompTIA Security+, which establishes the core knowledge required of any cybersecurity role and leads professionals into intermediate-level cybersecurity jobs.

Commented:
then that means you're not running any 1.1 developed projects and don't need it...
Have to disagree with silemone on this one.
.net 3.5 and 3.0 are extensions.  3.0 depends on 2.0, and 3.5 depends upon both 2.0 and 3.5.

1.1 should be safe to install, but if you're running anything on 3.5, you need to keep all 3 versions.

Here's a couple links explaining:

http://social.msdn.microsoft.com/Forums/en-US/netfxsetup/thread/b70bac17-94c9-4e7a-bef6-dd12189f1d52
http://stackoverflow.com/questions/385893/safe-to-uninstall-net-framework-2-0-and-1-0-after-installing-3-5

Author

Commented:
Thanks

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial