Cisco ASA site-to-site VPN not functioning

nevesis
nevesis used Ask the Experts™
on
Have an ASA 5505 in a central office, providing firewall and VPN server for remote access IPsec clients via Radius authentication.

Installed an ASA 5505 in a remote location today and was unable to successfully configure site-to-site.

The original preshared key was something#. After removing the pound symbol, the VPN light on the remote device activated and the tunnel was recognized on both devices, however I was still unable to pass data through via ping.

Attached are both configurations. Any help would be greatly appreciated!
=================Central Office========================
 
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 10.0.0.154 255.255.255.248 
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
boot system disk0:/asa804-23-k8.bin
ftp mode passive
dns domain-lookup inside
dns domain-lookup outside
dns server-group DefaultDNS
 name-server 192.168.1.5
 domain-name domain.local
access-list outside_access_in extended permit tcp any host 10.0.0.155 eq https 
access-list outside_access_in extended permit icmp any any echo-reply 
access-list outside_access_in extended permit icmp any any time-exceeded 
access-list inbound_access_in extended permit ip 192.168.1.0 255.255.255.0 any 
access-list inside_access_in extended permit ip 192.168.1.0 255.255.255.0 any 
access-list MyCompany_splitTunnelAcl standard permit any 
access-list inside_nat0_outbound extended permit ip any 172.16.1.0 255.255.255.224 
access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 172.16.1.0 255.255.255.224 
access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0 
access-list inside_nat0_outbound extended permit ip any 192.168.2.0 255.255.255.0 
access-list MyCompany_splitTunnelAcl_1 standard permit 192.168.1.0 255.255.255.0 
access-list DefaultRAGroup_splitTunnelAcl standard permit 192.168.1.0 255.255.255.0 
pager lines 24
logging enable
logging timestamp
logging trap informational
logging asdm informational
logging host inside 192.168.1.9
mtu inside 1500
mtu outside 1500
ip local pool VPN 172.16.1.1-172.16.1.25 mask 255.255.255.0
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-61557.bin
asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) 10.0.0.155 192.168.1.5 netmask 255.255.255.255 
static (inside,outside) 10.0.0.156 192.168.1.9 netmask 255.255.255.255 
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 10.0.0.153 1
timeout xlate 3:00:00
timeout conn 8:00:00 half-closed 4:00:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
aaa-server AuthInbound protocol radius
aaa-server AuthInbound (inside) host 192.168.1.5
 timeout 20
 key r@diu5
 authentication-port 9999
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set TRANS_ESP_3DES_SHA esp-3des esp-sha-hmac 
crypto ipsec transform-set TRANS_ESP_3DES_SHA mode transport
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map outside_dyn_map 20 set pfs 
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 20 set security-association lifetime seconds 28800
crypto dynamic-map outside_dyn_map 20 set security-association lifetime kilobytes 4608000
crypto map outside_map 1 set pfs 
crypto map outside_map 1 set peer 127.0.0.10 
crypto map outside_map 1 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp identity address 
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp ipsec-over-tcp port 10001 
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
 
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
 enable outside
 svc image disk0:/anyconnect-win-2.2.0136-k9.pkg 1
 svc enable
group-policy DefaultRAGroup internal
group-policy DefaultRAGroup attributes
 wins-server value 192.168.1.5
 dns-server value 192.168.1.5
 vpn-tunnel-protocol l2tp-ipsec svc webvpn
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value DefaultRAGroup_splitTunnelAcl
 webvpn
  svc ask none default svc
group-policy DfltGrpPolicy attributes
 vpn-filter value inbound_access_in
 vpn-tunnel-protocol IPSec l2tp-ipsec svc webvpn
 webvpn
  svc ask none default svc
group-policy MyCompany internal
group-policy MyCompany attributes
 wins-server value 192.168.1.5 192.168.1.9
 dns-server value 192.168.1.5 192.168.1.9
 vpn-tunnel-protocol IPSec l2tp-ipsec svc webvpn
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value MyCompany_splitTunnelAcl_1
 address-pools value VPN
 webvpn
  svc ask none default svc
tunnel-group DefaultRAGroup general-attributes
 address-pool VPN
 authentication-server-group AuthInbound
 default-group-policy DefaultRAGroup
tunnel-group DefaultRAGroup ipsec-attributes
 pre-shared-key *
 peer-id-validate nocheck
tunnel-group DefaultRAGroup ppp-attributes
 authentication ms-chap-v2
tunnel-group DefaultWEBVPNGroup general-attributes
 address-pool VPN
 authentication-server-group AuthInbound
tunnel-group MyCompany type remote-access
tunnel-group MyCompany general-attributes
 address-pool VPN
 authentication-server-group AuthInbound
 authorization-server-group AuthInbound
 default-group-policy MyCompany
tunnel-group MyCompany webvpn-attributes
 radius-reject-message
tunnel-group MyCompany ipsec-attributes
 pre-shared-key *
tunnel-group cfgwebvpn type remote-access
tunnel-group cfgwebvpn general-attributes
 address-pool VPN
 authentication-server-group AuthInbound
tunnel-group 127.0.0.10 type ipsec-l2l
tunnel-group 127.0.0.10 ipsec-attributes
 pre-shared-key *
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect sqlnet 
  inspect skinny  
  inspect sunrpc 
  inspect xdmcp 
  inspect sip  
  inspect netbios 
  inspect tftp 
!
service-policy global_policy global
prompt hostname context 
Cryptochecksum:914789ca448724bb808e8d4de79ee0e6
: end
asdm image disk0:/asdm-61557.bin
asdm history enable
 
 
=================Remote Office========================
 
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.2.1 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 127.0.0.10 255.255.255.248 
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
same-security-traffic permit intra-interface
access-list outside_1_cryptomap extended permit ip 192.168.2.0 255.255.255.0 192.168.1.0 255.255.255.0 
access-list inside_nat_outbound extended permit ip any any 
access-list inside_nat0_outbound extended permit ip 192.168.2.0 255.255.255.0 192.168.1.0 255.255.255.0 
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
nat-control
global (inside) 1 interface
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 access-list inside_nat_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 127.0.0.9 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 inside
http 192.168.2.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs 
crypto map outside_map 1 set peer 10.0.0.154 
crypto map outside_map 1 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp ipsec-over-tcp port 10001 
telnet 192.168.2.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.2.2-192.168.2.33 inside
dhcpd dns 192.168.1.5 interface inside
dhcpd wins 192.168.1.5 interface inside
dhcpd enable inside
!
 
group-policy DfltGrpPolicy attributes
 banner none
 wins-server none
 dns-server none
 dhcp-network-scope none
 vpn-access-hours none
 vpn-simultaneous-logins 3
 vpn-idle-timeout 30
 vpn-session-timeout none
 vpn-filter none
 vpn-tunnel-protocol IPSec 
 password-storage disable
 ip-comp disable
 re-xauth disable
 group-lock none
 pfs disable
 ipsec-udp disable
 ipsec-udp-port 10000
 split-tunnel-policy tunnelall
 split-tunnel-network-list none
 default-domain none
 split-dns none
 intercept-dhcp 255.255.255.255 disable
 secure-unit-authentication disable
 user-authentication disable
 user-authentication-idle-timeout 30
 ip-phone-bypass disable
 leap-bypass disable
 nem disable
 backup-servers keep-client-config
 msie-proxy server none
 msie-proxy method no-modify
 msie-proxy except-list none
 msie-proxy local-bypass disable
 nac disable
 nac-sq-period 300
 nac-reval-period 36000
 nac-default-acl none
 address-pools none
 smartcard-removal-disconnect enable
 client-firewall none
 client-access-rule none
 webvpn
  functions url-entry
  html-content-filter none
  homepage none
  keep-alive-ignore 4
  http-comp gzip
  filter none
  url-list none
  customization value DfltCustomization
  port-forward none
  port-forward-name value Application Access
  sso-server none
  deny-message value Login was successful, but because certain criteria have not been met or due to some specific group policy, you do not have permission to use any of the VPN features. Contact your IT administrator for more information
  svc none
  svc keep-installer installed
  svc keepalive none
  svc rekey time none
  svc rekey method none
  svc dpd-interval client none
  svc dpd-interval gateway none
  svc compression deflate
tunnel-group 10.0.0.154 type ipsec-l2l
tunnel-group 10.0.0.154 ipsec-attributes
 pre-shared-key *
tunnel-group-map default-group 10.0.0.154
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny 
  inspect sunrpc 
  inspect xdmcp 
  inspect sip 
  inspect netbios 
  inspect tftp 
!
service-policy global_policy global
prompt hostname context 
Cryptochecksum:d35dd7c59bf8127b5d551daa29f86638
: end
asdm image disk0:/asdm-524.bin
no asdm history enable

Open in new window

Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Jody LemoineNetwork Architect
Commented:
On the central office ASA, you're missing:

access-list outside_1_cryptomap extended permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0
crypto map outside_map 1 match address outside_1_cryptomap

Without an access-list an a match statement for the crypto map, the first ASA doesn't know which traffic to send over the VPN.

I've only had a brief moment to have a look and have to run, but everything else looks good at first glance.  Try adding the above and see if everything comes up.  If it doesn't, let me know and I'll have a closer look when I get back in.

Author

Commented:
Added, wrote, reloaded... no luck!

I actually did have the access-list in the config previously.
Jody LemoineNetwork Architect

Commented:
Ah, okay.  They weren't in the copy that you posted.  Can you post another copy of the configurations as they are now?
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
Remote office hasn't changed, here is the local office with the updates:


!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 10.0.0.154 255.255.255.248 
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
boot system disk0:/asa804-23-k8.bin
ftp mode passive
dns domain-lookup inside
dns domain-lookup outside
dns server-group DefaultDNS
 name-server 192.168.1.5
access-list outside_access_in extended permit tcp any host 10.0.0.155 eq https 
access-list outside_access_in extended permit icmp any any echo-reply 
access-list outside_access_in extended permit icmp any any time-exceeded 
access-list inbound_access_in extended permit ip 192.168.1.0 255.255.255.0 any 
access-list inside_access_in extended permit ip 192.168.1.0 255.255.255.0 any 
access-list MyCompany_splitTunnelAcl standard permit any 
access-list inside_nat0_outbound extended permit ip any 172.16.1.0 255.255.255.224 
access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 172.16.1.0 255.255.255.224 
access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0 
access-list inside_nat0_outbound extended permit ip any 192.168.2.0 255.255.255.0 
access-list MyCompany_splitTunnelAcl_1 standard permit 192.168.1.0 255.255.255.0 
access-list DefaultRAGroup_splitTunnelAcl standard permit 192.168.1.0 255.255.255.0 
access-list outside_1_cryptomap extended permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0 
pager lines 24
logging enable
logging timestamp
logging trap informational
logging asdm informational
logging host inside 192.168.1.9
mtu inside 1500
mtu outside 1500
ip local pool VPN 172.16.1.1-172.16.1.25 mask 255.255.255.0
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-61557.bin
asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) 10.0.0.155 192.168.1.5 netmask 255.255.255.255 
static (inside,outside) 10.0.0.156 192.168.1.9 netmask 255.255.255.255 
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 10.0.0.153 1
timeout xlate 3:00:00
timeout conn 8:00:00 half-closed 4:00:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
aaa-server AuthInbound protocol radius
aaa-server AuthInbound (inside) host 192.168.1.5
 timeout 20
 key r@diu5
 authentication-port 9999
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set TRANS_ESP_3DES_SHA esp-3des esp-sha-hmac 
crypto ipsec transform-set TRANS_ESP_3DES_SHA mode transport
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map outside_dyn_map 20 set pfs 
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 20 set security-association lifetime seconds 28800
crypto dynamic-map outside_dyn_map 20 set security-association lifetime kilobytes 4608000
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs 
crypto map outside_map 1 set peer 127.0.0.10 
crypto map outside_map 1 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp identity address 
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp ipsec-over-tcp port 10001 
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
 
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
 enable outside
 svc image disk0:/anyconnect-win-2.2.0136-k9.pkg 1
 svc enable
group-policy DefaultRAGroup internal
group-policy DefaultRAGroup attributes
 wins-server value 192.168.1.5
 dns-server value 192.168.1.5
 vpn-tunnel-protocol l2tp-ipsec svc webvpn
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value DefaultRAGroup_splitTunnelAcl
 webvpn
  svc ask none default svc
group-policy DfltGrpPolicy attributes
 vpn-filter value inbound_access_in
 vpn-tunnel-protocol IPSec l2tp-ipsec svc webvpn
 webvpn
  svc ask none default svc
group-policy MyCompany internal
group-policy MyCompany attributes
 wins-server value 192.168.1.5 192.168.1.9
 dns-server value 192.168.1.5 192.168.1.9
 vpn-tunnel-protocol IPSec l2tp-ipsec svc webvpn
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value MyCompany_splitTunnelAcl_1
 address-pools value VPN
 webvpn
  svc ask none default svc
username administrator password 3RlFF.7FSMhUZLkw encrypted
tunnel-group DefaultRAGroup general-attributes
 address-pool VPN
 authentication-server-group AuthInbound
 default-group-policy DefaultRAGroup
tunnel-group DefaultRAGroup ipsec-attributes
 pre-shared-key *
 peer-id-validate nocheck
tunnel-group DefaultRAGroup ppp-attributes
 authentication ms-chap-v2
tunnel-group DefaultWEBVPNGroup general-attributes
 address-pool VPN
 authentication-server-group AuthInbound
tunnel-group MyCompany type remote-access
tunnel-group MyCompany general-attributes
 address-pool VPN
 authentication-server-group AuthInbound
 authorization-server-group AuthInbound
 default-group-policy MyCompany
tunnel-group MyCompany webvpn-attributes
 radius-reject-message
tunnel-group MyCompany ipsec-attributes
 pre-shared-key *
tunnel-group cfgwebvpn type remote-access
tunnel-group cfgwebvpn general-attributes
 address-pool VPN
 authentication-server-group AuthInbound
tunnel-group 127.0.0.10 type ipsec-l2l
tunnel-group 127.0.0.10 ipsec-attributes
 pre-shared-key *
 peer-id-validate nocheck
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect sqlnet 
  inspect skinny  
  inspect sunrpc 
  inspect xdmcp 
  inspect sip  
  inspect netbios 
  inspect tftp 
!
service-policy global_policy global
prompt hostname context 
Cryptochecksum:bed21aa63e875258c734d45382f7b126
: end
asdm image disk0:/asdm-61557.bin
asdm history enable

Open in new window

Commented:
also helpful to see what happens during IPsec sa negotiations:

debug crypto isakmp 127
debug crypto ipsec    127

these commands will show exactly what is happening during tunnel SA formation, whether it be mismatched access lists, pre-shared secrets, rekey attempts and will make troubleshooting easier

Author

Commented:
It passes phase 1 and 2 and sends keep alives. When Remote Office sends interesting traffic to Central Office, the rx count on the tunnel at Central Office increases. However, that interesting traffic doesn't make it through... and the tx count on Central Office is stuck at 0.

Commented:
this is usually due to you access lists, for both interesting traffic and nat0
check both peers to make sure that these lists are identical in syntax i.e one peer should not have network objects and the other peer have numerical ip's in the acl statements. I have seen this many times casing your situation

While network object groups simplify the config, I have found in issues like yours the asa likes numerical network and subnet numbers. This issue had been posted by cisco as a known problem
Commented:
try temporarily removing this:

access-list inside_nat0_outbound extended permit ip any 192.168.2.0 255.255.255.0

might be conflicting with:
 access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0

if still not working, then temporarily try removing split-tunnel lists

Author

Commented:
removed the access-list above.. I actually added that trouble shooting...

I'm looking into the split tunnels now.

Will update asap --- thank you!

Commented:
remember to do the same on both peers, so the access lists are mirrors of each other

Author

Commented:
Gave them both matching group policies consisting of nothing but:

split-tunnel-policy tunnelall
vpn-tunnel-protocol IPSec

No change..

Author

Commented:
Reloaded and it all works. Must have been group policies?

Author

Commented:
Trouble shooting assistance.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial