Embarcadero C++ Builder 2010

Giampete
Giampete used Ask the Experts™
on
Have the following message when I run an *.exe file on a machine other than mine.

" This application has failed to start because rtl140.bpl was no found. Re-installing the application may fix this problem."

Am trying to run the executable file on its own;  the file is not that large , therefore I would want it to be stand alone.   Appreciate some Help
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
evilrixSenior Software Engineer (Avast)

Commented:
I don't use Builder 2010 but, it looks like this exe has a dependency on rtl140.bpl, which, I would guess, is a Borland runtime library. You need to ensure this library is also present.
Commented:
CBuilder defaults to use dynamic linking to the support libraries and all the component packages as well.

To make a stand alone exe you need to change two settings in the project's options.  Open options and look on the 'C++ Linker page',  you will see Dynamic RTL defaulted to true,  change that to false.

Then down farther on the 'Packages' page there is a checkbox 'Build with runtime packages',  uncheck that one.  

Now fully rebuild the project and you will see the exe file is going to be quite a bit larger. A basic program is typically ~ 1 mb when linked this way.

Of course it is also possible to just copy the needed bpl files into either the same directory as the exe or into a searchable path so your program can find them.  The default install puts the bpl files into c:\windows\system32 when you install CBuilder.

These settings are universal to all releases of CBuilder.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial