Cannot access sharepoint site from sharepoint server

cegeland
cegeland used Ask the Experts™
on
Hi!
I'm can't access my sharepoint site from the sharepoint server itself, but accessing from other workstations in the network is no problem.

I've created a standard "Alternate access mapping" for https://sharepoint.domain.com. I've created a local DNS A host record on the DNS server (which is also the sharepoint server) pointing to the server ip adress.

When try to open the URL mentioned above in a browser on the server I get a "Internet Explorer cannot display the webpage, It appears you are connected to the Internet, but you might want to try to reconnect to the Internet." When I do the same thing on a workstation the sharepoint site appears.

The result of a nslookup on the server reveals that "sharepoint.domain.com" points to the ip adress of the server.

Why am I not able to access the site from the server? This problem also causes my search crawl to fail.

Any suggestions ? :)
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Are you sure you don't have duplicate A records for your sharepoint.domain.com?  Do you have multiple IPs tagged on your NIC that could be interfering?  What about any other 80/443 sites running on that box?
Also, do you have anonymous allowed on your site?  Try logging in with a domain user ID on the server instead of an admin account and see what happens.
Top Expert 2010

Commented:
sounds like a possible loopback issue.
see here:
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/MS-SharePoint/Q_24417941.html

similar thing happened to me a few months ago after a windows update ;)
Become a Microsoft Certified Solutions Expert

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

Author

Commented:
Thanks for all your suggestions. Here's what I've checked:
1. I did not find any duplicate DNS A host records for "sharepoint.domain.com"
2. I do have multiple IPs on the NIC. The web site running Sharepoint in IIS is set to respond to the "sharepoint.domain.com" IP only. I also have "mysite.domain.com" running on the same server with a different IP, and this site is accessible from both the server and workstations.
3. "sharepoint.domain.com" is assigned port 443 on the IP assigned to "sharepoint.domain.com" (192.168.1.10). Port 443 is also assigned to the IP assigned to "mysite.domain.com" (192.168.1.11). Neither of the web sites listen to requests made to other IPs (All unassigned NOT selected).
4. Anonymous login is disabled.
5. Tried logging in with a standard domain user account - same error. Sharepoint is also accessible for all authenticated users on any workstation - as mentioned the only issue is access from the server itself
6. I've checked the registry and found that the DisableLoopbackCheck DWORD value was already added.

Author

Commented:
Forgot to add - running Windows 2003 Server R2 with MOSS 2007. Workstations are running Vista Business SP2.
Did you ever try logging into your server with a "domain user" account instead of your admin account?

Author

Commented:
Yes, I tried a standard domain user.. same thing happens.

I also tried changing adding a new IP for the sharepoint web site (192.168.1.14) and assigning port 443. I also updated the DNS A record for "sharepoint.domain.com" (pointing it to 192.168.1.14). Sharepoint is still accessible from workstations, but not from server.

The funny thing is that the "https://mysite.domain.com" works perfectly from the server. I would have expected the same error as when browsing to "https://sharepoint.domain.com" since they are both on the same server?

Author

Commented:
Update: I tried assigning the sharepoint web site an alternate access mapping, https://servername/, and I am then able to access the site from both the server and workstation.

However, this does not solve my search crawl problem which is the main reason for accessing the sharepoint site from the server. What could be causing this "incompatibility" with the "sharepoing.domain.com" domain?

Author

Commented:
Another update:

When I do a nslookup on both "sharepoint.domain.com" and "mysite.domain.com" I get the correct, local, IP adress.

When I try to ping "mysite.domain.com" I get a reply from the local IP adress, but when I ping "sharepoint.domain.com" I get a reply from 127.0.0.1 (localhost) instead of 192.168.1.14 that nslookup resolved to. Could this be the cause of my problems?
Commented:
The "sharepoint.domain.com" had an entry in the c:\windows\system32\drivers\hosts file pointing to localhost - removed the entry and now I am able to access the site from the server. Search crawl still fails - I've created a new question in the correct EE section.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial