Exchange 2003 Not Found The requested URL /exchange was not found on this server.  Apache/1.3.29 Server at www.xxxxxx.edu Port 443

tweakgames
tweakgames used Ask the Experts™
on
I have been trying to get our exchange server to finally pass all the security metrics tests, but now no body is able to access their mail off site through the web.  

They get the error =

Not Found
The requested URL /exchange was not found on this server.

Apache/1.3.29 Server at www.xxxxxxxxxxl.edu Port 443

I have done a lot of things like turning off old ssl 2.0 and ciphers in the registry, but I backed up the old registry before I started.  I imported the backup, but it say that some of them did not work because they were being used or overwritten.  

Any ideas or tips?

I have a feeling that this process might have caused this issue.  

I did this recently.

Option 1: Set the UseHostName property
To set the UseHostName property, follow these steps:
Click Start, click Run, type cmd, and then click OK to open a command prompt.
Change to the folder where the Adsutil.vbs tool is located. By default, this folder is the following:
%SYSTEMROOT%\Inetpub\AdminScripts
Type the following command, where x is your site identifier:
cscript adsutil.vbs set w3svc/x/UseHostName true


My site identifier was 1.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
It looks like you have Apache Web server running.  If you are using Exchange OWA, then it runs on IIS.  I think you have an Apache Web Server running on a server that should just be running IIS.

Either that, or I don't understand your question/error message.

Author

Commented:
Its ok.  I know it sounds complicated.  

Right now..... our exchange server is not working.  I disabled low bit encryption, did the process above where I reset the UseHostName ....  and now it isnt workin on OWA, or outlook.   I am very confused.  I tried to put the registry back the way it was... but I think that might have been a bad idea, as I did some windows updates after the backup registry.  

Author

Commented:
For some reason the MTA and information store service were not started.  :(   I think its time to a reinstall using exchange 2007... instead of 2003.  
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
The OWA IS working with the local IP address from inside the network, but not from outside the network.  Any tips on that?
Commented:
You need to summarize what you have now.  I'm not quite sure where you are at.  Did you go to 2007?  or 2003?

Are you hitting owa with ssl or just port 80?  If you are using Exchange 2007, the would have to configure an inside and outside name for the owa site.  

What error do you get from outside of the network?  Is everything working properly on your firewall?

If you have apache running on the same server as exchange, then you have to make sure the websites are all on different ports.  Either that or you need to check into the port forwarding on your firewall because it may be using the same public IP to forward to another internal server running apache.

Author

Commented:
I'm sorry for not keeping this up to date. I had someone run a program, it fixed it somehow, I remounted it, and it works.  We are going to get rid of this server, and go to 2010 asap.  

Thanks.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial