Original Firmware Required for WRT54G

samipk
samipk used Ask the Experts™
on
I posted a question way back and installed DDWRT on my router now i want to revert back as the wireless is causing me problems...i followed the guide in the below question  to install

http://www.experts-exchange.com/Hardware/Networking_Hardware/Routers/Q_23741121.html

but i forgot one crutial question to ask and that was where do i get the original firmware from cause i have lost it....i went to the Cisco site but it offers me Versions 6 8 and 8.1 whereas i have v7.2

how do i revert back to the original firmware as i dont want to brick the router...please show me the steps and give me the link to the original as i want to be sure i have the correct firmware
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Which version are you looking for.

That is quite easy to opload once you find it.



Anyway. What is your problem after the update?? I might help you with that and keep newest firmware on the router.

Best

Mike

Author

Commented:
well i have WRT54G v7.2 and i was looking for the original firmware which is required in the restore process

as for the problem it is that the internet on the wireless connections works for 10 15 minutes and after that internet stops working although wireless is working and connection is still established....when i connect the dsl modem directly to the pc internet starts working....this problem occurs on my leptop, iphone, and pc so its definitely a router problem
1. Are ALL those 3 devices working on the Wireless?? or maybe one of the has cable connection??

If all 3 are wireless then you should try changing the wireless channel and wireless security Option.

You should try between WPA, WPA2, WPA/WPA2

2. What is your security now? wep? wpa?

3. Are you using MAC filtering or any unusual or custom settings.

4. Have you tried to change your Wireless network name and reconnect from all 3 computers?

Best

Michael
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!


Hi again

Here you have the firmware

http://www.dd-wrt.com/wiki/index.php/Linksys_WRT54GS_v7.0_%26_7.2

Here you might find your solution

http://forums.linksysbycisco.com/linksys/board/message?board.id=Wireless_Routers&thread.id=105572

You could still answer my questions if you cant fix it.

Best

Mike

Author

Commented:
1. Yes all those devices working on wireless, i have changed the Channel from Auto to 10. 2.457 GHZ and changed the security from WPA to WPA-2 Personal
2. WPA-2 Personal
3. Yesi am using mac filtering
4. I have changed the router name also

I will try and see for a day what happens now if its still a problem i will drop a comment here...i too want to fix this issue rather then removing DDWRT
WPA2 is very strong protection.

You probably dont need Mac Filtering when WPA2 is used.

You could try disabling MAC filtering if you still have problems on WPA2.

Best

Michael

Author

Commented:
i am still having problems and i will try to remove the mac filter now and try to see if the problem still persists
Hi

After that you could also try different channels. Try channel 1.

I would also try changing the name of your wireless network and reconnecting from all computers (that clears old settings and problems)

Changes and playing like that might seem funny to you but this is the way to go and troubleshoot most of the wifi toys.

Best

Mike

Author

Commented:
well i have tried everything but its just not working for me...i have to remove dd-wrt and revert to the original firmware now...i went to the link that you provided for the original firmware but its a ddwrt page and i cant find the original linksys firmware required to remove dd-wrt...can you give me the exact link to it??
Off topic comment, with respects and some frustration..
samipk, Limited Member<< I've taken to watching the amount of abandoned questions with limited accounts that we participate in.
It's growing at an alarming rate so much I think it is becoming the norm.
points is not the goal here...
it's the volunteering to these questions that have been left with no further responses..
I see 7.2.01 listed on the
http://www.linksysbycisco.com/MEA/en/support/WRT54G/download
page.
Direct link
http://downloads.linksysbycisco.com/downloads/firmware/FW_WRT54Gv7.2_7.2.01.007_EN_20090727.bin

DO NOT UPLOAD THAT FILE STRAIGHT TO YOUR ROUTER USING THE DD-WRT INTERFACE!

v7.2 falls in the range of WRT54G's that take a few steps to revert.
First, download
ftp://dd-wrt.com/others/eko/WRT54G-V72%20Flashing/VxWorksRevert-Gv72-v3.bin

Be sure to do a hard reset (see http://www.experts-exchange.com/viewArticle.jsp?aid=373), and unplug all cables except the single connection to one LAN port which you'll use to apply the original firmware.
Upload that VxWorksRevert file using the Administration->Firmware Upgrade tab in DD-WRT.  When it finishes it will say to reboot - DO NOT REBOOT YET - wait a good 2 minutes (I would give it 5 minutes just to be sure), then reboot it by cycling the power off and on (just unplugging the power supply from the back for 5 seconds and plugging it back in should be fine).

When it finishes rebooting, connect to 192.168.1.1 and you should be at a management mode screen. NOW browse to the original v7.2 firmware file downloaded from linksysbycisco.com and upload that. Again, when it says it's done, give it a couple more minutes (or 5 more, to be safe), then reboot the router again by cycling the power.

Surf to 192.168.1.1 and you should have the original v7.2 Linksys firmware loaded.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial