Unable to edit MS Office Documents within Sharepoint 2007

ejg398
ejg398 used Ask the Experts™
on
A user has full control over a document library but when they select a document to edit, the option to open in read only or edit is not shown. The user has to select "Edit with Microsoft Excel"(or word depending on the type of doc) from the drop down menu. The program opens with the download progress dialog box, but goes no further. At times after about 10 min the document will open but in "read only". No other users are having this issue. I have uninstalled sharepoint service support tools from office and reinstalled them. The user is using Office 2003.
Any suggestions is appreciated.

thanks
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Does that user have any other Microsoft Office products installed from a different version? Like something from Office 2007?

Sharepoint uses the owssupp.dll file from the Office installation and IE can have some problems if there are multiple versions of the file installed. Typically you'd delete the version from the office installation you're not using.

So if you use Office 2003 mostly but have only Visio 2007, you'd want to keep the owssupp.dll file in the C:\Program Files\Microsoft Office\Office11 but delete the one in the Office12 folder.

Author

Commented:
The user has no other versions of office installed and there are no other instances of the dll present. I have tried to copy the owssupp.dll from my machine to the users machine to see if that would help but to no avail. I have also installed Office 2003 sp3, now it hangs when user is just opening any MS office documents. I installed FireFox browser and the MS Office docs will open now but still cannot edit any MS documents  unless the user downloads the doc to the computer then uploads the doc back to the sharepoint 07 library. The user has Office 03 standard installed at this time but has had Pro. thank you for your response I am stumped and I cannot find anything in my research that will help, but will keep trying. Any suggestions is greatly appreciated.
Commented:
The problem has been solved. On our network we have a device called TopLayer. It was blocking requests so that users could not edit documents. Our server admin need to modify two of the rules in order to all these packets through. What had led me to this is a problem with SharePoint Behind Cisco CSS Load Balancer. ( http://blogs.msdn.com/vsofficedeveloper/pages/SharePoint-Cisco-CSS-Switch-Issue.aspx )

We do not have this device on our network but we do have the TopLayer. Our Server Admin modified a couple of rules to allow packets through the device and now the users are able to open and edit the Microsoft documents.  Not sure if anyone else is having these problems, but if they are hopfully this information can help in trouble shooting.

thank you all for your input and suggestions.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial